Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-10-07 20:30:33

Xinnitus
Member
Registered: 2020-10-07
Posts: 4

[Resolved] Terminal problems after upgrading Xubuntu to 20.04

Hi,
The Xubuntu 20.04 Release displays a terminal for two or three seconds after the lightdm session.
Then the software system resumes executing in a normal manner.
I would like the pop up terminal to go away.
Thanks very much for your help,
D.B.

N.B.:
$ uname -a
Linux SATELLITE-C70D-B 5.4.0-48-generic #52-Ubuntu SMP Thu Sep 10 10:58:49 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Hardware:
Toshiba SATELLITE-C70D-B

Last edited by Xinnitus (2020-10-09 11:12:20)

Offline

#2 2020-10-07 21:36:27

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,119

Re: [Resolved] Terminal problems after upgrading Xubuntu to 20.04

Hello and welcome.

Perhaps its something in your autostart. What does the following return:

ls -l ~/.config/autostart

...and:

fgrep -ri term ~/.config/autostart

Can you also post back the contents of your ~/.xsession-errors file after a fresh login?

Last edited by ToZ (2020-10-07 21:47:54)

Offline

#3 2020-10-08 09:07:09

Xinnitus
Member
Registered: 2020-10-07
Posts: 4

Re: [Resolved] Terminal problems after upgrading Xubuntu to 20.04

Hi,
Thanks for your answer.
Here is some Information:

$ ls -l ~/.config/autostart
total 4
-rw-rw-r-- 1 dominique dominique 1868 sept. 30 00:10 redshift-gtk.desktop


$ fgrep -ri term ~/.config/autostart
/home/dominique/.config/autostart/redshift-gtk.desktop:Terminal=false


~$ cat ~/.xsession-errors
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/dominique/.Xauthority
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting XDG_CONFIG_DIRS=/etc/xdg/xdg-xubuntu:/etc/xdg
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
dbus-update-activation-environment: setting CLUTTER_BACKEND=x11
dbus-update-activation-environment: setting LANGUAGE=fr_FR
dbus-update-activation-environment: setting MANDATORY_PATH=/usr/share/gconf/xubuntu.mandatory.path
dbus-update-activation-environment: setting DESKTOP_SESSION=xubuntu
dbus-update-activation-environment: setting PWD=/home/dominique
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=xubuntu
dbus-update-activation-environment: setting LOGNAME=dominique
dbus-update-activation-environment: setting QT_QPA_PLATFORMTHEME=gtk2
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting XAUTHORITY=/home/dominique/.Xauthority
dbus-update-activation-environment: setting XDG_GREETER_DATA_DIR=/var/lib/lightdm-data/dominique
dbus-update-activation-environment: setting GDM_LANG=fr_FR
dbus-update-activation-environment: setting HOME=/home/dominique
dbus-update-activation-environment: setting IM_CONFIG_PHASE=1
dbus-update-activation-environment: setting LANG=fr_FR.UTF-8
dbus-update-activation-environment: setting XDG_CURRENT_DESKTOP=XFCE
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting XDG_SESSION_CLASS=user
dbus-update-activation-environment: setting GTK_OVERLAY_SCROLLING=0
dbus-update-activation-environment: setting DEFAULTS_PATH=/usr/share/gconf/xubuntu.default.path
dbus-update-activation-environment: setting USER=dominique
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting SHLVL=1
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/xubuntu:/usr/share/xfce4:/usr/local/share:/usr/share:/var/lib/snapd/desktop
dbus-update-activation-environment: setting PATH=/home/dominique/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
dbus-update-activation-environment: setting GDMSESSION=xubuntu
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting _=/usr/bin/dbus-update-activation-environment
/usr/bin/iceauth:  creating new authority file /run/user/1000/ICEauthority
xfwm4-Message: 10:51:51.207: Prefer XPresent with AMD KABINI (DRM 2.50.0, 5.4.0-48-generic, LLVM 10.0.0)
Tracker-Message: 10:51:53.758: Set scheduler policy to SCHED_IDLE
Tracker-Message: 10:51:53.758: Setting priority nice level to 19

(tracker-miner-fs:1918): Tracker-CRITICAL **: 10:51:53.995: Could not request DBus name 'org.freedesktop.Tracker1.Miner.Files': D-Bus service name:'org.freedesktop.Tracker1.Miner.Files' is already taken, perhaps the application is already running?
Tracker-Message: 10:51:54.053: Set scheduler policy to SCHED_IDLE
Tracker-Message: 10:51:54.054: Setting priority nice level to 19

(xfce4-session:1531): xfce4-session-WARNING **: 10:51:54.980: Unable to launch "light-locker" (specified by autostart/light-locker.desktop): L’exécution du processus fils « light-locker » a échoué (Aucun fichier ou dossier de ce type)

(polkit-gnome-authentication-agent-1:1933): GLib-CRITICAL **: 10:51:55.135: g_variant_new_string: assertion 'string != NULL' failed

(polkit-gnome-authentication-agent-1:1933): polkit-gnome-1-WARNING **: 10:51:55.137: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (wrapper-2.0:1889): WARNING **: 10:51:55.294: No outputs have backlight property

(nm-applet:1970): Gtk-WARNING **: 10:51:55.524: Can't set a parent on widget which has a parent

(nm-applet:1970): Gdk-CRITICAL **: 10:51:55.946: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed

(wrapper-2.0:1889): Gtk-WARNING **: 10:51:56.126: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PowerManagerButton)

(nm-applet:1970): Gtk-CRITICAL **: 10:51:56.466: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:1970): Gtk-CRITICAL **: 10:51:56.466: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed
[/home/dominique/.config/pulse/client.conf:2] Missing '='.

(nm-applet:1970): Gtk-WARNING **: 10:51:56.526: Can't set a parent on widget which has a parent

(wrapper-2.0:1888): GLib-GIO-CRITICAL **: 10:51:56.537: g_file_new_for_path: assertion 'path != NULL' failed

(wrapper-2.0:1888): GLib-GIO-CRITICAL **: 10:51:56.537: g_file_monitor_file: assertion 'G_IS_FILE (file)' failed

(wrapper-2.0:1888): GLib-GObject-WARNING **: 10:51:56.537: invalid (NULL) pointer instance

(wrapper-2.0:1888): GLib-GObject-CRITICAL **: 10:51:56.537: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(wrapper-2.0:1888): Gtk-WARNING **: 10:51:56.537: Attempting to add a widget with type GtkToggleButton to a container of type XfcePanelPlugin, but the widget is already inside a container of type XfcePanelPlugin, please remove the widget from its existing container first.

(nm-applet:1970): Gtk-CRITICAL **: 10:51:56.576: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:1970): Gtk-CRITICAL **: 10:51:56.576: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(wrapper-2.0:1888): Gtk-WARNING **: 10:51:56.582: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)

(wrapper-2.0:1890): Gtk-WARNING **: 10:51:56.623: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PulseaudioButton)

(nm-applet:1970): Gtk-WARNING **: 10:51:56.634: Can't set a parent on widget which has a parent

(wrapper-2.0:1884): Gtk-WARNING **: 10:51:56.673: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)
[/home/dominique/.config/pulse/client.conf:2] Missing '='.

** (xfce4-screensaver:2037): WARNING **: 10:51:57.997: économiseur d’écran déjà lancé dans cette session
[/home/dominique/.config/pulse/client.conf:2] Missing '='.
[/home/dominique/.config/pulse/client.conf:2] Missing '='.
blueman-applet 10.52.01 WARNING  PluginManager:147 __load_plugin: Not loading DhcpClient because its conflict has higher priority
blueman-applet 10.52.01 WARNING  PluginManager:147 __load_plugin: Not loading PPPSupport because its conflict has higher priority

(blueman-tray:2073): Gdk-CRITICAL **: 10:52:02.803: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed

** (zeitgeist-datahub:2047): WARNING **: 10:52:07.249: zeitgeist-datahub.vala:227: Unable to get name "org.gnome.zeitgeist.datahub" on the bus!



Ciao,
D.B.

Offline

#4 2020-10-08 10:45:57

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,119

Re: [Resolved] Terminal problems after upgrading Xubuntu to 20.04

A couple of things to try:

1. Try deleting the sessions cache. While not logged in (Ctrl+Alt+F2), delete the contents of the ~/.cache/sessions folder.

2. Try creating a secondary user account on your system and logging into that to see if the problem persists. This will help determine if its specific to your login or a system problem.

Offline

#5 2020-10-08 15:47:29

Xinnitus
Member
Registered: 2020-10-07
Posts: 4

Re: [Resolved] Terminal problems after upgrading Xubuntu to 20.04

Hi,
The second user session works normally.

I copied .cache in .cache_backup then .cache_backup in .cache.
Final result: ~/.cache/.cache_backup$
I restarted Xubuntu and all is ok.

I found this in ~/.cache/sessions:
Client6_CloneCommand=xfce4-terminal
Client6_RestartCommand=xfce4-terminal,--geometry=80x24,--display,:0.0,--role=xfce4-terminal-1580340483--3747612,--show-menubar,--show-borders,--hide-toolbar,--active-tab,--working-directory,/home/dominique,--window,--geometry=80x24,--display,:0.0,--role=xfce4-terminal-1588593752--1971286045,--show-menubar,--show-borders,--hide-toolbar,--active-tab,--working-directory,/home/dominique,--sm-client-id,2135e0212-f1d7-49f3-b882-68d4890ad29d

Was it the problem?

ciao,
D.B.

Last edited by Xinnitus (2020-10-08 15:53:42)

Offline

#6 2020-10-08 16:56:29

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,119

Re: [Resolved] Terminal problems after upgrading Xubuntu to 20.04

Xinnitus wrote:

I found this in ~/.cache/sessions:
Client6_CloneCommand=xfce4-terminal
Client6_RestartCommand=xfce4-terminal,--geometry=80x24,--display,:0.0,--role=xfce4-terminal-1580340483--3747612,--show-menubar,--show-borders,--hide-toolbar,--active-tab,--working-directory,/home/dominique,--window,--geometry=80x24,--display,:0.0,--role=xfce4-terminal-1588593752--1971286045,--show-menubar,--show-borders,--hide-toolbar,--active-tab,--working-directory,/home/dominique,--sm-client-id,2135e0212-f1d7-49f3-b882-68d4890ad29d

Was it the problem?

Yes. A previous terminal session was saved and was restarting.

Offline

#7 2020-10-08 21:24:25

Xinnitus
Member
Registered: 2020-10-07
Posts: 4

Re: [Resolved] Terminal problems after upgrading Xubuntu to 20.04

Hi,
Thanks very much for all.
Bye,
D.B.

Offline

Board footer

Powered by FluxBB