Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-03-25 01:43:00

golinux
Member
Registered: 2011-11-19
Posts: 120

Clearlooks-Phenix again

Greetings all . . .

I have gotten together the theme for the next Devuan release - Beowulf - and hoping that you can help me with one minor glitch.  Once again I have used Clearlooks-Phenix as a base.  The code in Beowulf/Buster is identical to the version in Stretch/ASCII so this issue was also present in the last theme but more critical here because the current hilight color is darker.  This is the problem which also happens in Catfish (and probably elsewhere):

black-on-dark.png

You can see that the gtk isn't picking up the selected-foreground-color.  I have gone through every instance of that selector and even tried changing it to #ffffff in places but in a few circumstances, the text remains black.   I know that gtk-3 is a moving target but I'm hoping you might be able to help me find a way to fix it because you have been so helpful in the past.

I have posted all the pieces of that theme HERE.  There are also screenshots is that thread.

Happy hunting!

PS.  I also have an issue after the last updates with not being able to choose a wallpaper from any location from the desktop settings or from the file or from drag and drop..  Will search here, check with Devuan specific changes and post if I can't find an answer.

Offline

#2 2019-03-25 02:32:02

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,650

Re: Clearlooks-Phenix again

You can see that the gtk isn't picking up the selected-foreground-color.

At the end of your menu section (line 1590 of gtk-widgets.css) add the following snippet:

combobox menuitem:hover > cellview * {
	color:white;
}

...that grabs the ones in catfish and engrampa.

PS.  I also have an issue after the last updates with not being able to choose a wallpaper from any location from the desktop settings or from the file or from drag and drop..  Will search here, check with Devuan specific changes and post if I can't find an answer.

Maybe this is related to the change where you have to select a folder first and then the contents of that folder will be displayed and then you select the image you want to use. Are you running into the issue where you can't select any folders?

Offline

#3 2019-03-25 04:47:53

golinux
Member
Registered: 2011-11-19
Posts: 120

Re: Clearlooks-Phenix again

ToZ wrote:

You can see that the gtk isn't picking up the selected-foreground-color.

At the end of your menu section (line 1590 of gtk-widgets.css) add the following snippet:

combobox menuitem:hover > cellview * {
	color:white;
}

...that grabs the ones in catfish and engrampa.

It does indeed.  Thank you, THANK YOU!

PS.  I also have an issue after the last updates with not being able to choose a wallpaper from any location from the desktop settings or from the file or from drag and drop..  Will search here, check with Devuan specific changes and post if I can't find an answer.

Maybe this is related to the change where you have to select a folder first and then the contents of that folder will be displayed and then you select the image you want to use. Are you running into the issue where you can't select any folders?

There are no images populated by any of the choices.  I think it is session-related because I lost the custom "Applications" icon on  on the panel too.  We have forked quite a few pkgs relating to session management and I suspect they missed something.  This thread seems to nibble around the problem.  I have passed that to the devs who maintain those packages.  Will update here when I get a response.  But I suspect it's a Devuan-specific thing.

Offline

#4 2019-03-25 19:15:59

golinux
Member
Registered: 2011-11-19
Posts: 120

Re: Clearlooks-Phenix again

ToZ wrote:
golinux wrote:

PS.  I also have an issue after the last updates with not being able to choose a wallpaper from any location from the desktop settings or from the file or from drag and drop..  Will search here, check with Devuan specific changes and post if I can't find an answer.

Are you running into the issue where you can't select any folders?

Just rereading your comments.  Yes.  Selecting the options does nothing.  No images appear and there is no navigation to even get to them.  Correction . . . "other" does produce a file tree but all the options are grayed out and unselectable.  Maybe it's not on Devuan's end . . .

Last edited by golinux (2019-03-25 19:20:34)

Offline

#5 2019-03-25 19:42:00

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,650

Re: Clearlooks-Phenix again

Can you post a screenshot?

Offline

#6 2019-03-25 20:19:17

golinux
Member
Registered: 2011-11-19
Posts: 120

Re: Clearlooks-Phenix again

ToZ wrote:

Can you post a screenshot?

How about 2.  First one is from selecting "Backgrounds" the second is from selecting the "Other" menu.  It won't load the files no matter where I put them.
bg-direct.png

no-bg-options.png

Grrrrr . . .

Offline

#7 2019-03-25 20:43:49

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,650

Re: Clearlooks-Phenix again

What version of xfdesktop are you using? There is an old bug that did this, that was fixed. I'll see if I can find it.

Edit: This bug fixed for 4.12.4.

Last edited by ToZ (2019-03-25 20:53:21)

Offline

#8 2019-03-25 22:10:54

golinux
Member
Registered: 2011-11-19
Posts: 120

Re: Clearlooks-Phenix again

ToZ wrote:

What version of xfdesktop are you using? There is an old bug that did this, that was fixed. I'll see if I can find it.

Edit: This bug fixed for 4.12.4.

This is what's in the repos and installed:

    [beowulf] xfdesktop4-4.12.4-2
    [beowulf] xfdesktop4-data-4.12.4-2
    [ceres] xfdesktop4-4.12.4-2
    [ceres] xfdesktop4-data-4.12.4-2

It was broken after these upgrades on Mar 23.  None of those pkgs has been forked by Devuan. I had done a bigger upgrade on the 18th but the desktop background was still there after that:

Commit Log for Sat Mar 23 17:42:39 2019

Installed the following packages:
gftp (2.0.19-5)
gftp-common (2.0.19-5)
gftp-gtk (2.0.19-5)
gftp-text (2.0.19-5)


Commit Log for Sat Mar 23 17:41:47 2019

Upgraded the following packages:
libpython3.7-minimal (3.7.2-3) to 3.7.3~rc1-1
libpython3.7-stdlib (3.7.2-3) to 3.7.3~rc1-1
libsndfile1 (1.0.28-5) to 1.0.28-6
python-apt-common (1.8.3) to 1.8.4
python3-apt (1.8.3) to 1.8.4
python3.7 (3.7.2-3) to 3.7.3~rc1-1
python3.7-minimal (3.7.2-3) to 3.7.3~rc1-1


Commit Log for Sat Mar 23 17:40:13 2019

Upgraded the following packages:
libcairo-gobject2 (1.16.0-3) to 1.16.0-4
libcairo2 (1.16.0-3) to 1.16.0-4
libgdbm-compat4 (1.18.1-3) to 1.18.1-4
libgdbm6 (1.18.1-3) to 1.18.1-4
libpam-gnome-keyring (3.28.2-2) to 3.28.2-5


Commit Log for Sat Mar 23 17:39:26 2019

Upgraded the following packages:
fonts-liberation2 (2.00.4-1) to 2.00.5-1
gdbm-l10n (1.18.1-3) to 1.18.1-4
gnome-keyring (3.28.2-2) to 3.28.2-5
gnome-keyring-pkcs11 (3.28.2-2) to 3.28.2-5
grub-common (2.02+dfsg1-12) to 2.02+dfsg1-13
grub-pc (2.02+dfsg1-12) to 2.02+dfsg1-13
grub-pc-bin (2.02+dfsg1-12) to 2.02+dfsg1-13
grub2-common (2.02+dfsg1-12) to 2.02+dfsg1-13


Commit Log for Sat Mar 23 17:38:33 2019

Upgraded the following packages:
libmailutils5 (1:3.5-2) to 1:3.5-3
lsb-base (10.2018112800) to 10.2019031300
lsb-release (10.2018112800) to 10.2019031300
mailutils (1:3.5-2) to 1:3.5-3
mailutils-common (1:3.5-2) to 1:3.5-3

Last edited by golinux (2019-03-25 22:15:12)

Offline

#9 2019-03-25 22:50:18

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,650

Re: Clearlooks-Phenix again

From your previous screenshots, where you are in the xfce folder and there are greyed out image files, wat happens if you click on the "Open" button?  Does it populate the contents in Desktop>Background tab with the files that are shown in the xfce folder?

Offline

#10 2019-03-25 23:12:55

golinux
Member
Registered: 2011-11-19
Posts: 120

Re: Clearlooks-Phenix again

Bingo!  Yes that populated the images!!  Why have they made it so difficult to access background images?  (rhetorical question)  Surely the Xfce devs don't want to make things this difficult.  The other options should work also.

Last edited by golinux (2019-03-25 23:14:01)

Offline

#11 2019-03-25 23:27:54

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,650

Re: Clearlooks-Phenix again

The whole desktop settings screen was redesigned to work this way. It is different from the previous method. You can also set wallpaper by using the "Set as Wallpaper" context menu entry in Thunar.

Offline

#12 2019-03-26 01:28:03

golinux
Member
Registered: 2011-11-19
Posts: 120

Re: Clearlooks-Phenix again

ToZ wrote:

The whole desktop settings screen was redesigned to work this way. It is different from the previous method. You can also set wallpaper by using the "Set as Wallpaper" context menu entry in Thunar.

From my initial description:

I also have an issue after the last updates with not being able to choose a wallpaper from any location from the desktop settings or from the file or from drag and drop.

None of the options I have previously used were working.  I am seeing some dbus errors in the logs which could be coming from some of the changes we made.  I may drop some of that here when I get around to looking more carefully.

Offline

#13 2021-03-28 21:21:29

golinux
Member
Registered: 2011-11-19
Posts: 120

Re: Clearlooks-Phenix again

Here we go again . . . nearly 2 years after you fixed the unreadable font issue, someone discovered a glitch in selection rendering on chimaera (bullseye) but I also found that it is present on cinnabar (buster).  I didn't notice because I never use the icon view option and never thought to check. The hilighting works as expected in list view.

In icon view, when selecting a group of icons, the visual selection indicator is opaque not transparent and uses the theme_base_color #DFEAF2:
no transparency

When the mouse is released, the selected items are marked properly:
icons marked properly

Note that this defect was not present in ASCII (stretch):
stretch was fine

I imagine it's somewhere in the gtk-widgets.css. I couldn't find it but have no doubt you can figure this out.

Thanks again . . .

Last edited by golinux (2021-03-28 21:22:15)

Offline

#14 2021-03-28 21:51:29

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,650

Re: Clearlooks-Phenix again

Starting line 158 of gtk-widgets,css, add a ".thunar .rubberband" statement:

.rubberband,
.thunar .rubberband,
view rubberband,
rubberband {
	background-color: alpha (@theme_selected_bg_color, 0.35);
	border-color: @theme_selected_bg_color;
	border-style: solid;
	border-width: 1px;
	border-radius: 2px;
}

Offline

#15 2021-03-28 23:36:40

golinux
Member
Registered: 2011-11-19
Posts: 120

Re: Clearlooks-Phenix again

Thank you!  THANK YOU!!  Works perfectly!!!

Offline

#16 2021-03-29 01:26:23

fsmithred
Member
Registered: 2019-07-06
Posts: 6

Re: Clearlooks-Phenix again

ToZ wrote:

Starting line 158 of gtk-widgets,css, add a ".thunar .rubberband" statement:

.rubberband,
.thunar .rubberband,
view rubberband,
rubberband {
	background-color: alpha (@theme_selected_bg_color, 0.35);
	border-color: @theme_selected_bg_color;
	border-style: solid;
	border-width: 1px;
	border-radius: 2px;
}

I need clarification on this. Should this entire stanza be added, so that there are two rubberband sections, or should the '.thunar .rubberband,' line be inserted into the existing rubberband section? Thanks.

fsmithred

Offline

#17 2021-03-29 01:30:04

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,650

Re: Clearlooks-Phenix again

Its odd that thunar isn't respecting the existing rubberband settings. It must be overwritten somewhere else but I couldn't find it. This is the simplest solution.

If you are using the Clearlook-Phenix theme, then all you need to add is ".thunar .rubberband," to the existing stanza.

Offline

#18 2021-03-29 02:07:18

fsmithred
Member
Registered: 2019-07-06
Posts: 6

Re: Clearlooks-Phenix again

Wow, thanks for the quick response. It's working in thunar with that one line added. The other part of this is that it's not working in caja in mate desktop. (I guess we need to be asking some mate devs about that.)

I tried adding a line that says ".caja .rubberband," but it did not fix the problem.

Offline

#19 2021-03-29 02:38:47

golinux
Member
Registered: 2011-11-19
Posts: 120

Re: Clearlooks-Phenix again

Should a bug report be filed about this?  And is the bug in the clearlooks-phenix theme or in thunar or ???  Someone on Mate had to roll some of the GTK-3 files back to the jessie version to get it working properly.  There may or may not be a better way.

Last edited by golinux (2021-03-29 02:39:54)

Offline

#20 2021-03-29 10:59:58

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,650

Re: Clearlooks-Phenix again

Had a deeper look. Instead of adding ".thunar .rubberband", add ".view .rubberband" - this should extend to the other file managers as well. The section should be:

.rubberband,
.view .rubberband,
view rubberband,
rubberband {
	background-color: alpha (@theme_selected_bg_color, 0.35);
	border-color: @theme_selected_bg_color;
	border-style: solid;
	border-width: 1px;
	border-radius: 2px;
}

Offline

#21 2021-03-29 14:49:29

fsmithred
Member
Registered: 2019-07-06
Posts: 6

Re: Clearlooks-Phenix again

ToZ wrote:

Had a deeper look. Instead of adding ".thunar .rubberband", add ".view .rubberband" - this should extend to the other file managers as well. The section should be:

.rubberband,
.view .rubberband,
view rubberband,
rubberband {
	background-color: alpha (@theme_selected_bg_color, 0.35);
	border-color: @theme_selected_bg_color;
	border-style: solid;
	border-width: 1px;
	border-radius: 2px;
}

Confirmed. This fixes it in xfce (thunar) and mate (caja).

Many thanks!

Offline

#22 2021-03-29 16:54:39

golinux
Member
Registered: 2011-11-19
Posts: 120

Re: Clearlooks-Phenix again

Indeed.  Magic happened while I had a good snooze.  Thanks to all who sorted this.

Offline

Board footer

Powered by FluxBB