Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-08-08 04:05:24

SteveM
Member
Registered: 2021-06-12
Posts: 7

Window/panel all transparent xfce

I was overwhelmed with messages coming in while trying to work with 3 computers. My laptop has Linuxmint xfce on it. I set the transparency sliders wrong and now all my windows/panels are invisible.

I tried logging in with a live USB and thought I found a couple of the settings. But the live usb looks more like Cinnamon than XFCE.

What can I do to make my panels and windows visible again?

Offline

#2 2021-08-08 11:37:02

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,040

Re: Window/panel all transparent xfce

Right-click where the panel should be and you should see a context menu pop up. Select Panel > Panel Properties, and on the "Appearance" tab, set the Enter and leave opacity values to 100.

To make the panel transparent (assuming versions 4.14 or 4.16), on the Appearance tab change Background Color to Solid Color, click on the color box, create a custom color and you should see a transparency slider at the bottom of the screen.

Offline

#3 2021-08-08 13:26:32

SteveM
Member
Registered: 2021-06-12
Posts: 7

Re: Window/panel all transparent xfce

Right-clicking isn't bringing up a menu, unless it's invisible too.

Offline

#4 2021-08-08 16:13:57

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,040

Re: Window/panel all transparent xfce

Is the panel running?

ps -ef | grep xfce4-panel

Can you post back all of your panel settings:

xfconf-query -c xfce4-panel -lv

Offline

#5 2021-08-08 16:49:25

SteveM
Member
Registered: 2021-06-12
Posts: 7

Re: Window/panel all transparent xfce

steve@steve-HP-Pavilion-dv6-Notebook-PC:~$ ps -ef | grep xfce4-panel
steve       1718    1388  1 10:26 ?        00:00:07 xfce4-panel
steve       3352    3277  0 10:38 pts/0    00:00:00 grep --color=auto xfce4-panel
steve@steve-HP-Pavilion-dv6-Notebook-PC:~$ xfconfg-query -c xfce4-panel -lv

Command 'xfconfg-query' not found, did you mean:

  command 'xfconf-query' from deb xfconf (4.14.1-1)

Try: sudo apt install <deb name>

steve@steve-HP-Pavilion-dv6-Notebook-PC:~$ xfconf-query -c xfce4-panel -lv
/configver                                    2
/panels                                       <<UNSUPPORTED>>
/panels/panel-1/background-alpha              95
/panels/panel-1/background-image              /home/steve/Pictures/backgrounds/anders-jilden-uwbajDCODj4-unsplash.jpg
/panels/panel-1/background-style              0
/panels/panel-1/enter-opacity                 100
/panels/panel-1/icon-size                     0
/panels/panel-1/leave-opacity                 100
/panels/panel-1/length                        100
/panels/panel-1/length-adjust                 true
/panels/panel-1/mode                          0
/panels/panel-1/output-name                   Primary
/panels/panel-1/plugin-ids                    <<UNSUPPORTED>>
/panels/panel-1/position                      p=8;x=640;y=706
/panels/panel-1/position-locked               true
/panels/panel-1/size                          35
/plugins/plugin-1                             applicationsmenu
/plugins/plugin-10                            battery
/plugins/plugin-11                            separator
/plugins/plugin-11/style                      0
/plugins/plugin-12                            xapp-status-plugin
/plugins/plugin-12/enable-keyboard-shortcuts  true
/plugins/plugin-12/enable-mpris               true
/plugins/plugin-12/mixer-command              pavucontrol
/plugins/plugin-12/show-notifications         false
/plugins/plugin-13                            separator
/plugins/plugin-13/digital-format             %H:%M
/plugins/plugin-13/style                      0
/plugins/plugin-14                            xapp-status-plugin
/plugins/plugin-16                            pulseaudio
/plugins/plugin-16/enable-keyboard-shortcuts  true
/plugins/plugin-16/mpris-players              firefox.instance1868;firefox.instance1961;firefox.instance2164;firefox.instance2203;firefox.instance2208;firefox.instance3268;firefox.instance3690;firefox.instance7489;io.github.celluloid_player.Celluloid.instance-1;vlc
/plugins/plugin-1/button-icon                 linuxmint-logo-simple
/plugins/plugin-1/button-title               
/plugins/plugin-1/show-button-title           false
/plugins/plugin-2                             tasklist
/plugins/plugin-3                             separator
/plugins/plugin-3/expand                      true
/plugins/plugin-3/items                       <<UNSUPPORTED>>
/plugins/plugin-3/style                       0
/plugins/plugin-4                             launcher
/plugins/plugin-4/items                       <<UNSUPPORTED>>
/plugins/plugin-5                             separator
/plugins/plugin-5/items                       <<UNSUPPORTED>>
/plugins/plugin-5/style                       0
/plugins/plugin-6                             systray
/plugins/plugin-6/known-items                 <<UNSUPPORTED>>
/plugins/plugin-6/known-legacy-items          <<UNSUPPORTED>>
/plugins/plugin-6/middle-click                1
/plugins/plugin-6/names-ordered               <<UNSUPPORTED>>
/plugins/plugin-6/show-frame                  false
/plugins/plugin-6/show-handle                 false
/plugins/plugin-6/square-icons                true
/plugins/plugin-7                             clock
/plugins/plugin-7/digital-format              %a %d %b,%r
/plugins/plugin-7/expand                      true
/plugins/plugin-7/mode                        2
/plugins/plugin-7/style                       0
/plugins/plugin-8                             systray
/plugins/plugin-8/names-visible               <<UNSUPPORTED>>
/plugins/plugin-8/show-frame                  false
/plugins/plugin-9                             xapp-status-plugin

Offline

#6 2021-08-08 17:34:14

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,040

Re: Window/panel all transparent xfce

Try running the following command:

xfconf-query -c xfce4-panel -p /panels/panel-1/background-alpha -s 50

...and restart the panel:

xfce4-panel -r

Does this make it visible again?

If not, what version of Mint are you running?

Offline

#7 2021-08-08 17:59:37

SteveM
Member
Registered: 2021-06-12
Posts: 7

Re: Window/panel all transparent xfce

That didn't do anything. This is Linuxmint 20.2 Uma xfce4

Offline

#8 2021-08-08 18:16:50

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,040

Re: Window/panel all transparent xfce

Lets look at the window manager:

xfconf-query -c xfwm4 -lv

We're looking to see if the frame, inactive, move, popup, and resize_opacity values are closer to 100 than 0.

Offline

#9 2021-08-08 19:17:11

SteveM
Member
Registered: 2021-06-12
Posts: 7

Re: Window/panel all transparent xfce

Doesn't look to me like they are close to 100

$ xfconf-query -c xfwm4 -lv
/general/activate_action                 bring
/general/borderless_maximize             true
/general/box_move                        false
/general/box_resize                      false
/general/button_layout                   O|SHMC
/general/button_offset                   0
/general/button_spacing                  0
/general/click_to_focus                  true
/general/cycle_apps_only                 false
/general/cycle_draw_frame                true
/general/cycle_hidden                    true
/general/cycle_minimized                 false
/general/cycle_minimum                   true
/general/cycle_preview                   false
/general/cycle_raise                     false
/general/cycle_tabwin_mode               0
/general/cycle_workspaces                false
/general/double_click_action             maximize
/general/double_click_distance           5
/general/double_click_time               250
/general/easy_click                      Alt
/general/focus_delay                     250
/general/focus_hint                      true
/general/focus_new                       true
/general/frame_border_top                0
/general/frame_opacity                   0
/general/full_width_title                true
/general/horiz_scroll_opacity            false
/general/inactive_opacity                5
/general/margin_bottom                   0
/general/margin_left                     0
/general/margin_right                    0
/general/margin_top                      0
/general/maximized_offset                0
/general/mousewheel_rollup               true
/general/move_opacity                    5
/general/placement_mode                  center
/general/placement_ratio                 20
/general/popup_opacity                   3
/general/prevent_focus_stealing          false
/general/raise_delay                     250
/general/raise_on_click                  true
/general/raise_on_focus                  false
/general/raise_with_any_button           true
/general/repeat_urgent_blink             false
/general/resize_opacity                  6
/general/restore_on_move                 true
/general/scroll_workspaces               true
/general/shadow_delta_height             0
/general/shadow_delta_width              0
/general/shadow_delta_x                  0
/general/shadow_delta_y                  -3
/general/shadow_opacity                  50
/general/show_app_icon                   false
/general/show_dock_shadow                true
/general/show_frame_shadow               false
/general/show_popup_shadow               false
/general/snap_resist                     false
/general/snap_to_border                  true
/general/snap_to_windows                 false
/general/snap_width                      10
/general/theme                           Daloa
/general/tile_on_move                    true
/general/title_alignment                 center
/general/title_font                      Sans Bold 9
/general/title_horizontal_offset         0
/general/titleless_maximize              false
/general/title_shadow_active             false
/general/title_shadow_inactive           false
/general/title_vertical_offset_active    0
/general/title_vertical_offset_inactive  0
/general/toggle_workspaces               false
/general/unredirect_overlays             true
/general/urgent_blink                    false
/general/use_compositing                 true
/general/vblank_mode                     auto
/general/workspace_count                 4
/general/workspace_names                 <<UNSUPPORTED>>
/general/wrap_cycle                      true
/general/wrap_layout                     true
/general/wrap_resistance                 5
/general/wrap_windows                    true
/general/wrap_workspaces                 false
/general/zoom_desktop                    true
/general/zoom_pointer                    true

Offline

#10 2021-08-08 22:52:06

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,040

Re: Window/panel all transparent xfce

Go to Settings Manager > Window Manager Tweaks > Compositor tab. Set all the sliders in the bottom half of the screen to 100.

If you can't get there, run the following commands:

xfconf-query -c xfwm4 -p /general/frame_opacity -s 100
xfconf-query -c xfwm4 -p /general/inactive_opacity  -s 100
xfconf-query -c xfwm4 -p /general/move_opacity -s 100
xfconf-query -c xfwm4 -p /general/popup_opacity  -s 100
xfconf-query -c xfwm4 -p /general/resize_opacity -s 100

Offline

#11 2021-08-09 02:27:49

SteveM
Member
Registered: 2021-06-12
Posts: 7

Re: Window/panel all transparent xfce

That worked. Everything is working fine now thanks to you. I really appreciate your help.

Offline

Board footer

Powered by FluxBB