Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-09-15 00:36:56

sonycdr
Member
Registered: 2009-01-30
Posts: 102

[SOLVED] Xfwm Default theme don't load the GTK color scheme

Xfce have a xfwm Default theme, this theme changes its background according to GTK theme. So when You select Adwaita Light the window bar is light and when You select Adwaita Dark the window bar is dark.

Now I've using Debian 11 (xfce 4.16) and I have this weird behavior: xfwm Default theme don't load the GTK color scheme. I select Adwaita Dark and the window bar (xfwm) has a light background.

I don't have idea what is the problem. I installed <gtk2-engines-murrine> and nothing change. I noticed when I log out session and relogin the xfwm theme works, but when I shutdown my PC, the theme crashes again.

Last edited by sonycdr (2021-09-15 19:04:02)

Offline

#2 2021-09-15 16:22:02

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,128

Re: [SOLVED] Xfwm Default theme don't load the GTK color scheme

It sounds like xfwm4 is not connected properly to xfconf and/or xfsettingsd. Are you able to share the contents of your ~/.xsession-errors file after a fresh login as well as the contents of ~/.config/gtk-3.0/gtk.css (if it exists)?

Offline

#3 2021-09-15 17:28:42

sonycdr
Member
Registered: 2009-01-30
Posts: 102

Re: [SOLVED] Xfwm Default theme don't load the GTK color scheme

Hi, ToZ

Here the .xsession-errors file (I don't have the ~/.config/gtk-3.0/gtk.css file, I'm in a fresh Debian 11):

Xsession: X session started for sonycdr at Wed 15 sep 2021 12:01:55 -05
WARNING: tempfile is deprecated; consider using mktemp instead.
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/sonycdr/.Xauthority
localuser:sonycdr being added to access control list
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
/usr/bin/x-session-manager: X server already running on display :0
/usr/bin/iceauth:  creating new authority file /run/user/1000/ICEauthority
xfce4-session-Message: 12:01:56.939: SSH authentication agent is already running
gpg-agent: ya hay un agente gpg ejecutándose - no se inicia otro

(xfsettingsd:918): xfsettingsd-WARNING **: 12:02:09.419: Failed to get the _NET_NUMBER_OF_DESKTOPS property.

** (xfce4-power-manager:993): WARNING **: 12:02:11.246: Failed to get name owner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.freedesktop.PowerManagement': no such name


** (xfce4-power-manager:993): WARNING **: 12:02:11.246: Failed to get name owner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.xfce.PowerManager': no such name


(xfce4-power-manager:993): GLib-GObject-WARNING **: 12:02:11.421: ../../../gobject/gsignal.c:2614: signal 'Changed' is invalid for instance '0x5613fd3d38d0' of type 'GDBusProxy'

(xfce4-power-manager:993): xfce4-power-manager-WARNING **: 12:02:11.463: could not map keysym 1008ffa8 to keycode


** (xfce4-power-manager:993): WARNING **: 12:02:11.505: No outputs have backlight property

(xfce4-power-manager:993): xfce4-power-manager-WARNING **: 12:02:11.579: It seems the kernel brightness switch handling value was not restored properly on exit last time, xfce4-power-manager will try to restore it this time.
xfce4-power-manager-Message: 12:02:11.751: Set kernel brightness switch to 0

(xfce4-power-manager:993): xfce4-power-manager-WARNING **: 12:02:11.757: Failed to get keyboard max brightness level : GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No existe la interfaz «org.freedesktop.UPower.KbdBacklight» en el objeto en la ruta /org/freedesktop/UPower/KbdBacklight

** (wrapper-2.0:1034): WARNING **: 12:02:14.641: No outputs have backlight property

(wrapper-2.0:1035): GLib-GIO-CRITICAL **: 12:02:14.813: g_file_new_for_path: assertion 'path != NULL' failed

(wrapper-2.0:1035): GLib-GIO-CRITICAL **: 12:02:14.813: g_file_monitor_file: assertion 'G_IS_FILE (file)' failed

(wrapper-2.0:1035): GLib-GObject-WARNING **: 12:02:14.813: invalid (NULL) pointer instance

(wrapper-2.0:1035): GLib-GObject-CRITICAL **: 12:02:14.814: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(wrapper-2.0:1035): Gtk-WARNING **: 12:02:14.814: Attempting to add a widget with type GtkToggleButton to a container of type XfcePanelPlugin, but the widget is already inside a container of type XfcePanelPlugin, please remove the widget from its existing container first.

(wrapper-2.0:1035): Gtk-WARNING **: 12:02:14.992: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)

(wrapper-2.0:1033): Gtk-WARNING **: 12:02:15.011: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PulseaudioButton)

(wrapper-2.0:1034): Gtk-WARNING **: 12:02:15.223: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PowerManagerButton)

(xfce4-appearance-settings:2224): Gtk-WARNING **: 12:18:40.182: Content added to the action area of a dialog using header bars

(xfce4-appearance-settings:2224): Gtk-WARNING **: 12:18:40.182: Content added to the action area of a dialog using header bars

(xfwm4-settings:2228): Gtk-WARNING **: 12:18:43.618: Content added to the action area of a dialog using header bars

(xfwm4-settings:2228): Gtk-WARNING **: 12:18:43.618: Content added to the action area of a dialog using header bars

(xfce4-appearance-settings:2243): Gtk-WARNING **: 12:19:04.647: Content added to the action area of a dialog using header bars

(xfce4-appearance-settings:2243): Gtk-WARNING **: 12:19:04.648: Content added to the action area of a dialog using header bars

(xfwm4-settings:2249): Gtk-WARNING **: 12:19:10.483: Content added to the action area of a dialog using header bars

(xfwm4-settings:2249): Gtk-WARNING **: 12:19:10.483: Content added to the action area of a dialog using header bars

Last edited by sonycdr (2021-09-17 01:54:56)

Offline

#4 2021-09-15 18:02:46

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,128

Re: [SOLVED] Xfwm Default theme don't load the GTK color scheme

That looks okay (with respect to this issue). I've installed Debian 11 in a VM and can't replicate this problem.

When the problem happens (changing themes and the window manager theme doesn't change), is anything added to the ~/.xsession-errors file?

Offline

#5 2021-09-15 18:05:22

sonycdr
Member
Registered: 2009-01-30
Posts: 102

Re: [SOLVED] Xfwm Default theme don't load the GTK color scheme

ToZ, I searched about xfsettingsd from your comment and I have news (maybe can help).

In the official documentation recommends use the next command for debbuging:

XFSETTINGSD_DEBUG=1 xfsettingsd --replace --no-daemon

After type the command the xfwm error fixes and the theme works.

Maybe when xfsettingsd daemon starts don't load properly. The command that xfsettingsd runs is Exec=xfsettingsd (/etc/xdg/autostart/xfsettingsd.desktop). I don't know.

Last edited by sonycdr (2021-09-15 18:07:12)

Offline

#6 2021-09-15 19:03:35

sonycdr
Member
Registered: 2009-01-30
Posts: 102

Re: [SOLVED] Xfwm Default theme don't load the GTK color scheme

I don't know what exactly happens here, ToZ can't replicate the problem so I suppose this a very precise problem. Anyway, I decided to apply a raw solution. I create a new entry in startup.

Settings manager > Session and Startup > Application Autostart > Add:

sh -c "sleep 3 && xfsettingsd --replace"

I don't know this solution has a some complication but works (for now).

Offline

#7 2021-09-15 19:29:36

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,128

Re: [SOLVED] Xfwm Default theme don't load the GTK color scheme

Some sort of race condition? There was a bunch of work done dealing with race conditions pre-4.14 that sound similar. However, since you are running 4.16, they shouldn't still exist.

Can you try the following? With root privileges, create the file /usr/local/bin/xfsettingsd with the following content:

#!/bin/bash
XFSETTINGSD_DEBUG=1 /usr/bin/xfsettingsd --replace --no-daemon > /tmp/xfsettingsd.log

...and make the file executable.

Reboot your computer, log in and post back the contents of /tmp/xfsettingsd.log.

To return the computer to its regular state, delete /us/local/bin/xfsettingsd and reboot.

Offline

#8 2021-09-16 21:18:17

sonycdr
Member
Registered: 2009-01-30
Posts: 102

Re: [SOLVED] Xfwm Default theme don't load the GTK color scheme

Well, ToZ I followed your recommendations but the /tmp/xfsettingsd.log file is empty. But if I type on terminal XFSETTINGSD_DEBUG=1 /usr/bin/xfsettingsd --replace --no-daemon, I have the next out:

xfce4-settings(xsettings): _XSETTINGS_S0 registered on screen 0
xfce4-settings(xsettings): 31 settings changed (serial=0, len=1228)
xfce4-settings(xsettings): resource manager (xft) changed (len=150)
xfce4-settings(displays): Detected CRTC 63.
xfce4-settings(displays): Detected CRTC 64.
xfce4-settings(displays): Detected output 65 LVDS-1.
xfce4-settings(displays): Detected output 67 HDMI-1.
xfce4-settings(displays): CRTC 63 assigned to LVDS-1.
xfce4-settings(displays): CRTC 64 assigned to HDMI-1.
xfce4-settings(displays): CRTC 64, output list[0] -> 67.
xfce4-settings(displays): Total 1 active output(s).
xfce4-settings(displays): Normalized CRTC 64: size=1920x1024, pos=0x0.
xfce4-sett9ings(displays): min_h = 100, min_w = 520, max_h = 8022, max_w = 8022, prev_h = 1024, prev_w = 1920, prev_hmm = 510, prev_wmm = 180, h = 1024, w = 1920, hmm = 510, wmm = 180.
xfce4-settings(displays): Configuring CRTC 63.
xfce4-settings(displays): Configuring CRTC 64.
xfce4-settings(pointers): initialized xi 2.3
xfce4-settings(keyboards): initialized xkb 1.0
xfce4-settings(keyboards): set auto repeat on
xfce4-settings(keyboards): set key repeat (delay=500, rate=50)
xfce4-settings(keyboards): set numlock on
xfce4-settings(accessibility): AccessXKeys disabled
xfce4-settings(accessibility): stickykeys disabled
xfce4-settings(accessibility): slowkeys disabled
xfce4-settings(accessibility): bouncekeys disabled
xfce4-settings(accessibility): mousekeys disabled
xfce4-settings(keyboard-shortcuts): 23 shortcuts loaded
xfce4-settings(fontconfig): monitoring 1074 paths
xfce4-settings(workspaces): 2 desktop names set from xfconf

Last edited by sonycdr (2021-09-16 21:21:40)

Offline

#9 2021-09-16 23:14:11

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,128

Re: [SOLVED] Xfwm Default theme don't load the GTK color scheme

Hmm. Try this script instead and see if it works:

#!/bin/bash
export XFSETTINGSD_DEBUG=1 
/usr/bin/xfsettingsd --replace --no-daemon > /tmp/xfsettingsd.log 2>&1 &

Running it manually doesn't help because that solves the problem. I'm wondering if there are any error messages on the first run.

Offline

#10 2021-09-17 01:59:32

sonycdr
Member
Registered: 2009-01-30
Posts: 102

Re: [SOLVED] Xfwm Default theme don't load the GTK color scheme

Here I am with news. With the new script I have a log file. So, here the info:

xfce4-settings(xsettings): _XSETTINGS_S0 registered on screen 0
xfce4-settings(xsettings): 31 settings changed (serial=0, len=1228)
xfce4-settings(xsettings): resource manager (xft) changed (len=150)
xfce4-settings(displays): Detected CRTC 63.
xfce4-settings(displays): Detected CRTC 64.
xfce4-settings(displays): Detected output 65 LVDS-1.
xfce4-settings(displays): Detected output 67 HDMI-1.
xfce4-settings(displays): CRTC 63 assigned to LVDS-1.
xfce4-settings(displays): CRTC 64 assigned to HDMI-1.
xfce4-settings(displays): CRTC 64, output list[0] -> 67.
xfce4-settings(displays): Total 1 active output(s).
xfce4-settings(displays): Normalized CRTC 64: size=1920x1024, pos=0x0.
xfce4-settings(displays): Normalized CRTC 64: size=1920x1024, pos=0x0.
xfce4-settings(displays): min_h = 100, min_w = 520, max_h = 8022, max_w = 8022, prev_h = 1024, prev_w = 1920, prev_hmm = 510, prev_wmm = 180, h = 1024, w = 1920, hmm = 510, wmm = 180.
xfce4-settings(displays): Configuring CRTC 63.
xfce4-settings(displays): Configuring CRTC 64.
xfce4-settings(pointers): initialized xi 2.3
xfce4-settings(keyboards): initialized xkb 1.0
xfce4-settings(keyboards): set auto repeat on
xfce4-settings(keyboards): set key repeat (delay=500, rate=50)
xfce4-settings(keyboards): set numlock on
xfce4-settings(accessibility): AccessXKeys disabled
xfce4-settings(accessibility): stickykeys disabled
xfce4-settings(accessibility): slowkeys disabled
xfce4-settings(accessibility): bouncekeys disabled
xfce4-settings(accessibility): mousekeys disabled
xfce4-settings(keyboard-shortcuts): 23 shortcuts loaded
xfce4-settings(fontconfig): monitoring 1074 paths
xfce4-settings(workspaces): 2 desktop names set from xfconf

I look similar, but I don't know.

Offline

#11 2021-09-17 02:06:42

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,128

Re: [SOLVED] Xfwm Default theme don't load the GTK color scheme

Yeah, looks fine. Did you disable your fix from post #6 when you tried this?

Offline

#12 2021-09-19 16:47:21

sonycdr
Member
Registered: 2009-01-30
Posts: 102

Re: [SOLVED] Xfwm Default theme don't load the GTK color scheme

ToZ wrote:

Yeah, looks fine. Did you disable your fix from post #6 when you tried this?

Yes, I did. I will hope fix it with a new update or when I'll install some dependence. Thanks for all ToZ.

Offline

Board footer

Powered by FluxBB