Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-09-17 14:11:40

Iago
Member
Registered: 2021-09-17
Posts: 1

Weird behaviour using Alt+Tab with LibreOffice. Is it an XFCE bug?

Hi!

I am new to this forum. I just found a weird behaviour which seems to me related to XFCE, but as other software is related I would not say 100% sure that it is an XFCE bug.

I am using Debian 11 with updated packages and, in particular, XFCE 4.16. I use often the shortcut Alt+Tab to switch among windows in a workspace, usually without problems.

The weird behaviour is when using LibreOffice Calc (I tested with versions 7.0.4.2 and 7.1.4.2). If I have the cursor on a cell, Alt+Tab seems to work fine, but if I place the cursor on the Find  toolbar (by means of the touchpad or Ctrl+F), when next I use Alt+Tab to switch to another window, then in an abstract way the switch is done (sometimes)*, but the window in front is still LibreOffice Calc.

* I say that in an abstract way the switch is done (sometimes) because:

  • First, on the panel bar, among the shown tabs of open windows, the app marked is that I decided to switch with Alt+Tab (sometimes)

  • Moreover, after I have done the previous step, so 1) I was on LibreOffice Calc on Find Toolbar, but after 2) I switched window with Alt+Tab but I see yet LibreOffice Calc window, then, if 3) I use again Alt+Tab, this time the window that appears is the one I decide, so it works fine.

  • That happens sometimes, but other times, after using Alt+Tab to swich to another window, the app marked on the panel  bar is yet LibreOffice Calc

NB: I tried to illustrate the first item of the list with an screenshot saved on Dropbox, but I couldn't get it previewed on this message. Let me know if I could be more specific, or if this issue happens also to you.

Thank you!


Iago

Last edited by Iago (2021-09-17 14:17:55)

Offline

#2 2021-09-17 20:02:00

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,128

Re: Weird behaviour using Alt+Tab with LibreOffice. Is it an XFCE bug?

Hello and welcome.

I can replicate this on my system as well. I'm not sure if this is a bug in xfwm4 or the libreoffice find dialog somehow interfering in the process. I'm leaning towards libreoffice as I can't replicate the problem with other find dialogs in the system.

Offline

Board footer

Powered by FluxBB