Xfce Forum

Sub domains
 

You are not logged in.

#51 2017-02-01 15:03:31

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: [Solved] System sounds

But when trying to ..... delete something it still gives me simple beep

I'm not sure what you mean by beep when deleting a file, because deleting a file doesn't generate a sound event. Emptying the trash does. If you are referring to the sound made when emptying the trash, then yes, you need to change the "trash-empty.ogg" sound file.

But when trying to log out ..... it still gives me simple beep

As for sound on logout, this is not an easy thing to do. Xfce does not have any support for logout sounds or actions (see: https://bugzilla.xfce.org/show_bug.cgi?id=13207, https://bugzilla.xfce.org/show_bug.cgi?id=10172, https://bugzilla.xfce.org/show_bug.cgi?id=2382).

There is a workaround available if you're willing to edit system files. Using the patch from comment #2 of that last bug report, you could edit the file "/etc/xdg/xfce4/xinitrc" and add in around line 111 after xfce4-session is run and after the "fi" statement following it, the following snippet:

  # Cleanup after the session if desired
  test -r $HOME/.logout && . $HOME/.logout

...then creating an executable ~/.logout file that will contain a play command to play your log out sound:

#!/bin/bash
play /path/to/logout/sound/file

That should play an exit sound for you.

Offline

#52 2017-02-01 21:09:39

xfzfflm
Member
Registered: 2017-01-31
Posts: 6

Re: [Solved] System sounds

@Toz

Thank you for your reply. By simple beep I mean something sounds like the beep produced by the motherboard when it finds some error of hardware while no sound card loaded, just a sound of "beep~", which is a really annoying sound. By deleting something I mean simply select a file in file manager and press delete button, which puts it into trash. Same sound happens when I press backspace in the address bar with no text in it.

Actually I just want to get rid of this beep sound (either disable it or replace by something sounds not that annoying) and I am not really expecting a sound when I try to logout. Disabling sound event doesn't help.

Last edited by xfzfflm (2017-02-01 21:09:59)

Offline

#53 2017-02-02 00:29:36

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: [Solved] System sounds

xfzfflm wrote:

I mean something sounds like the beep produced by the motherboard when it finds some error of hardware while no sound card loaded, just a sound of "beep~"

Oh. See this arch wiki page to disable the PC speaker.

Offline

#54 2017-02-02 05:18:14

xfzfflm
Member
Registered: 2017-01-31
Posts: 6

Re: [Solved] System sounds

@Toz
Great. Thank you!
It looks like this is automatically mapped to other sound in Gnome/KDE, but not in xfce.

A little problem left though.
It seems that setting within xfce is not supported? I would like to install other wms as well and keep them default behavior.

Offline

#55 2017-02-02 11:29:51

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: [Solved] System sounds

If gnome is remapping the pc speaker sound it must be doing something internally to disable the module. Xfce does not do this.

Why not just manually "rmmod pcspkr" when you start Xfce?

Offline

#56 2017-02-02 16:59:38

xfzfflm
Member
Registered: 2017-01-31
Posts: 6

Re: [Solved] System sounds

Thank you. I would prefer "xset -b" which won't require sudo.

Offline

#57 2017-02-02 18:07:28

xfzfflm
Member
Registered: 2017-01-31
Posts: 6

Re: [Solved] System sounds

BTW, I found there's "blacklist pcspkr" in Ubuntu's modprobe.d but not the case in Arch with KDE/Gnome.

Last edited by xfzfflm (2017-02-02 18:25:41)

Offline

#58 2017-11-07 16:45:52

mkkot
Member
Registered: 2017-11-07
Posts: 4

Re: [Solved] System sounds

Hi, it seems I have a slightly different problem.

[mk@linux ~]$ env | grep GTK_MODULE
GTK_MODULES=canberra-gtk-module:canberra-gtk-module

(I just set that one manually, before it was canberra-gtk-module.)

[mk@linux ~]$ xfconf-query -c xsettings -lv | grep Enable
/Net/EnableEventSounds          true
/Net/EnableInputFeedbackSounds  true
[mk@linux ~]$ xfconf-query -c xsettings -p /Net/SoundThemeName
freedesktop
[mk@linux ~]$ ls -l /usr/share/sounds/`xfconf-query -c xsettings -p /Net/SoundThemeName`/stereo
razem 520
-rw-r--r-- 1 root root 73696 2014-07-03  alarm-clock-elapsed.oga
-rw-r--r-- 1 root root 17015 2014-07-03  audio-channel-front-center.oga
-rw-r--r-- 1 root root 15675 2014-07-03  audio-channel-front-left.oga
-rw-r--r-- 1 root root 19019 2014-07-03  audio-channel-front-right.oga
-rw-r--r-- 1 root root 17099 2014-07-03  audio-channel-rear-center.oga
-rw-r--r-- 1 root root 14129 2014-07-03  audio-channel-rear-left.oga
-rw-r--r-- 1 root root 18791 2014-07-03  audio-channel-rear-right.oga
-rw-r--r-- 1 root root 17089 2014-07-03  audio-channel-side-left.oga
-rw-r--r-- 1 root root 17198 2014-07-03  audio-channel-side-right.oga
-rw-r--r-- 1 root root 18152 2014-07-03  audio-test-signal.oga
-rw-r--r-- 1 root root  5596 2014-07-03  audio-volume-change.oga
-rw-r--r-- 1 root root  8495 2014-07-03  bell.oga
-rw-r--r-- 1 root root 23142 2014-07-03  camera-shutter.oga
-rw-r--r-- 1 root root 21073 2014-07-03  complete.oga
-rw-r--r-- 1 root root  8748 2014-07-03  device-added.oga
-rw-r--r-- 1 root root  8500 2014-07-03  device-removed.oga
lrwxrwxrwx 1 root root    18 2014-07-03  dialog-error.oga -> dialog-warning.oga
-rw-r--r-- 1 root root  5666 2014-07-03  dialog-information.oga
-rw-r--r-- 1 root root 12182 2014-07-03  dialog-warning.oga
-rw-r--r-- 1 root root 22733 2014-07-03  message-new-instant.oga
-rw-r--r-- 1 root root 10429 2014-07-03  message.oga
lrwxrwxrwx 1 root root    16 2014-07-03  network-connectivity-established.oga -> device-added.oga
lrwxrwxrwx 1 root root    18 2014-07-03  network-connectivity-lost.oga -> device-removed.oga
-rw-r--r-- 1 root root 25889 2014-07-03  phone-incoming-call.oga
-rw-r--r-- 1 root root  7996 2014-07-03  phone-outgoing-busy.oga
-rw-r--r-- 1 root root  4792 2014-07-03  phone-outgoing-calling.oga
lrwxrwxrwx 1 root root    16 2014-07-03  power-plug.oga -> device-added.oga
lrwxrwxrwx 1 root root    18 2014-07-03  power-unplug.oga -> device-removed.oga
lrwxrwxrwx 1 root root    18 2014-07-03  screen-capture.oga -> camera-shutter.oga
-rw-r--r-- 1 root root 17274 2014-07-03  service-login.oga
-rw-r--r-- 1 root root 14573 2014-07-03  service-logout.oga
-rw-r--r-- 1 root root  6849 2014-07-03  suspend-error.oga
-rw-r--r-- 1 root root 38223 2014-07-03  trash-empty.oga
lrwxrwxrwx 1 root root    18 2014-07-03  window-attention.oga -> dialog-warning.oga
lrwxrwxrwx 1 root root    18 2014-07-03  window-question.oga -> dialog-warning.oga

Notification sounds in pavucontrol are not muted.

canberra-gtk-play -i bell

plays a sound


But instead of sound notification I had pc speaker notification. So I disabled it by xset -b and now I don't have any notification. What else could be wrong?
I'm using Archlinux.

Last edited by mkkot (2017-11-07 16:53:33)

Offline

#59 2017-11-07 17:30:36

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: [Solved] System sounds

now I don't have any notification. What else could be wrong?

Which sound notifications are you expecting to get? The freedesktop sound theme only supports canberra's error dialog (IIRC). Try downloading the Borealis sound theme from post #6 of this thread, copying it to ~/.local/share/sounds and setting the SoundThemeName to "Borealis". You should get more window open/close, minimize/maximize sound events.

Edit: Here is another pretty good sound theme.

Offline

#60 2020-12-18 09:12:42

ferrvittorio
Member
Registered: 2020-12-18
Posts: 4

Re: [Solved] System sounds

Good morning, I also bump here because cannot get this cosmetic mod to work.
Sorry for necrobump. I believe I did my homework, but no sound!

uname -a
Linux hp-pavilion590 5.9.11-3-MANJARO #1 SMP PREEMPT Sat Nov 28 09:08:57 UTC 2020 x86_64 GNU/Linux

xfconf-query -c xsettings -p /Net/SoundThemeName
Borealis
env | grep GTK_MODULE
GTK_MODULES=canberra-gtk-module:canberra-gtk-module
ls -l /usr/share/sounds/$(xfconf-query -c xsettings -p /Net/SoundThemeName)/stereo
totale 2960
-rw-r--r-- 1 root root   8357 18 dic 09.38 button-pressed.ogg
-rw-r--r-- 1 root root  10284 18 dic 09.38 button-toggle-off.ogg
-rw-r--r-- 1 root root  10120 18 dic 09.38 button-toggle-on.ogg
-rw-r--r-- 1 root root 447104 18 dic 09.38 desktop-login.ogg
-rw-r--r-- 1 root root 227654 18 dic 09.38 desktop-logout.ogg
-rw-r--r-- 1 root root  10120 18 dic 09.38 desktop-switch-left.ogg
-rw-r--r-- 1 root root  10284 18 dic 09.38 desktop-switch-right.ogg
-rw-r--r-- 1 root root  10120 18 dic 09.38 device-added.ogg
-rw-r--r-- 1 root root  10284 18 dic 09.38 device-removed.ogg
-rw-r--r-- 1 root root  40703 18 dic 09.38 dialog-error.ogg
-rw-r--r-- 1 root root  11652 18 dic 09.38 dialog-information.ogg
-rw-r--r-- 1 root root  52026 18 dic 09.38 dialog-question.ogg
-rw-r--r-- 1 root root  16193 18 dic 09.38 dialog-warning.ogg
-rw-r--r-- 1 root root 225536 18 dic 09.38 Exit1_2.ogg
-rw-r--r-- 1 root root   4630 18 dic 09.38 install.sh
-rw-r--r-- 1 root root 278722 18 dic 09.38 K3b_success.ogg
-rw-r--r-- 1 root root  24192 18 dic 09.38 Knock.ogg
-rw-r--r-- 1 root root  29711 18 dic 09.38 Kopete_status.ogg
-rw-r--r-- 1 root root  30409 18 dic 09.38 message-new-instant.ogg
-rw-r--r-- 1 root root  84820 18 dic 09.38 phone-incoming-call.ogg
-rw-r--r-- 1 root root  48009 18 dic 09.38 phone-outgoing-busy.ogg
-rw-r--r-- 1 root root   7782 18 dic 09.38 README
-rw-r--r-- 1 root root  17274 18 dic 09.38 service-login.ogg
-rw-r--r-- 1 root root  14573 18 dic 09.38 service-logout.ogg
-rw-r--r-- 1 root root 397380 18 dic 09.38 Startup1_1.ogg
-rw-r--r-- 1 root root 408878 18 dic 09.38 Startup1_2.ogg
-rw-r--r-- 1 root root 413931 18 dic 09.38 Startup1_3.ogg
-rw-r--r-- 1 root root  41886 18 dic 09.38 system-ready.ogg
-rw-r--r-- 1 root root   8869 18 dic 09.38 trash-empty.ogg
-rw-r--r-- 1 root root   2860 18 dic 09.38 uninstall.sh
-rw-r--r-- 1 root root  11114 18 dic 09.38 window-close.ogg
-rw-r--r-- 1 root root  10120 18 dic 09.38 window-maximized.ogg
-rw-r--r-- 1 root root  11114 18 dic 09.38 window-minimized.ogg
-rw-r--r-- 1 root root  10284 18 dic 09.38 window-unmaximized.ogg
-rw-r--r-- 1 root root  11439 18 dic 09.38 window-unminimized.ogg

(had to force the creation of "stereo" in Borealis and copy content)

which canberra-gtk-play
/usr/bin/canberra-gtk-play

Offline

#61 2020-12-18 12:22:36

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: [Solved] System sounds

Hello and welcome.

A couple of things. Make sure that both the Event Sounds options are enabled in Settings Manager > Appearance > Settings tab, and if not installed, install "pavucontrol" then run it and on the Playback tab, ensure that System Sounds is turned up.

Also note that there is only a limited number of system sounds that are available. Open and closing a window should generate a sound for you to hear.

Offline

#62 2020-12-22 07:14:26

ferrvittorio
Member
Registered: 2020-12-18
Posts: 4

Re: [Solved] System sounds

Hi, and thanks.
No magic for me
The only results I could achieve where "canberra-gtk-play -i service-login" and "logout" (which is not "shutdown" smile )

Where are all other events coded
on shutdown
on suspend
etc.

would like to try adding more events seemingly present in Borealis

Offline

#63 2020-12-22 12:39:00

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: [Solved] System sounds

Xfce does not have any sound events coded into it. It uses libcanberra (which hooks into gtk events). libcanberra only supports the following events (and even some of them I can't seem to generate an sound event for). libcanberra development stopped back in and around 2012.

Since you can play the service-login event using canberra-gtk-play, then that would mean that the sound events back end is properly setup. If you've got the System Sounds volume unmuted and on high, you should hear a sound when you minimize and restore a window.

You can create separate sound events for suspend, shutdown, etc via Settings Manager > Session and Startup > Application Autostart. For each entry there, you can specify a trigger, one of login, logout, shutdown, restart, suspend, hibernate, hybrid sleep, switch user. Note that this may take some fiddling as I recall when I was trying that the canberra modules were being unloaded before the sound played on shutdown/restart/logout triggers. I create a generic sounds script for which you can pass a parameter to (one of login, shutdown, restart, etc) and added this script+parameter to the Startup Applications list:

#!/bin/bash

case $1 in
        login)
                canberra-gtk-play -i _desktop-login
        ;;
        restart|logout|shutdown)
                #nohup canberra-gtk-play -i desktop-logout &
                nohup mplayer /usr/share/sounds/Smooth/stereo/desktop-logout.oga &
        ;;
esac    

exit 0

...note: I couldn't get canberra-gtk-play to work on restart|logout|shutdown because I think the libraries were being unloaded. Ended up resorting to "nohup mplayer", but I only get a second or two of sound before it gets cut off as well. Though admittedly, I didn't spend too much time on this.

Offline

#64 2021-10-07 03:21:27

bendipa
Member
Registered: 2021-05-10
Posts: 1

Re: [Solved] System sounds

ToZ wrote:

Xfce does not have any sound events coded into it. It uses libcanberra (which hooks into gtk events). libcanberra only supports the following events (and even some of them I can't seem to generate an sound event for). libcanberra development stopped back in and around 2012.

Since you can play the service-login event using canberra-gtk-play, then that would mean that the sound events back end is properly setup. If you've got the System Sounds volume unmuted and on high, you should hear a sound when you minimize and restore a window.

You can create separate sound events for suspend, shutdown, etc via Settings Manager > Session and Startup > Application Autostart. For each entry there, you can specify a trigger, one of login, logout, shutdown, restart, suspend, hibernate, hybrid sleep, switch user. Note that this may take some fiddling as I recall when I was trying that the canberra modules were being unloaded before the sound played on shutdown/restart/logout triggers. I create a generic sounds script for which you can pass a parameter to (one of login, shutdown, restart, etc) and added this script+parameter to the Startup Applications list:

#!/bin/bash

case $1 in
        login)
                canberra-gtk-play -i _desktop-login
        ;;
        restart|logout|shutdown)
                #nohup canberra-gtk-play -i desktop-logout &
                nohup mplayer /usr/share/sounds/Smooth/stereo/desktop-logout.oga &
        ;;
esac    

exit 0

o
...note: I couldn't get canberra-gtk-play to work on restart|logout|shutdown because I think the libraries were being unloaded. Ended up resorting to "nohup mplayer", but I only get a second or two of sound before it gets cut off as well. Though admittedly, I didn't spend too much time on this.

I set up 2 event sounds in Session & Startup, namely Login Sound and Logout Sound as shown in the image below. The commands for both sounds were first tested with:  canberra-gtk-play -f [absolute path to sound file], which were both in the folder /usr/share/sounds/LinuxMint/stereo/, being files desktop-login.ogg and GurglingSink.ogg respectively. Both files played fine. The 'Logout Sound' was assigned with event 'on restart' (highlighted).

I then logged out and logged back in and file desktop-login.ogg played as expected. However, when I restarted my computer there was no sound played at all.

Any idea why the 'on restart' event remained silent?

kqWMpkF.png

Last edited by bendipa (2021-10-07 03:23:22)

Offline

#65 2021-10-07 15:30:47

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: [Solved] System sounds

bendipa wrote:

Any idea why the 'on restart' event remained silent?

I think its because all of the processes required to make the sound (pulseaudio) have been killed/disconnected as part of the log out/restart process so nothing is available to make the sound. Perhaps the script itself is getting killed.

You could look at a systemd service to do the shutdown/reboot sound. Just tested and this worked for me:

  1. With root privileges, create the file /etc/systemd/system/sound-shutdown.service with the following content:

    [Unit]
    Description=Play a shutdown sound
     
    [Service]
    Type=oneshot
    RemainAfterExit=true
    ExecStart=/bin/true
    ExecStop=/usr/bin/sudo -u toz play /usr/share/sounds/Smooth/stereo/desktop-logout.oga
     
    [Install]
    WantedBy=multi-user.target

    ...make sure to replace "toz" with your userid and point to your correct sound file. Note: you need to have the "sox" package installed for the play command.

  2. Enable and start the service file:

    sudo systemctl daemon-reload
    sudo systemctl enable sound-shutdown.service --now
  3. Test.

Offline

Board footer

Powered by FluxBB