Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-11-21 10:55:05

tehkos
Member
Registered: 2021-07-12
Posts: 10

How to make Chrome show files in pcmanfm instead of thunar?

When I download a file and click "Show in folder", the file is shown in thunar. How can I switch the default file manager to pcmanfm?
It's the same in Firefox and many other apps.

I'm using xfce 4.14 with Xubuntu 20.04.

The solutions I searched are very old and  they don't  work for me today.

Last edited by tehkos (2021-11-21 11:28:28)

Offline

#2 2021-11-21 11:14:16

KBar
Member
Registered: 2021-11-05
Posts: 70

Re: How to make Chrome show files in pcmanfm instead of thunar?

It's managed under Preferred Applications.

preferred_applications_2.png

Last edited by KBar (2021-11-21 11:36:58)

Offline

#3 2021-11-21 11:27:27

tehkos
Member
Registered: 2021-07-12
Posts: 10

Re: How to make Chrome show files in pcmanfm instead of thunar?

No. Apps have been ignoring these settings for a long time.

Offline

#4 2021-11-21 11:31:56

KBar
Member
Registered: 2021-11-05
Posts: 70

Re: How to make Chrome show files in pcmanfm instead of thunar?

Let's check if the exo-utils package is installed.

dpkg -l exo-utils
apt-cache policy exo-utils

Offline

#5 2021-11-21 11:37:53

tehkos
Member
Registered: 2021-07-12
Posts: 10

Re: How to make Chrome show files in pcmanfm instead of thunar?

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version                  Architecture Description
+++-==============-========================-============-=================================
ii  exo-utils      0.12.11-1ubuntu1.20.04.1 amd64        Utility files for libexo
exo-utils:
  Installed: 0.12.11-1ubuntu1.20.04.1
  Candidate: 0.12.11-1ubuntu1.20.04.1
  Version table:
 *** 0.12.11-1ubuntu1.20.04.1 500
        500 http://ru.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     0.12.11-1ubuntu1 500
        500 http://ru.archive.ubuntu.com/ubuntu focal/universe amd64 Packages

Offline

#6 2021-11-21 11:47:07

KBar
Member
Registered: 2021-11-05
Posts: 70

Re: How to make Chrome show files in pcmanfm instead of thunar?

Make sure to set PCManFM as your default file manager (I edited my first reply and included a better screenshot) and try this:

exo-open --launch FileManager

Does it launch PCManFM or Thunar?

Last edited by KBar (2021-11-21 11:48:07)

Offline

#7 2021-11-21 11:56:54

tehkos
Member
Registered: 2021-07-12
Posts: 10

Re: How to make Chrome show files in pcmanfm instead of thunar?

It opens pcmanfm.

Never mind. I found the solution that I used before:
https://unix.stackexchange.com/a/581233/311304

Create a file /etc/dbus-1/session-local.conf
with the code:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-Bus Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">

<busconfig>
  <policy context="default">
    <!-- Block all usage of org.freedesktop.FileManager1 for opening files -->
    <deny send_interface="org.freedesktop.FileManager1" send_destination="org.freedesktop.FileManager1"/>
  </policy>
</busconfig>

Then  launch this command (under the current user not root):

dbus-send --session --print-reply --dest=org.freedesktop.DBus --type=method_call /org/freedesktop/DBus org.freedesktop.DBus.ReloadConfig

Very complicated as I think. Never understood why such a trivial function can't work from the settings.

Last edited by tehkos (2021-11-21 12:11:13)

Offline

Board footer

Powered by FluxBB