Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-12-23 08:43:06

bulent
Member
Registered: 2021-12-23
Posts: 5

Opening the Login screen at startup

Hi,
I am using Xubuntu 20.04. Although automatic login is turned on, sometimes the login screen appears at startup. It's very rare, but it's annoying. What can I do about it?

Offline

#2 2021-12-23 13:15:34

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,506

Re: Opening the Login screen at startup

Hello and welcome.

Do you need the login screen (display manager) at all? Is there some use case where you want to logout of your auto-logged in session and login as someone else? If not, you can remove/uninstall the display manager and configure the system to autologin without a display manager.

Offline

#3 2021-12-23 13:22:09

bulent
Member
Registered: 2021-12-23
Posts: 5

Re: Opening the Login screen at startup

Thanks for your answer,

I don't need the login screen, I don't do any user switching.

What configs do I need to change for autologin after removing display manager?

Offline

#4 2021-12-23 14:11:45

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,506

Re: Opening the Login screen at startup

I was just having a look at it on my 20.04 VM. You can disable the display manager but unfortunately now text gets printed to the screen that I cannot remove. Not sure if thats any better.

Anyways, to disable lightdm (the display manager):

sudo systemctl disable lightdm

Since you have autologin working now, try rebooting to see what happens.

You can always re-enable the display manager with:

sudo systemctl enable lightdm

Offline

#5 2021-12-24 09:42:47

bulent
Member
Registered: 2021-12-23
Posts: 5

Re: Opening the Login screen at startup

When I disable lightdm, xubuntu does not open at all. Waiting on black screen after bios screen.

Offline

#6 2021-12-24 12:06:27

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,506

Re: Opening the Login screen at startup

Hmmm. The Display Manager (lightdm) isn't actually part of Xfce. I personally don't use a display manager so I won't be able to offer any further advice - but perhaps someone at the ubuntuforums might be to assist with the black screen and with your autologin issue.

Offline

#7 2021-12-27 14:07:23

bulent
Member
Registered: 2021-12-23
Posts: 5

Re: Opening the Login screen at startup

There is one more thing that may be important, The processor of the device we see this error is AMD , We are using the same version of the operating system as an Intel processor and we did not encounter this error.

Offline

#8 2021-12-27 14:20:02

KBar
Member
Registered: 2021-11-05
Posts: 189

Re: Opening the Login screen at startup

That's odd. I'm on Xubuntu 20.04 as well and have never had this issue.

Could you elaborate how exactly you set up auto-login? Here's two things that I did: 1) tick the "Don't ask for password on login" box; 2) edit the lightdm.conf file.

Did you do the same?

Offline

#9 2021-12-28 06:13:08

bulent
Member
Registered: 2021-12-23
Posts: 5

Re: Opening the Login screen at startup

I have xubuntu installed on my 2 different types of devices, 1 of which never did. But it does it occasionally with AMD processors.

I turned off asking for password on login, now it just asks for login.

My lightdm.conf file is as follows

[Seat:*]
autologin-guest=false
autologin-user=USERNAME
autologin-user-timeout=0

Offline

#10 2021-12-28 06:38:40

KBar
Member
Registered: 2021-11-05
Posts: 189

Re: Opening the Login screen at startup

Do you have guest users set up? If not, try removing the first and the third lines.

I suspect the problem is caused by PAM. Whenever this happens again, could you immediately switch to a virtual terminal, run

journalctl --boot

and press Shift-g or End to reach the last line.

journalctl --follow

will also work, but it defaults to 10 lines so we might miss out on something that happened prior.

Offline

#11 2022-01-10 01:00:33

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,115

Re: Opening the Login screen at startup

KBar wrote:

Do you have guest users set up? If not, try removing the first and the third lines.

When troubleshooting by making line deletions to files, when one does not know for sure that the edit(s) will solve an issue, I would suggest that a person turn the line into a comment, rather than actually remove it. In case the thing does not solve the issue, it is easier to go back and remove the ";" that the person added to the beginning of the line than to retype it.

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

Board footer

Powered by FluxBB