Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-01-01 14:31:30

Moi
Member
Registered: 2022-01-01
Posts: 15

Notes is crashing

Hi all,

I'm using Raspberry Pi OS 64-bit, which is Debian-based.
This variant of Debian does not include xfce4's Notes program, so I had to compile it and install it myself.

That went OK, and I added Notes to my panel, however I find there are 2 problems:
A) whatever changes I make to a note is never saved.
B) after about 2 minutes, Notes crashes, which is to say that it suddenly disappears.

This always happens.
There is no logging from Notes itself, however there is a little logging about it:

daemon.log:Dec 30 18:32:58 darkstar dbus-daemon[1748]: [session uid=1001 pid=1748] Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service' requested by ':1.7' (uid=1001 pid=1806 comm="xfce4-notes ")
daemon.log:Dec 30 18:32:58 darkstar dbus-daemon[1748]: [session uid=1001 pid=1748] Activating service name='org.xfce.Xfconf' requested by ':1.7' (uid=1001 pid=1806 comm="xfce4-notes ")

There is no logging at the moment of the crash.

Has anyone seen such an issue with Notes?
Thanks.

Offline

#2 2022-01-01 14:46:43

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,836

Re: Notes is crashing

Hello and welcome.

Moi wrote:

This variant of Debian does not include xfce4's Notes program, so I had to compile it and install it myself.

Any chance you could post back the autogen.sh/configure command that you used as well as the output from that command?

A) whatever changes I make to a note is never saved.

Notes should be saved to ~/.local/share/notes/Notes - do you have any content in there?

B) after about 2 minutes, Notes crashes, which is to say that it suddenly disappears.

Can you try running xfce4-panel in debug mode:

xfce4-panel -q
PANEL_DEBUG=all xfce4-panel

...re-add the plugin if necessary, create a note and when it crashes post back the output in the terminal.

This always happens.
There is no logging from Notes itself, however there is a little logging about it:

There is no logging at the moment of the crash.

Is this version of raspberry pi based on systemd? If so, does

coredumpctl list --no-pager | grep -i notes

return anything?

Online

#3 2022-01-01 18:28:12

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

This RpiOS is based on systemd, yes. It's either I run this or jump to Manjaro or Ubuntu. That's about all there is for the Pi4.

I just ran the panel in debug mode and the demise of Notes only produces this one line:

main-status-icon.vala:37: Status Icon is not embedded

When I run sudo coredumpctl list, I get:

No coredumps found.

Offline

#4 2022-01-01 18:41:31

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

I just rebuilt Notes now. Configure said:

* Maintainer Mode:        no
* GTK+:                   3.24.24
* Xfce Panel:             4.16.2
* Debug Support:          minimum

I originally built Notes when I was running RpiOS64 based on Debian buster. Now I have upgraded and it is Debian bullseye.

Anyway I still get the crash.

The main error that the panel itself is printing is

(xfce4-panel:357734): garcon-CRITICAL **: 12:36:58.561: garcon_gtk_menu_get_desktop_actions_menu: assertion 'actions != NULL' failed

----
I stand corrected. It is not a crash. I ran the notes program in gdb and it willfully exited.

Reading symbols from src/xfce4-notes...
(gdb) r
Starting program: /big/zack/Downloads/xfce4-notes-plugin-1.9.0/src/xfce4-notes 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/aarch64-linux-gnu/libthread_db.so.1".
[New Thread 0x7ff5b03e80 (LWP 358126)]
[New Thread 0x7ff5302e80 (LWP 358127)]
[New Thread 0x7ff4b01e80 (LWP 358128)]
[Detaching after vfork from child process 358129]
[Detaching after vfork from child process 358130]
[Detaching after vfork from child process 358131]
[New Thread 0x7fe7ffee80 (LWP 358132)]
[New Thread 0x7fdfffee80 (LWP 358137)]
[Thread 0x7fdfffee80 (LWP 358137) exited]
[Thread 0x7fe7ffee80 (LWP 358132) exited]

** (xfce4-notes:358123): WARNING **: 12:39:52.615: main-status-icon.vala:37: Status Icon is not embedded
[New Thread 0x7fe7ffee80 (LWP 358275)]
[Thread 0x7fe7ffee80 (LWP 358275) exited]
[Thread 0x7ff4b01e80 (LWP 358128) exited]
[Thread 0x7ff5302e80 (LWP 358127) exited]
[Thread 0x7ff5b03e80 (LWP 358126) exited]
[Inferior 1 (process 358123) exited normally]
(gdb) 

Last edited by Moi (2022-01-01 18:42:18)

Offline

#5 2022-01-01 18:44:45

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

Looking in the Notes code, I see that the "is not embedded" warning is immediately followed by a call

 gtk_main_quit ();

Removing that naturally prevents the premature exit. But the question is, why did the author of this code put that in there, in the first place?

Last edited by Moi (2022-01-01 18:48:30)

Offline

#6 2022-01-01 18:46:53

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,836

Re: Notes is crashing

I just rebuilt Notes now. Configure said:

I'm curious as to the actual ./configure command that you are running and the complete output - to see if there are any errors and whether the proper library locations are being set.

I stand corrected. It is not a crash. I ran the notes program in gdb and it willfully exited.

To confirm: you are adding the plugin to the panel, then clicking on the panel plugin to bring up the window and enter notes. Is this correct?

Online

#7 2022-01-01 18:50:09

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

ToZ wrote:

I stand corrected. It is not a crash. I ran the notes program in gdb and it willfully exited.

To confirm: you are adding the plugin to the panel, then clicking on the panel plugin to bring up the window and enter notes. Is this correct?

In order to run the panel in GDB, I have to do that from the command line. (Well OK I could do an "attach" but I didn't do that yet.)
But regardless of how it is run, if that call to gtk_main_quit is in there, Notes will exit prematurely.

Last edited by Moi (2022-01-01 18:51:20)

Offline

#8 2022-01-01 18:52:24

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

OK here's the configure output:

~/Downloads/xfce4-notes-plugin-1.9.0$ ./configure
checking build system type... aarch64-unknown-linux-gnu
checking host system type... aarch64-unknown-linux-gnu
checking target system type... aarch64-unknown-linux-gnu
checking how to print strings... printf
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for fgrep... /usr/bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking how to convert aarch64-unknown-linux-gnu file names to aarch64-unknown-linux-gnu format... func_convert_file_noop
checking how to convert aarch64-unknown-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking for gawk... gawk
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for sysroot... no
checking for a working dd... /usr/bin/dd
checking how to truncate binary pipes... /usr/bin/dd bs=4096 count=1
checking for mt... mt
checking if mt is a manifest tool... no
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking whether make sets $(MAKE)... yes
checking whether make supports the include directive... yes (GNU style)
checking whether make supports nested variables... yes
checking dependency style of gcc... gcc3
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether make supports nested variables... (cached) yes
checking for ld used by gcc... (cached) /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... (cached) yes
checking math.h usability... yes
checking math.h presence... yes
checking for math.h... yes
checking for X... libraries , headers 
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for main in -lX11... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for glib-2.0 >= 2.30.0... 2.66.8
checking GLIB_CFLAGS... -I/usr/include/glib-2.0 -I/usr/lib/aarch64-linux-gnu/glib-2.0/include
checking GLIB_LIBS... -lglib-2.0
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for gio-2.0 >= 2.30.0... 2.66.8
checking GIO_CFLAGS... -pthread -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/glib-2.0 -I/usr/lib/aarch64-linux-gnu/glib-2.0/include
checking GIO_LIBS... -lgio-2.0 -lgobject-2.0 -lglib-2.0
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for gtk+-3.0 >= 3.22.0... 3.24.24
checking GTK_CFLAGS... -pthread -I/usr/include/gtk-3.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib/aarch64-linux-gnu/dbus-1.0/include -I/usr/include/gtk-3.0 -I/usr/include/gio-unix-2.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/fribidi -I/usr/include/harfbuzz -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/uuid -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/glib-2.0 -I/usr/lib/aarch64-linux-gnu/glib-2.0/include
checking GTK_LIBS... -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for libxfce4util-1.0 >= 4.14.0... 4.16.0
checking LIBXFCE4UTIL_CFLAGS... -I/usr/include/xfce4 -I/usr/include/glib-2.0 -I/usr/lib/aarch64-linux-gnu/glib-2.0/include
checking LIBXFCE4UTIL_LIBS... -lxfce4util -lglib-2.0
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for libxfce4ui-2 >= 4.14.0... 4.16.0
checking LIBXFCE4UI_CFLAGS... -pthread -I/usr/include/xfce4/libxfce4ui-2 -I/usr/include/gtk-3.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib/aarch64-linux-gnu/dbus-1.0/include -I/usr/include/gtk-3.0 -I/usr/include/gio-unix-2.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/fribidi -I/usr/include/harfbuzz -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/uuid -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/xfce4 -I/usr/include/glib-2.0 -I/usr/lib/aarch64-linux-gnu/glib-2.0/include
checking LIBXFCE4UI_LIBS... -lxfce4ui-2 -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lxfce4util -lglib-2.0
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for libxfconf-0 >= 4.14.0... 4.16.0
checking XFCONF_CFLAGS... -pthread -I/usr/include/xfce4/xfconf-0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/glib-2.0 -I/usr/lib/aarch64-linux-gnu/glib-2.0/include
checking XFCONF_LIBS... -lxfconf-0 -lgio-2.0 -lgobject-2.0 -lglib-2.0
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for libxfce4panel-2.0 >= 4.14.0... 4.16.2
checking LIBXFCE4PANEL_CFLAGS... -pthread -I/usr/include/xfce4/libxfce4panel-2.0 -I/usr/include/gtk-3.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib/aarch64-linux-gnu/dbus-1.0/include -I/usr/include/gtk-3.0 -I/usr/include/gio-unix-2.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/fribidi -I/usr/include/harfbuzz -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/uuid -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/xfce4 -I/usr/include/glib-2.0 -I/usr/lib/aarch64-linux-gnu/glib-2.0/include
checking LIBXFCE4PANEL_LIBS... -lxfce4panel-2.0 -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lxfce4util -lglib-2.0
checking whether NLS is requested... yes
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.32.1
checking for XML::Parser... ok
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking for CFPreferencesCopyAppValue... no
checking for CFLocaleCopyCurrent... no
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for ngettext in libc... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... (cached) /usr/bin/msgfmt
checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... (cached) /usr/bin/msgfmt
checking for xgettext... (cached) /usr/bin/xgettext
checking for catalogs to be installed...  am ar ast be bg ca cs da de el en_AU en_GB es et eu fi fr gl he hr hu hy_AM hye id ie is it ja kk ko lt lv ms nb nl oc pl pt pt_BR ro ru sk sl sq sr sv th tr ug uk ur ur_PK vi zh_CN zh_TW
checking for bind_textdomain_codeset... (cached) yes
checking for locales directory... ${prefix}/share/locale
checking for additional xgettext flags... --keyword=Q_ --from-code=UTF-8
checking whether to build with debugging support... minimum
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating data/Makefile
config.status: creating data/gtk-3.0/Makefile
config.status: creating data/icons/Makefile
config.status: creating data/icons/16x16/Makefile
config.status: creating data/icons/22x22/Makefile
config.status: creating data/icons/24x24/Makefile
config.status: creating data/icons/32x32/Makefile
config.status: creating data/icons/scalable/Makefile
config.status: creating data/pixmaps/Makefile
config.status: creating lib/Makefile
config.status: creating src/Makefile
config.status: creating po/Makefile.in
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing libtool commands
config.status: executing depfiles commands
config.status: executing default-1 commands
config.status: executing po/stamp-it commands

Build Configuration:

* Maintainer Mode:        no
* GTK+:                   3.24.24
* Xfce Panel:             4.16.2
* Debug Support:          minimum

Offline

#9 2022-01-01 19:09:28

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

OK I've now used the GDB attach method to debug Notes when it's invoked from the panel, and there's nothing new to report.

I find that now that I've removed the call to gtk_main_quit, my edits to notes are saved to ~/.local/share/notes/Notes ...

Thus I think the important thing is to find out why the call to gtk_main_quit was put in there. It seems odd to quit over a warning.

Last edited by Moi (2022-01-01 19:11:41)

Offline

#10 2022-01-01 19:11:12

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,836

Re: Notes is crashing

Do a:

make uninstall

...from the source build directory to remove the files that were installed, then run configure like this:

./configure --prefix=/usr --libdir=/usr/lib/$(uname -m)-linux-gnu

This will put all of the executables and libraries in the proper locations. This works on my debian bullseye VM. Hopefully its the same for the raspberry pi.

Online

#11 2022-01-01 19:19:30

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

That appears to fix the problem, however I think the a change is still required. Either
* configure could be updated to be less problematic, or
* the gtk_main_quit call should be removed since it's not necessary and appears to be overkill.

Offline

#12 2022-01-01 19:22:08

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,836

Re: Notes is crashing

Issue reports can be made here. I don't think the plugin currently has an active maintainer though.

Online

#13 2022-01-01 19:42:42

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

OK I made the fix (one line change) and I tried to push to a feature branch, but I got this error:

remote: You are not allowed to push code to this project.
(username xfceuser)

Offline

#14 2022-01-01 19:58:51

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,836

Re: Notes is crashing

Only approved users will have access to push to the code base. Best bet is to create an issue report at the link above and then, if you are interested in providing merge requests, request access from xfce4-dev mailing list to create merge requests for this package. Once access if granted, you can create a merge request and a developer will need to review and approve.

If you provide good quality merge requests for more than one issue, and if you are interested, you may be invited to maintain the code base for that package.

Edit: more info on contributing via the "Contribute" link in my signature.

Last edited by ToZ (2022-01-01 20:07:25)

Online

#15 2022-01-01 20:15:11

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

I'll ask although I don't think I'll be able to take over as maintainer until I get a better distro.

Make is generating an error:

make[2]: Entering directory '/big/zack/xfce4-notes-plugin/lib'
  VALAC    libnotes_la_vala.stamp
/bin/bash: line 1: --library=libnotes: command not found
make[2]: *** [Makefile:635: libnotes_la_vala.stamp] Error 127

Maybe my valac is too new or too old. I'm not sure what using valac is meant to achieve.

Last edited by Moi (2022-01-01 20:27:40)

Offline

#16 2022-01-01 20:52:36

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,836

Re: Notes is crashing

Did it work earlier and its not working now?

I don't even have vala installed on my VM - which is odd.

Where did you get your tarball? archive.xfce.org?

Edit: I installed valac 0.48.17-1 and the make still worked. Try running a "make clean" then "make" again.

Last edited by ToZ (2022-01-01 20:54:58)

Online

#17 2022-01-06 12:41:56

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

OK yes, make clean & make worked for me. It builds now.

It seems odd that that they wrote this in a largely unheard of language.

Last edited by Moi (2022-01-06 12:44:51)

Offline

#18 2022-01-16 16:08:40

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

Correction: I checked out the code again with the intention of making the 1-line fix. This new code does not compile. I get the error from above regardless of doing "make clean".

Offline

#19 2022-01-16 16:16:43

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,836

Re: Notes is crashing

Can you post back all the commands you entered (starting with the git checkout), and the output of those commands?

Online

#20 2022-01-17 21:11:57

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

git clone https://gitlab.xfce.org/panel-plugins/xfce4-notes-plugin
cd xfce4-notes-plugin
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib/$(uname -m)-linux-gnu
make clean
make
Result:
/bin/bash: line 1: --library=libnotes: command not found

So if I try instead
VALAC=valac  ./configure --prefix=/usr --libdir=/usr/lib/$(uname -m)-linux-gnu
I get:
error: Package `libxfconf-0' not found in specified Vala API directories or GObject-Introspection GIR directories
error: Package `libxfce4util-1.0' not found in specified Vala API directories or GObject-Introspection GIR directories
But I have these installed already.

Offline

#21 2022-01-18 02:25:51

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,836

Re: Notes is crashing

See: https://gitlab.xfce.org/panel-plugins/x … /issues/69. Looks like there is some sort of issue with xfconf build in the debian repos.

Edit: I am able to build xfce4-notes-plugin version 1.9.0 (get it from https://archive.xfce.org/src/panel-plug … lugin/1.9/) on bullseye using the following:

./configure --prefix=/usr --libdir=/usr/lib/$(uname -m)-linux-gnu --disable-maintainer-mode
make
sudo make install

The following vala packages are installed:

$ dpkg -l | grep vala | awk '{print $2}'
libvala-0.48-0:amd64
libvalacodegen-0.48-0:amd64
valac
valac-0.48-vapi
valac-bin

Last edited by ToZ (2022-01-18 11:58:01)

Online

#22 2022-01-20 16:42:49

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

Here are my packages:

$ dpkg -l | grep vala | awk '{print $2}'
libvala-0.48-0:arm64
libvalacodegen-0.48-0:arm64
vala-panel-appmenu-common
valac
valac-0.48-vapi
valac-bin

Just to make anything I have to do this:

VALAC=`which valac` ./configure --prefix=/usr --libdir=/usr/lib/$(uname -m)-linux-gnu --disable-maintainer-mode

I wonder if perhaps this project should be converted to C and the Vala code be abandoned.

Last edited by Moi (2022-01-20 16:44:47)

Offline

#23 2022-01-20 20:07:13

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,836

Re: Notes is crashing

Moi wrote:

I wonder if perhaps this project should be converted to C and the Vala code be abandoned.

I don't think the product currently has a maintainer - someone would need to take over that role.

Online

#24 2022-01-22 15:32:42

Moi
Member
Registered: 2022-01-01
Posts: 15

Re: Notes is crashing

ToZ wrote:
Moi wrote:

I wonder if perhaps this project should be converted to C and the Vala code be abandoned.

I don't think the product currently has a maintainer - someone would need to take over that role.

I would be willing to perform that conversion, as I want to improve my GTK skills anyway.
In the end the admin would have to accept my MR, so I'll ask him what he thinks.

Offline

Board footer

Powered by FluxBB