Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-08-25 18:32:13

f0lskPrat1mA
Member
Registered: 2022-08-25
Posts: 3

Help debugging xfce4-appearance.

Hello.

My system is Debian 11.

In brief, I'm installing new version of Libreoffice using binaries provided by The Document Foundation (still branch), but this new version renders HighContrast theme awfully. This only exists in new versions of Libreoffice (old ones display everything correctly), so initially I thought it's their issue, but not really.

Initial steps I took.

I logged into jwm and tried launching LO there and suddenly everything just worked. I figured it's theme issue and used (now in xfce) Appearance to set Adwaita (which I hate). With Adwaita everything is OK.

I went further and did (in jwm)

GTK_DATA_DIR=/usr GTK_THEME='HighContrast' ./soffice --impress

and everything worked! I thought maybe it's variables' failure and tested it with GTK_THEME='Adwaita-dark' and the theme was dark, so variables do take effect.

I again went back to xfce, set theme back to HighContrast, and tried the same approach and manually set Adwaita-dark (dark so that I can clearly see variables are honored) and theme rendering is broken again.

At first I was confused, then I tried setting every theme I had (see the list below) using mentioned variables, while keeping HighContrast in Appearance, and things were broken. Then I tried setting the very same themes using Appearance, while not using the variables at all, and everything was OK.

The last thing I did is I set Adwaita in Appearance and used variables to select HighContrast theme and things just worked.

With what's written above it's almost clear that Appearance changes something else, that makes HighContrast theme to break.

Further investigations.

Installed HighContrast from Arch repo. Of course, it made things ten times worse, heh...

Installed Arch with libreoffice-still and obviously everything was Ok, thought I, and actually installed Arch with libreoffice-still. Even official LO from Arch repository is broken in Arch, when HighContrast theme is selected in Appearance.

In this way, it is obviously issue between either HighContast theme or Appearance and Libreoffice.


I'd really hate to abandon xfce just because of this, could you please help me with debugging? Because I'm absolutely clueless as to where even to start.

Offline

#2 2022-08-25 18:34:41

f0lskPrat1mA
Member
Registered: 2022-08-25
Posts: 3

Re: Help debugging xfce4-appearance.

Themes list:
Adwaita, Adwaita-ark, Cyanogen, Neon_Knights_Orange  Neon_Knights_Yellow, Neon_Knights_Blue, Neon_Knights_Red, Neon_Knights_Green, Neon_Knights_Violet.

Offline

#3 2022-08-25 19:28:45

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,524

Re: Help debugging xfce4-appearance.

Hello and welcome.

In brief, I'm installing new version of Libreoffice using binaries provided by The Document Foundation (still branch), but this new version renders HighContrast theme awfully.

Can you explain what you mean by "awfully"? What are you seeing that you feel is broken? Maybe share a screenshot.

Even official LO from Arch repository is broken in Arch, when HighContrast theme is selected in Appearance.

I've installed LO from the Arch repo and with High Contrast theme, it looks fine to me:
LO.png

Can you post back the results of:

cat ~/.config/gtk-3.0/gtk.css
cat ~/.config/gtk-3.0/settings.ini

Edit:

Installed HighContrast from Arch repo. Of course, it made things ten times worse, heh...

Do you mean you installed gnome-themes-extra?

Last edited by ToZ (2022-08-25 19:31:34)

Offline

#4 2022-08-26 05:59:22

f0lskPrat1mA
Member
Registered: 2022-08-25
Posts: 3

Re: Help debugging xfce4-appearance.

Hello and welcome.

Thank you.

Can you explain what you mean by "awfully"?. I've installed LO from the Arch repo and with High Contrast theme, it looks fine to me.

Why, of course. Firstly, look at text fields on your slide. Select any and look at the borders, they are just ugly mesh. Next, try moving that text field dragging it by border. For me, it is super laggy. Type some text in any of the text boxes. Even typing is very sluggish for me. Then select your text and selection will be black. Now open writer and in left upper corner you'll see your current text style. Select it and selection will be blue. It must be blue everywhere. And finally, (in any part of the suite, be it impress or calc or whatever), look at the right side. There must be panel with icons and you only see empty (but clickable) squares. I only investigated this far, the list of bugs may go on. I'll repeat that this only happens with upstream Libreoffice and other themes do just fine, without lags and incorrect rendering.

Can you post back the results of:

Sure.

$ ls ~/.config/gtk-3.0
bookmarks  settings.ini
$ cat settings.ini
[Settings]
gtk-application-prefer-dark-theme=0

Do you mean you installed gnome-themes-extra?

I just copied /usr/share/themes/HighContrast form Arch installation to Debian installation. That was kind of desperate, for the sake of experiment.

By the way, I went a little further, and typed text below into settings.ini

[Settings]
gtk-application-prefer-dark-theme=0
gtk-theme-name = HighContrast

and then logged into jwm. Rendering was broken. So maybe I was wrong and it is nevertheless Libreoffice issue?

Offline

Board footer

Powered by FluxBB