Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-06-01 08:29:55

matchi
Member
Registered: 2019-12-18
Posts: 5

libsystray.so not showing new icons - dbind-WARNING

Hi there,

I'm struggling some time (AFAIR since Xubuntu 20.04) with an annoying behaviour of the systray panel plugin.
The plugin doesn't show icons from started applications until I send a SIGHUP to the panel process via

pkill -HUP -f systray

I get corresponding events when starting an application:

$ PANEL_DEBUG=1 xfce4-panel
xfce4-panel(main): version 4.16.3 on gtk+ 3.24.30 (3.24.29), glib 2.68.4 (2.68.3)
[...]
xfce4-panel(module): new item (type=external-wrapper, name=systray, id=8)
xfce4-panel(external): systray-8: child spawned; pid=11214, argc=7
xfce4-panel(application): saving /panels/panel-0: ids=true, providers=false

(wrapper-2.0:11214): dbind-WARNING **: 09:49:14.349: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
xfce4-panel(external): systray-8: child is embedded; 8 properties in queue
xfce4-panel(systray): rgba visual is 0x55e033be84a0
xfce4-panel(systray): registered manager on screen 0
xfce4-panel(struts): 0x556464196470: bottom=49, start_x=0, end_x=1919

(twinkle:11228): dbind-WARNING **: 09:49:24.024: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

I didn't find any posts here about the topic - searched for "wrapper | dbind | systray".
Any ideas on this?

kind regards
Mathias


:-d

Offline

#2 2022-06-01 11:06:05

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: libsystray.so not showing new icons - dbind-WARNING

Are you currently using Xubuntu 20.04?

Does this happen with all applications or just some?

I believe the accessibility bus message is a red herring. It means that it can't find any accessibility devices and times out. If you add:

export NO_AT_BRIDGE=1

somewhere like ~/.bashrc, it should silence the warning.

Perhaps you ca post the full contents of your ~/.xsession-errors file after a fresh login?
Also, can you create a second test account on your computer and try this new profile to see if the problem exists there as well.

Offline

#3 2022-06-13 20:21:43

matchi
Member
Registered: 2019-12-18
Posts: 5

Re: libsystray.so not showing new icons - dbind-WARNING

Hi ToZ,

thanks for the hint, you were right about that fish.
At least, I found a solution:

Purge: ayatana-indicator-application:amd64 (22.2.0-1)

I didn't went into a deep dive of how this neat little tool works inside the dbus-structures for XFCE-indicator-plugins, but it seems to block/filter/discard certain neccessary communication for libsystray.so.

Maybe I find some motivation for a bug report someday...

kind regards
Mathias


:-d

Offline

#4 2022-08-27 18:29:10

k3dAR
Member
From: Czech Republic
Registered: 2022-07-27
Posts: 5

Re: libsystray.so not showing new icons - dbind-WARNING

hi, i have same problem too (with xfce4-panel 4.17.2-1~bpo22.04 from XubuntuDev PPA),
find this thread and can confirm that kill ayatana-indicator-application-service solve problem...

anyway now i get update xfce4-panel to 4.17.3-1~bpo22.04 and problem is gone,
(with running ayatana-indicator-application-service, tested for sure with reboot),
so i think problem fixed by:

- systray: Help to keep status notifiers from vanishing (#102, #243, #599) link

thanks dev's smile

Offline

Board footer

Powered by FluxBB