Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-09-27 20:49:03

artivision
Member
Registered: 2022-09-24
Posts: 5

How to disable Dwell click in Xfce?

When i Left Click if i move just a pixel then the Release Counts as Hold_Release aka Left Click. Even if i Release as fast as a human can, a pixel hand tremble movement chooses a Highlighted option from a Pop Up Menu.

Offline

#2 2022-09-27 21:54:49

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: How to disable Dwell click in Xfce?

Hello and welcome.

I'm confused about the title and content of your message. "Dwell click" refers to functionality where a mouse clicks itself when you hover over an element on the screen. However, in the content of your post you talk about left-click and release - this isn't dwell click.

So its a little confusing as what you are experiencing.

Can you give detailed instructions on the steps you are taking (where you clicking, which application, which button) and what is happening?

hand tremble movement chooses a highlighted option from a popup menu

This is an interesting example of maybe the spacing between the mouse pointer and the first element in a dialog being off - but this doesn't have anything to do with "dwell clicks".

Which Appearance theme are you using? If you try another Appearance theme, does it work better?

Online

#3 2022-09-28 01:36:13

artivision
Member
Registered: 2022-09-24
Posts: 5

Re: How to disable Dwell click in Xfce?

Example: Lets say that i left click for a default thunar menu. If i left click and hold, i can move the mouse normally upon lets say "create folder" option and release the left click there, it will count as right click choosing "create folder". Unfortunately every left click counts as left hold if i accidentally move the mouse a few pixels, choosing random options that the cursor is upon.

Because several people in various forums lie to me, please can you confirm that this is an XFCE future? Also is it removable?

Offline

#4 2022-09-28 02:10:00

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: How to disable Dwell click in Xfce?

What would you prefer would happen then in this instance? Click and hold the mouse, move to another menu item, release the mouse and .... (not select the highlighted item?)

Are you referring to some sort of forced "click to activate" on all menu items?

Online

#5 2022-09-28 19:11:56

artivision
Member
Registered: 2022-09-24
Posts: 5

Re: How to disable Dwell click in Xfce?

Its not a matter to what i want to happen but what shouldn't happen and that is not to accidentally erase something important. Right click menu options should only be checked with the left click when highlighted by the cursor. That is the Windows default behavior.

Offline

#6 2022-09-29 02:52:08

CwF
Member
Registered: 2018-01-28
Posts: 244

Re: How to disable Dwell click in Xfce?

On standard setups it is the right click than opens the menu is it not?
And a second tight click to select?
No left clicking applicable here?

Offline

#7 2022-09-29 10:48:08

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: How to disable Dwell click in Xfce?

I believe and example of OP's issue is to left-click and hold on a menu (e.g. thunar menu bar) and while holding down the mouse button, move the mouse over various menu items. When you release the mouse button, the menu item that is highlighted is executed. So activation on mouse release. I believe OP is looking to disable that feature, and I'm not sure that is possible in GTK3 - or at least I haven't been able to find anything.

Or maybe there is some sort of accessibility feature that would allow for this? Still looking though.

Online

#8 2022-09-29 11:09:17

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: How to disable Dwell click in Xfce?

Online

#9 2022-09-30 00:09:07

artivision
Member
Registered: 2022-09-24
Posts: 5

Re: How to disable Dwell click in Xfce?

ToZ wrote:

That partially solves the problem. Now if i accidentally drag the mouse during left-click, there is no popup menu and a red gesture curve shows instead. Also i notice now overhead.

Offline

#10 2022-09-30 02:10:55

artivision
Member
Registered: 2022-09-24
Posts: 5

Re: How to disable Dwell click in Xfce?

Can i at least disable client events or buttons in Gtk3? Is this link related:

https://www.anycodings.com/1questions/1 … ns-in-gtk3

Offline

Board footer

Powered by FluxBB