Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-10-31 05:42:42

minotaursteak
Member
Registered: 2022-10-31
Posts: 3

Flickering on title bars and menus

Hello,

I'm using Xfce 4.16 on Debian 11. When switching windows, I occasionally see flickering on the title bars and drop-down menus.

Video: https://i.imgur.com/yq0ElIc.mp4

This happens when using Xfce's built-in compositor as well as Picom. I did not run into this issue while running Linux Mint 21 Xfce, so it seems likely this may be a Debian-specific issue on my hardware rather than an Xfce issue. Having said that, I would appreciate any troubleshooting tips you may have.

System Specs:

System:    Kernel: 5.18.0-0.deb11.4-amd64 x86_64 bits: 64 compiler: gcc v: 10.2.1 
           Desktop: Xfce 4.16.0 Distro: Debian GNU/Linux 11 (bullseye) 
Machine:   Type: Laptop System: Acer product: Aspire 4733Z v: N/A serial: <filter> 
           Mobo: Acer model: JE41-MV serial: <filter> BIOS: Phoenix v: 1.05 date: 12/20/2010 
Battery:   ID-1: BAT1 charge: 43.9 Wh condition: 43.9/48.8 Wh (90%) model: SIMPLO AS10C5E 
           status: Full 
CPU:       Info: Dual Core model: Pentium T4500 bits: 64 type: MCP arch: Penryn rev: A 
           L2 cache: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 9176 
           Speed: 1197 MHz min/max: 1200/2300 MHz Core speeds (MHz): 1: 1197 2: 1367 
Graphics:  Device-1: Intel Mobile 4 Series Integrated Graphics vendor: Acer Incorporated ALI 
           driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: Sunplus 1.3M HD WebCam type: USB driver: uvcvideo bus ID: 7-8:2 
           Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting unloaded: fbdev,vesa 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express (CTG) v: 2.1 Mesa 20.3.5 
           direct render: Yes 
Audio:     Device-1: Intel 82801I HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.18.0-0.deb11.4-amd64 
Network:   Device-1: Qualcomm Atheros AR9287 Wireless Network Adapter vendor: Foxconn T77H167.00 
           driver: ath9k v: kernel port: 18e0 bus ID: 07:00.0 
           IF: wlan0 state: up mac: <filter> 
           Device-2: Broadcom NetLink BCM57780 Gigabit Ethernet PCIe 
           vendor: Acer Incorporated ALI driver: tg3 v: kernel port: 18e0 bus ID: 09:00.0 
           IF: eth0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.04 TiB used: 11.85 GiB (1.1%) 
           ID-1: /dev/sda vendor: Toshiba model: MK6465GSX size: 596.17 GiB 
           ID-2: /dev/sdb type: USB vendor: Seagate model: ST9500325AS size: 465.76 GiB 
Partition: ID-1: / size: 596.17 GiB used: 11.85 GiB (2.0%) fs: btrfs dev: /dev/sda1 
           ID-2: /home size: 596.17 GiB used: 11.85 GiB (2.0%) fs: btrfs dev: /dev/sda1 
           ID-3: /tmp size: 596.17 GiB used: 11.85 GiB (2.0%) fs: btrfs dev: /dev/sda1 
           ID-4: /var/log size: 596.17 GiB used: 11.85 GiB (2.0%) fs: btrfs dev: /dev/sda1 
Swap:      ID-1: swap-1 type: zram size: 3.5 GiB used: 0 KiB (0.0%) dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 177 Uptime: 16m Memory: 3.68 GiB used: 851.5 MiB (22.6%) Init: systemd 
           runlevel: 5 Compilers: gcc: 10.2.1 Packages: 1584 Shell: Bash v: 5.1.4 inxi: 3.3.01

Offline

#2 2022-10-31 10:47:24

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,524

Re: Flickering on title bars and menus

Hello and welcome.

Does this happen with all windows? (video shows mousepad - does it also happen with thunar)?

With xfwm4's compositor enabled, do any of the different vblank modes make a difference?

Edit: are you using the xorg-video-intel driver? If so, uninstall it and let the kernel driver load.

Last edited by ToZ (2022-10-31 10:51:56)

Offline

#3 2022-11-01 00:02:27

minotaursteak
Member
Registered: 2022-10-31
Posts: 3

Re: Flickering on title bars and menus

Thanks for the reply.

I don't recall if Thunar was affected, but I did recently see the issue in Synaptic and xfce4-terminal. Because of the intermittent nature of this issue, I cannot easily replicate it on-demand.

I checked my packages and confirmed that xserver-xorg-video-intel is not installed.

I will re-enable the compositor and experiment with the different vblank modes. Out of curiosity, would those vblank modes apply to Picom or does Picom have its own settings? Without Picom, I have really bad screen tearing.

Offline

#4 2022-11-01 00:18:12

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,524

Re: Flickering on title bars and menus

They won't work with picom - thats an alternative to xfwm4's compositor. For this test, disable/stop picom, enable xfwm4's compositor, and try the different vblank modes.

Offline

#5 2022-11-17 05:18:24

minotaursteak
Member
Registered: 2022-10-31
Posts: 3

Re: Flickering on title bars and menus

I changed the vblank mode to xpresent a couple weeks ago and am happy to report that the issue is resolved. Thanks, ToZ!

Now I need to make this work with Picom since the screen tearing is pretty severe without it.

Picom seems to have three backends to choose from: xrender, glx and xr_glx_hybrid. Since glx caused the flickering with Xfce's vblank mode, I'm guessing it's also the cause of the flickering in Picom. Admittedly, I initially configured Picom to use glx because the documentation led me to believe it was better. I will revert Picom to the xrender backend and see if it fixes the issue.

Offline

Board footer

Powered by FluxBB