Xfce Forum

Sub domains
 

You are not logged in.

#1 2023-01-11 18:48:13

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Login Window

Hi, I installed Mint Xfce 21.1 in a laptop, fonts were way too small, I did some scaling, things are fine now, except in my login window. There is no option in loginwindow/settings for fonts.
Tried to edit etc/lightdm/lightdm-gtk-greeter.conf.d/99_linuxmint.conf/ file, it does have zero effects. Is there a trick to increase fonts, maybe in gtk3.css file?
Thank you!!


Linux Mint Xfce 21.1

Offline

#2 2023-01-11 22:18:24

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: Login Window

What change did you make to that file? Did you restart lightdm?

There is a lightdm-gtk-greeter-settings application that gives you a GUI to make changes to the greeter for light. Is it available in Mint?


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#3 2023-01-11 23:17:06

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Re: Login Window

Hi ToZ,
font-name=Ubuntu 15

It was 11.
I did a restart, did not restart lightdm.
I installed greeter-settings, it did not do any good either.


Linux Mint Xfce 21.1

Offline

#4 2023-01-12 02:09:08

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: Login Window

Try:

font-name = Ubuntu 15

instead (note the spaces). I assume the Ubuntu font installed on your system and in a system location?


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#5 2023-01-12 02:21:55

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Re: Login Window

Thanks ToZ. I tried, didn't make any difference. Ubuntu font is installed by default, I even tried some different fonts, nothing changes.


Linux Mint Xfce 21.1

Offline

#6 2023-01-12 02:47:41

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: Login Window

Can you post the contents of both /etc/lightdm/lightdm.conf and /etc/lightdm/lightdm-gtk-greeter.conf.d/99_linuxmint.conf?

Also post back the contents of /var/log/lightdm/seat0-greeter.log.

Edit: just had a look at a mint VM. It looks like it logs to ~/.cache/lightdm/log. It also looks like it uses the slick-greeter. And if that is the case, see: https://github.com/linuxmint/slick-greeter/issues/50

Last edited by ToZ (2023-01-12 03:40:07)


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#7 2023-01-12 17:05:58

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Re: Login Window

Thanks ToZ for looking into this. I think I can live with smaller fonts in login window, I might be old, but not blind (yet).
The link you found is interesting, but it's 2-3 years old! What are those Mint guys doing??
The strange thing is that I installed the same thing in my wife's old laptop and it looks perfect, including login fonts. At least twice as large.
Thanks again!


Linux Mint Xfce 21.1

Offline

#8 2023-01-12 17:34:55

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: Login Window

Check to see which greeter she is using. It would be shown in the ~/.cache/lightdm/log/seat0-greeter.log file.

The lightdm-gtk-greeter allows fonts to be set, if you're looking for an alternative.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#9 2023-01-12 17:40:21

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Re: Login Window

Toz, it should be in /home/cache/ right?
There is no lightdm there.


Linux Mint Xfce 21.1

Offline

#10 2023-01-12 17:41:55

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: Login Window

/home/user/.cache (where user is your username)

Its a hidden directory. Within that directory there should be a lightdm directory.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#11 2023-01-12 17:47:10

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Re: Login Window

There is no lightdm in my .cache.


Linux Mint Xfce 21.1

Offline

#12 2023-01-12 17:53:36

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Re: Login Window

However, there is a slick-greeter.conf file in /etc/lightdm/

[Greeter]
background=/usr/share/backgrounds/7455424.jpg
show-clock=false
show-keyboard=false
show-power=false
icon-theme-name=shadow
theme-name=Mint-Y-Aqua
cursor-theme-name=+UEChameleon
enable-hidpi=auto
show-a11y=false


Linux Mint Xfce 21.1

Offline

#13 2023-01-12 21:24:59

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: Login Window

agashamu wrote:

There is no lightdm in my .cache.

Thats odd. There is in 21.2. Maybe it was changed?


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#14 2023-01-12 21:25:19

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: Login Window

agashamu wrote:

However, there is a slick-greeter.conf file in /etc/lightdm/

[Greeter]
background=/usr/share/backgrounds/7455424.jpg
show-clock=false
show-keyboard=false
show-power=false
icon-theme-name=shadow
theme-name=Mint-Y-Aqua
cursor-theme-name=+UEChameleon
enable-hidpi=auto
show-a11y=false

I can't change the font either with the slick greeter.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#15 2023-01-12 22:17:52

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Re: Login Window

Mine is 21.1, it was upgraded with Mintupdater from 21.0
I remember getting an update a couple of days ago, remember seeing "slick" in there, I didn't even know what it was, I just let it go.
Synaptic shows both slick and lightdm installed. What if I just remove slick? Would it fix it?


Linux Mint Xfce 21.1

Offline

#16 2023-01-12 22:37:13

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: Login Window

slick is the greeter. lightdm is the display manager. You need both a display manager and a greeter. You could install lightdm-gtk-greeter and update lightdm.conf to use that greeter instead of slick.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#17 2023-01-12 22:45:45

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Re: Login Window

It is installed! lightdm-gtk-greeter  version:2.0.8-2ubuntu1


Linux Mint Xfce 21.1

Offline

#18 2023-01-12 23:10:25

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Re: Login Window

2023-01-12-14-50.png


Do I need all these folders, files??


Linux Mint Xfce 21.1

Offline

#19 2023-01-12 23:29:09

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: Login Window

If they were part of the package, then yes. Best to leave them there and let the package manager control them.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#20 2023-01-12 23:42:40

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Re: Login Window

OK.
So how do I update lightdm.conf?

[greeter]
background=/usr/share/backgrounds/linuxmint/default_background.jpg
theme-name=Mint-X
icon-theme-name=Mint-X
font-name = Ubuntu 20
xft-antialias=true
xft-dpi=101
xft-hintstyle=hintslight
xft-rgba=rgb
indicators=~host;~spacer;~clock;~spacer;~session;~a11y;~language;~power
keyboard=onboard
reader=orca
position = 50%,center 50%,center
default-user-image = #avatar-default
screensaver-timeout = 60
a11y-states=contrast;font;keyboard;reader
user-background = false
clock-format = %a %d %b, %H:%M


Linux Mint Xfce 21.1

Offline

#21 2023-01-12 23:52:43

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: Login Window

agashamu wrote:

OK.
So how do I update lightdm.conf?

I'm not exactly sure how Mint does it, but since its based on Ubuntu, maybe this can help: https://wiki.ubuntu.com/LightDM#Changing_the_Greeter


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#22 2023-01-13 00:16:44

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Re: Login Window

I read the link, checked the files, all is set the way it should be,


[SeatDefaults]
user-session=xfce

there is nothing I can do.
Thank you ToZ!!!


Linux Mint Xfce 21.1

Offline

#23 2023-01-17 22:52:43

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 112

Re: Login Window

Hi ToZ, a good friend of mine in Hungary helped me out, he created this script, it works, my login window is now perfect in size.

#!/bin/bash
if [[ ! -f "/usr/bin/slick-greeter-check-hidpi.bak" ]]; then
    mv /usr/bin/slick-greeter-check-hidpi /usr/bin/slick-greeter-check-hidpi.bak
cat <<_EOF >/usr/bin/slick-greeter-check-hidpi
#!/usr/bin/python3

import gi
gi.require_version('Gdk', '3.0')
from gi.repository import Gdk
import sys
import os
import syslog

HIDPI_LIMIT = 143

def get_window_scale():
    window_scale = 1
    try:
        display = Gdk.Display.get_default()
        screen = display.get_default_screen()
        primary = screen.get_primary_monitor()

        rect = screen.get_monitor_geometry(primary)
#        width_mm = screen.get_monitor_width_mm(primary)
#        height_mm = screen.get_monitor_height_mm(primary)
#        monitor_scale = screen.get_monitor_scale_factor(primary)
        scale = rect.width / 1024
        window_scale = round ( scale )
        # Return 1 if the screen size isn't available (some TVs report their aspect ratio instead ... 16/9 or 16/10)
#        if ((width_mm == 160 and height_mm == 90) \
#            or (width_mm == 160 and height_mm == 100) \
#            or (width_mm == 16 and height_mm == 9) \
#            or (width_mm == 16 and height_mm == 10)):
#            return 1

#        if rect.height * monitor_scale < 1500:
#            return 1

#        if width_mm > 0 and height_mm > 0:
#            witdh_inch = width_mm / 25.4
#            height_inch = height_mm / 25.4
#            dpi_x = rect.width * monitor_scale / witdh_inch
#            dpi_y = rect.height * monitor_scale / height_inch
#            if dpi_x > HIDPI_LIMIT and dpi_y > HIDPI_LIMIT:
#                window_scale = 2

    except Exception as detail:
        syslog.syslog("Error while detecting hidpi mode: %s" % detail)

    return window_scale

if __name__ == '__main__':
    window_scale = get_window_scale();
    syslog.syslog("Window scale: %d" % window_scale)
    print (window_scale)
    sys.exit(0)
_EOF
chmod +x /usr/bin/slick-greeter-check-hidpi

echo "enable-hidpi=on" >> /etc/lightdm/lightdm-gtk-greeter.conf.d/99_linuxmint.conf 


else echo "már buherált a greeter, mert van backup!"
fi

Linux Mint Xfce 21.1

Offline

#24 2023-01-17 23:42:35

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: Login Window

Thanks for sharing.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

Board footer

Powered by FluxBB