Xfce Forum

Sub domains
 

You are not logged in.

#1 2023-01-24 23:49:19

wrh1728
Member
Registered: 2020-12-15
Posts: 35

Zoom won't launch

This is under Slackware64 15.0, which uses Xfce 4.16.

When I attempt to launch the zoom application from the Xfce Menu -> Internet -> zoom nothing happens, except for the fact that the following diagnostics are printed out at the X server's log:

(wrapper-2.0:1749): GLib-GObject-WARNING **: 15:11:49.394: instance with invalid (NULL) class pointer

(wrapper-2.0:1749): GLib-GObject-CRITICAL **: 15:11:49.394: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(wrapper-2.0:1749): libsystray-CRITICAL **: 15:11:49.394: sn_item_invalidate: assertion 'XFCE_IS_SN_ITEM (item)' failed

The zoom package is installed under /opt/zoom-linux. In this directory there is an executable named ZoomLauncher. When I invoke it from the command line, it returns after one second or so, with the diagnostics mentioned above appearing in the X server's log. Nothing else happens: the zoom client apparently can't be launched.

Any idea as to what is going on, and how to solve the problem?

Offline

#2 2023-01-25 00:20:22

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,792

Re: Zoom won't launch

Looks like an issue putting the tray icon in the tray.

Exactly which version of xfce4-panel?

xfce4-panel -V

And which (tray) panel plugins do you have installed?

xfconf-query -c xfce4-panel -lv | grep "plugin-.. "

Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#3 2023-01-25 00:33:58

wrh1728
Member
Registered: 2020-12-15
Posts: 35

Re: Zoom won't launch

Here you are:

$ xfce4-panel -V
xfce4-panel 4.16.3 (Xfce 4.16)

Copyright (c) 2004-2011
    The Xfce development team. All rights reserved.

Please report bugs to <http://bugzilla.xfce.org/>.

$ xfconf-query -c xfce4-panel -lv | grep "plugin-.. "
/plugins/plugin-1                             separator
/plugins/plugin-10                            datetime
/plugins/plugin-11                            separator
/plugins/plugin-12                            launcher
/plugins/plugin-13                            launcher
/plugins/plugin-14                            launcher
/plugins/plugin-15                            launcher
/plugins/plugin-16                            launcher
/plugins/plugin-17                            launcher
/plugins/plugin-18                            launcher
/plugins/plugin-19                            separator
/plugins/plugin-2                             separator
/plugins/plugin-20                            launcher
/plugins/plugin-21                            launcher
/plugins/plugin-22                            separator
/plugins/plugin-23                            separator
/plugins/plugin-24                            launcher
/plugins/plugin-25                            launcher
/plugins/plugin-26                            launcher
/plugins/plugin-27                            systemload
/plugins/plugin-28                            launcher
/plugins/plugin-29                            separator
/plugins/plugin-3                             tasklist
/plugins/plugin-30                            separator
/plugins/plugin-31                            systray
/plugins/plugin-32                            launcher
/plugins/plugin-33                            cpugraph
/plugins/plugin-34                            pager
/plugins/plugin-35                            weather
/plugins/plugin-36                            launcher
/plugins/plugin-37                            launcher
/plugins/plugin-38                            actions
/plugins/plugin-39                            xfce4-sensors-plugin
/plugins/plugin-4                             screenshooter
/plugins/plugin-40                            pulseaudio
/plugins/plugin-41                            launcher
/plugins/plugin-42                            launcher
/plugins/plugin-43                            netload
/plugins/plugin-44                            launcher
/plugins/plugin-45                            launcher
/plugins/plugin-46                            mailwatch
/plugins/plugin-47                            launcher
/plugins/plugin-48                            launcher
/plugins/plugin-5                             applicationsmenu
/plugins/plugin-50                            launcher
/plugins/plugin-52                            launcher
/plugins/plugin-6                             launcher
/plugins/plugin-7                             launcher
/plugins/plugin-8                             clock
/plugins/plugin-9                             launcher

Offline

#4 2023-01-25 00:47:19

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,792

Re: Zoom won't launch

Are you able to upgrade xfce4-panel? The current 4.16 version is 4.16.6 and there have been some systray fixes since your version.

Also, can you try running the panel in debug mode to see if it generates any other information when you start zoom?

xfce4-panel -q
PANEL_DEBUG=all xfce4-panel

Similar messages but more extreme than yours is https://gitlab.xfce.org/xfce/xfce4-panel/-/issues/688. Also they are running 4.18.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#5 2023-01-25 01:15:51

wrh1728
Member
Registered: 2020-12-15
Posts: 35

Re: Zoom won't launch

I don't think I will be able to upgrade it in the short term. I'll see. This aside, starting xfce4-panel as you described does not result in any new diagnostics when launching zoom.

Offline

#6 2023-01-25 15:24:30

wrh1728
Member
Registered: 2020-12-15
Posts: 35

Re: Zoom won't launch

After doing some poking around, this is not an Xfce thing at all - it seems to be an issue to do with a shared library shipped with zoom, and it has been reported in other Linux distributions and under KDE as well.

Offline

Board footer

Powered by FluxBB