Xfce Forum

Sub domains
 

You are not logged in.

#1 2023-03-19 00:05:16

youni
Member
Registered: 2023-02-28
Posts: 10

Xfce4 on Slackware 15.0 was broken

Hello! I use Slackware 15.0 with Xfce4, dbus, sysvinit (or own scripts from slackware).
I removed some packages here and now Xfce4 works but "Applications menu" and windows button and also Keyboard layout plugins cannot start with message: Plugin "Applications Menu" unexpectedly left the panel, do you want to restart it?

I removed these packages, caould you say which of them should be turned back for xfce4?

seamonkey mozilla-thunderbird
samba speech-dispatcher nfsd cups dovecot httpd
ksirk konquest klines knetwalk kmines klickety kjumpingcube killbots katomic picmi rocs knavalbattle kpat kubrick ksudoku kdiamond khangman kanagram blinken lskat ksquares kreversi knights kmahjongg kiriki kigo kfourinline kblackbox bovo kspaceduel ksnakeduel kollision kolf kgoldrunner kbreakout kbounce kblocks kapman granatier bomber filelight kdf kshisen xsnow windowmaker xaos xgames gnuchess nethack
kalzium kstars cantor kalgebra step minuet kturtle ktouch kgeography kmplot kbruch parley kwordquiz kiten artikulate kig analitza alkimia kdeedu-data kdiagram
krusader kdfkteatime kalarm bitinerary kfloppy kjots ktimer ktimetracker kopete konversation krdc krfb ktnef sieveeditor kamoso kid3 kmymoney akregator pim-sieve-editor kget kmail-account-wizard kmail cervisia  kcontacts kde-dev-scripts kde-dev-utils kdepim-addons kdepim-runtime kdesdk-kioslaves kdesdk-thumbnailers kdesignerplugin kdev-php kdev-python kdevelop kdevelop-pg-qt kapptemplate kirigami-gallery korganizer kruler kdeconnect-kde calligraplan calligra zanshin kile kaddressbook kontact kontactinterface lokalize kontrast kcachegrind krita kimagemapeditor kbackup kmag kmousetool khelpcenter knotes sweeper kleopatra bsd-games
plasma-sdk 
latte-dock pidgin xmms gkrellm pan xine-ui xpaint xscreensaver gucharmap hplip skanlite xsane xfig dragon easytag digikam grantlee-editor pim-data-exporter kitinerary itinerary twm yakuake hexchat fcitx fcitx-anthy fcitx-configtool fcitx-hangul fcitx-kkc fcitx-libpinyin fcitx-m17n fcitx-qt5 fcitx-sayura fcitx-table-extra fcitx-table-other fcitx-unikey greybird kcm-fcitx konqueror tigervnc umbrello soma tumbler garcon akonadi-import-wizard v4l-utils
blackbox fluxbox fvwm geeqie gnome-keyring
xfce4-panel-profiles xfce4-screensaver xfce4-whiskermenu-plugin xfce4-clipman-plugin xfce4-dev-tools  xfce4-weather-plugin 

I hope that these packages are unnecessary: xfce4-panel-profiles xfce4-screensaver xfce4-whiskermenu-plugin xfce4-clipman-plugin xfce4-dev-tools  xfce4-weather-plugin.

I removed some other packages too, but I already reinstalled them, when saw errors:

#now xfce4 does not work
xfce4-panel -r
xfce4-panel: error while loading shared libraries: libxfce4ui-2.so.0: cannot open shared object file: No such file or directory

#https://slackware.pkgs.org/15.0/slackware-x86_64/libxfce4ui-4.16.1-x86_64-1.txz.html
installpkg /home/user/Downloads/libxfce4ui-4.16.1-x86_64-1.txz
#it was wrong to remove libxfce4ui

#now applets do not work
Plugin "Applications Menu" unexpectedly left the panel, do you want to restart it?
https://slackware.pkgs.org/15.0/slackwa … 1.txz.html
installpkg /home/user/Downloads/xfce4-panel-profiles-1.0.13-x86_64-1.txz

xfce4-screenshooter
xfce4-screenshooter: error while loading shared libraries: libexo-2.so.0: cannot open shared object file: No such file or directory
https://slackware.pkgs.org/15.0/slackwa … 1.txz.html
installpkg /home/user/Downloads/exo-4.16.3-x86_64-1.txz
#it was wrong to remove exo
xfce4-screenshooter
#works now
#but Application menu still cannot work

Offline

#2 2023-03-19 01:12:08

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,136

Re: Xfce4 on Slackware 15.0 was broken

xfce4-panel -q
PANEL_DEBUG=1 xfce4-panel

...and post back the debug output. There maybe something there to indicate why.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#3 2023-04-26 15:08:09

bigbadaboum
Member
Registered: 2022-12-22
Posts: 19

Re: Xfce4 on Slackware 15.0 was broken

hello youni,

xfce cannot work properly without garcon.
v4l-utils  is also a very important package.

if you are looking for lightness, I advise you to open a VM with a ISO by Eric Hameleers (aka alienbob) 908Mo xfce 4.18 slackware-current.
https://mirrors.slackware.devl.club/sla … urrent.iso
https://mirrors.slackware.devl.club/sla … nt.iso.asc
https://mirrors.slackware.devl.club/sla … nt.iso.md5

Best regards,

Offline

Board footer

Powered by FluxBB