Xfce Forum

Sub domains

You are not logged in.

#1 2023-05-16 03:55:42

Registered: 2014-08-16
Posts: 48

Upgrade to Xubuntu 23.04, can't login, popup loop, tty login info does

Hi folks.

I'm trying to login after upgrading to 23.04 via the GUI prompt. It warns of the dangers of not disabling your lock screen, but I was sure I didn't have a lock screen enabled.

The login prompt pops up, with my username, and a login button, which when clicked causes a blank screen for a second, then the same login screen pops up again.

I can select user "Other..." instead of my full name, and then put in my username, and try either my admin password, or blank (I don't use a login password), but nothing works, just prompts the login loop again. If I put my username into that box, the password box then disappears. I can enter my password first, then enter my username, but if I click tab after entering the username, the password box disappears again.

Based on this, possibly it could be solved by removing nvidia drivers, but my correct login info doesn't work in tty2. There was a question about that here, but never answered. Perhaps I could remove the drivers from the root prompt using the recovery boot option?

I reset my password using this, but nothing changes.

Someone on Reddit fixed it by picking a different desktop environment from the drop down menu, but my options are GNOME + Remmina kiosk (probably won't be this), Xfce session, and Xubuntu session (likely default), and none of them work.

Edit: an answer online suggests I should disable AutomaticLoginEnable in /etc/gdm3/custom.conf but the gdm3 folder doesn't exist in 23.04. It looks like lightdm is my /etc/X11/default-display-manager; /etc/lightdm/lightdm.conf has:




Based on online suggestions, I commented out the last 2 lines, saved, rebooted, aaaaand, no change. Based on a different suggestion I uncommented and then deleted my name from the second line. Also no change.

Edit: Next, nano /etc/group and commented out line beginning 'nopasswdlogin'. This at least prompts me for my password, which I have successfully changed/confirmed multiple times with "passwd". It doesn't work.

Any advice very gratefully received. Thanks!

Last edited by Sharky (2023-05-16 17:18:39)


#2 2023-05-19 06:58:50

Registered: 2019-10-11
Posts: 69

Re: Upgrade to Xubuntu 23.04, can't login, popup loop, tty login info does

Have you tried on other TTY, login, then startx? You can get the error of why the X server is refusing to start XFCE. Last time I did that, at least on the terminal, I can see the error


Board footer

Powered by FluxBB