Xfce Forum

Sub domains
 

You are not logged in.

#1 2023-11-03 00:40:50

Hkmxfce
Member
Registered: 2023-11-03
Posts: 3

Error code installing Xfce on Linux Mint

Here's a little snippet of what's going on here. I currently have Cinnamon on my desktop, and I wanted to install Xfce being that it's lighter-weight on my old computer. As a Linux newbie, I looked up the installation process online and just typed:

sudo apt-get install xubuntu-desktop -y

All was going well until I got this message:

Preparing to unpack .../189-xubuntu-default-settings_22.04.0_all.deb ...
Unpacking xubuntu-default-settings (22.04.0) ...
dpkg: error processing archive /tmp/apt-dpkg-install-YfzJyX/189-xubuntu-default-settings_22.04.0_all.deb (--unpack):
trying to overwrite '/etc/skel/.config/hexchat/hexchat.conf', which is also in package mint-artwork 1.7.5

So I didn't know what to do, figured I'd just type this in:

apt --fix-broken install

Still didn't work...then it said:

Preparing to unpack .../xubuntu-default-settings_22.04.0_all.deb ...
Unpacking xubuntu-default-settings (22.04.0) ...
<b>dpkg:</b> error processing archive /var/cache/apt/archives/xubuntu-default-settings_22.04.0_all.deb (--unpack):
trying to overwrite &apos;/etc/skel/.config/hexchat/hexchat.conf&apos;, which is also in package mint-artwork 1.7.5
Errors were encountered while processing:
/var/cache/apt/archives/xubuntu-default-settings_22.04.0_all.deb
<font color="#EF2929"><b>E: </b></font>Sub-process /usr/bin/dpkg returned an error code (1)


Any thoughts, Xfce community?

Last edited by Hkmxfce (2023-11-03 00:41:34)

Offline

#2 2023-11-03 01:41:07

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,202

Re: Error code installing Xfce on Linux Mint

Hello and welcome.

This is really an issue with Mint and the way they use/package xubuntu-default-settings_22.04.0 and mint-artwork_1.7.5. Both packages have the same /etc/skel/.config/hexchat files included (which is kind of a packaging no-no). At the very least, those two packages should conflict and the package manager should tell you that before attempting install.

I would recommend advising the Mint developers of this situation. Let them fix it in their repositories.

Looking closer at the Mint repositories, it looks like you might want to install the "mint-meta-xfce" package instead of xubuntu-desktop. It looks like it is the Mint branded install of Xfce.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#3 2023-11-03 12:51:07

Hkmxfce
Member
Registered: 2023-11-03
Posts: 3

Re: Error code installing Xfce on Linux Mint

Well, when I typed in that command:

sudo apt-get install mint-meta-xfce

I got this:

The following packages have unmet dependencies:
mint-meta-xfce : Depends: mintdesktop but it is not going to be installed
                  Depends: xfce4-cpufreq-plugin but it is not going to be installed
                  Depends: xfce4-eyes-plugin but it is not going to be installed
                  Depends: xfce4-timer-plugin but it is not going to be installed
                  Depends: xfce4-time-out-plugin but it is not going to be installed
                  Depends: xfce4-xapp-status-plugin but it is not going to be installed
xubuntu-core : Depends: xubuntu-default-settings but it is not going to be installed
                Recommends: snapd but it is not installable
xubuntu-desktop : Depends: xubuntu-default-settings but it is not going to be installed
                   Recommends: snapd but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So I typed in that very command, and it said that certain packages that I currently had were no longer required, and then this:

The following NEW packages will be installed:
  xubuntu-default-settings
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
196 not fully installed or removed.
Need to get 0 B/56.1 kB of archives.
After this operation, 391 kB of additional disk space will be used.
Do you want to continue? [Y/n] y   
(Reading database ... 713479 files and directories currently installed.)
Preparing to unpack .../xubuntu-default-settings_22.04.0_all.deb ...
Unpacking xubuntu-default-settings (22.04.0) ...
dpkg: error processing archive /var/cache/apt/archives/xubuntu-default-settings_
22.04.0_all.deb (--unpack):
trying to overwrite '/etc/skel/.config/hexchat/hexchat.conf', which is also in
package mint-artwork 1.7.5
Errors were encountered while processing:
/var/cache/apt/archives/xubuntu-default-settings_22.04.0_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hmm, it seems like the same Hexchat file is causing it to trip up...

Last edited by Hkmxfce (2023-11-03 12:53:42)

Offline

#4 2023-11-03 15:49:05

eriefisher
Member
From: ON, Canada
Registered: 2008-10-25
Posts: 430

Re: Error code installing Xfce on Linux Mint

Do you need Hexchat? remove it then reinstall it afterwards.

OR

dpkg --force-overwrite -i package-name.deb
apt -f install

Not ideal but until ubuntu fixes the package conflict or you edit the .deb yourself this will work.


Siduction
Debian Sid
Xfce 4.18

Offline

#5 2023-11-03 18:01:53

Bamber
Member
Registered: 2023-03-05
Posts: 8

Re: Error code installing Xfce on Linux Mint

Mint has a Xfce version, you should do a clean install of that.

Offline

#6 2023-11-05 15:29:49

Hkmxfce
Member
Registered: 2023-11-03
Posts: 3

Re: Error code installing Xfce on Linux Mint

Appreciate that, eriefisher. It overrided the package conflict and installed it perfectly. It seems like the Hexchat file issue prevented other packages from being installed/uninstalled as well. Strange. Anyway, thank you!

Offline

Board footer

Powered by FluxBB