Xfce Forum

Sub domains
 

You are not logged in.

#1 2024-02-01 20:43:08

callmejoe
Member
Registered: 2019-11-19
Posts: 75

[solved] xfce4-panel on wayland

hello, i installed xfce4-panel version 4.19.2 to try out on my wayland desktop (wayfire) but getting an error when trying to run it.

xfce4-panel: Failed to connect to session manager: Failed to connect to the session manager: SESSION_MANAGER environment variable not defined
** Message: 15:33:05.842: Your compositor does not support the ext_workspace_manager_v1 protocol

(xfce4-panel:93637): Wnck-WARNING **: 15:33:05.943: libwnck is designed to work in X11 only, no valid display found
Segmentation fault (core dumped)

I do have wayfire installed along with the xfce desktop so maybe there are conflicting files/versions?  I did remove the xfce4-panel package that came a long with  installing the xfce desktop before installing version 4.19.2.  I also removed the ~/.config/xfce4 directory before installing the new panel version.

the new xfce4-panel version 4.19.2 is installed to /usr/local/bin

any suggestions i might try to get this working?  thanks

Last edited by callmejoe (2024-02-02 03:59:46)

Offline

#2 2024-02-01 21:08:12

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 10,992

Re: [solved] xfce4-panel on wayland

Can you post the configure/autogen command you used and the full outputs of those commands? Make sure your properly building the wayland version (which should take care of not installing X11 components like libwnck) and not the X11 version.

the new xfce4-panel version 4.19.2 is installed to /usr/local/bin

If you're trying to run two concurrent versions of xfce4-panel, you're going to run into alot of problems. If not, is there any reason you didn't install to your default prefix and libdirs so that all the libraries can be properly found?

Which distro are you using?


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#3 2024-02-01 22:44:51

callmejoe
Member
Registered: 2019-11-19
Posts: 75

Re: [solved] xfce4-panel on wayland

Here is the log from configure command
http://dpaste.com//2GVC3MHV4

I did remove xfce4-panel version 4.18.2 before I attempted to install this newer version.  I didn't purposely install to /usr/local/bin.  that's just where 'make install' put everything.  Sounds like I need to specify a prefix then?

Distro is Arch

Offline

#4 2024-02-01 22:50:01

Tamaranch
Member
Registered: 2020-12-31
Posts: 269

Re: [solved] xfce4-panel on wayland

callmejoe wrote:

Distro is Arch

So unless the goal is to learn, you should probably just use https://aur.archlinux.org/packages/xfce4-panel-devel or https://aur.archlinux.org/packages/xfce4-panel-git.

Offline

#5 2024-02-01 23:06:23

callmejoe
Member
Registered: 2019-11-19
Posts: 75

Re: [solved] xfce4-panel on wayland

Tamaranch wrote:
callmejoe wrote:

Distro is Arch

So unless the goal is to learn, you should probably just use https://aur.archlinux.org/packages/xfce4-panel-devel or https://aur.archlinux.org/packages/xfce4-panel-git.

ah good idea.  i always forget to look in the aur.  i'll try it.

Offline

#6 2024-02-01 23:32:40

callmejoe
Member
Registered: 2019-11-19
Posts: 75

Re: [solved] xfce4-panel on wayland

ok i removed all instances of xfce4 pacakges from /usr/local/

i then installed xfce4-panel-devel from aur, but panel didnt launch. I didn't get the session_manager error,  just this one

** Message: 18:24:43.588: Your compositor does not support the ext_workspace_manager_v1 protocol

(xfce4-panel:4889): Gtk-WARNING **: 18:24:43.630: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.

(xfce4-panel:4889): Wnck-WARNING **: 18:24:43.698: libwnck is designed to work in X11 only, no valid display found
Segmentation fault (core dumped)

i removed xfce4-panel-devel and tried xfce4-panel-git.   but unfortunately, same error

I imagine it could be incompatible with wayfire.  wayfire has had so much development over past 6 months.

oh well.

Last edited by callmejoe (2024-02-01 23:35:16)

Offline

#7 2024-02-01 23:37:10

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 10,992

Re: [solved] xfce4-panel on wayland

You need to run your configure or autogen.sh command like this:

./configure --prefix=/usr --enable-wayland --disable-x11
make
sudo make install

I don't have a system to test this on so please post back all the output and the results of whether it works or not.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#8 2024-02-01 23:55:51

Tamaranch
Member
Registered: 2020-12-31
Posts: 269

Re: [solved] xfce4-panel on wayland

There's something wrong with your environment, making GTK think you're on X11 when you're not. X11 code paths (including wnck) can be disabled at compile time, but you don't have to, as they're also protected at runtime. I'm afraid that even with --disable-x11 you'll still have problems. That said, it may be worth testing to get a better idea of the problem.

Offline

#9 2024-02-02 00:54:44

callmejoe
Member
Registered: 2019-11-19
Posts: 75

Re: [solved] xfce4-panel on wayland

am i okay leaving the xfce4-dev-tools-git package in place?

Offline

#10 2024-02-02 01:35:35

callmejoe
Member
Registered: 2019-11-19
Posts: 75

Re: [solved] xfce4-panel on wayland

ok.  used

./configure --prefix=/usr --enable-wayland --disable-x11

  but still getting same error.

here is the config.log.  i do see some errors. not sure if they are critical.
http://dpaste.com//3MNNYU32C

Offline

#11 2024-02-02 02:34:59

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 10,992

Re: [solved] xfce4-panel on wayland

configure:24938: WARNING: unrecognized options: --enable-wayland, --disable-x11

My understanding is obviously wrong. I'll let @Tamaranch take over, he'll understand this best.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#12 2024-02-02 03:17:49

callmejoe
Member
Registered: 2019-11-19
Posts: 75

Re: [solved] xfce4-panel on wayland

hey got it working! i was using the 4.19.2 tarball to install the panel this whole time.  decided to scrap that and just build from master branch and it is running now.

i definitely complicated things not knowing I needed to provide these arguments when building

--prefix=/usr --enable-wayland --disable-x11

using an older dev-tools package also didnt help.

thanks ToZ and Tamaranch for the help!

Last edited by callmejoe (2024-02-02 04:04:23)

Offline

#13 2024-02-02 12:02:12

Tamaranch
Member
Registered: 2020-12-31
Posts: 269

Re: [solved] xfce4-panel on wayland

It's a difficult story to follow, we obviously don't have all the elements we need to understand it. Anyway, all the better if it works out in the end smile

Offline

Board footer

Powered by FluxBB