Xfce Forum

Sub domains
 

You are not logged in.

#1 2024-01-24 13:10:37

WonXfce
Member
Registered: 2022-11-10
Posts: 5

Disable "Stick to Windows Title Bar" ?

Ever since using XFCE on any Linux Distribution one nagging issue that comes up constantly is what I like to term as "Stick to Windows Title Bar (STWTB)".  It goes like this I'll have multiple application window open and to gain focus on a window I would click in or near the Windows Title Bar (This is the same way I would navigate Microsoft Windows).  A majority of the time the action performed is executed correctly but every once in a while the mouse pointer would STWTB and move with the mouse where ever it goes.  To "unstick" it I would left click once and the mouse pointer would release from the Windows Title Bar.

I can't figure out how to disable it?  Any suggestions?

Offline

#2 2024-02-05 14:43:57

eriefisher
Member
From: ON, Canada
Registered: 2008-10-25
Posts: 376

Re: Disable "Stick to Windows Title Bar" ?

I have had this happen on occasion to me as well. I'm not sure what causes it or how to disable it but as a work around when I'm jumping through several windows a lot I will double click on the title bar but holding the second click. This will grab the window and allow you to move it around until you release it. You can also ALT+left click to raise and move a window. ALT+TAB will cycle through windows as well.

Last edited by eriefisher (2024-02-05 14:44:58)


Siduction
Debian Sid
Xfce 4.18

Offline

#3 2024-02-05 20:05:47

mint4all
Member
From: off the map
Registered: 2018-08-21
Posts: 263

Re: Disable "Stick to Windows Title Bar" ?

WonXfce wrote:

Ever since using XFCE on any Linux Distribution one nagging issue that comes up constantly is what I like to term as "Stick to Windows Title Bar (STWTB)".  It goes like this I'll have multiple application window open and to gain focus on a window I would click in or near the Windows Title Bar (This is the same way I would navigate Microsoft Windows).  A majority of the time the action performed is executed correctly but every once in a while the mouse pointer would STWTB and move with the mouse where ever it goes.  To "unstick" it I would left click once and the mouse pointer would release from the Windows Title Bar.

I can't figure out how to disable it?  Any suggestions?

Hi to y'all ... I see that you welcome suggestions, so I'll try. First, I'd like to mention the mouse's basic function: button-down <> movement (if any) <> button-up. Based on the x/y-coordinate (relative to a gui-widget)  of a click, the window-manager decides what to do. In your case, button-up clicks get sometimes "lost". That forces the window-manager to continue acting out (such as move a window) until it receives a new -down or -up click that ends the function loop. So I suggest you explore why your -up click gets lost by your system: a faulty component, or (more likely, ime) contention with another device attached to the some USB-bus (assuming you're using a USB-mouse). When you run the command

lsusb -t

you'll see what is attached and where, and if there is possibly something else competing with your mouse. My personal choice: i'd attach the mouse to its own USB-bus and -port, nothing else, and wait and see if the problem goes away. If it doesn't stop, then there's likely a hardware defect involved. Cheers, m4a


Linux Mint 21.2 -- xfce 4.18 ... Apple iMAC -- Dell & HP Desktops and Laptops -- Family & Community Support

Offline

#4 2024-02-09 10:02:08

eev2
Member
Registered: 2023-02-24
Posts: 15

Re: Disable "Stick to Windows Title Bar" ?

Hi. I don't have anything to contribute, but I just want to say that I also have this issue. It happens to every computer I own with XFCE. I don't know how to fix it, but because it rarely happens, I learnt to live with it, although I would love to know how to fix it.

Offline

#5 2024-02-09 16:21:35

mint4all
Member
From: off the map
Registered: 2018-08-21
Posts: 263

Re: Disable "Stick to Windows Title Bar" ?

eev2 wrote:

Hi. I don't have anything to contribute, but I just want to say that I also have this issue. It happens to every computer I own with XFCE. I don't know how to fix it, but because it rarely happens, I learnt to live with it, although I would love to know how to fix it.

Thank you -- your reply helps to draw some concluions (mine, of course smile ) ... I would say that this "mouse feature" travels with you. Since most wireless mice use the 2.4Ghz band, is there something (on you) that might interfere? Wrist/smart watch, wedding/smart ring? Certain kind of jewelry? Have you tried a wired mouse? Or is there something low-level but repetitive that applies to all your systems, such as the same hardware/usbports/mouse driver?
Cheers, m4a


Linux Mint 21.2 -- xfce 4.18 ... Apple iMAC -- Dell & HP Desktops and Laptops -- Family & Community Support

Offline

#6 2024-02-09 17:02:07

eev2
Member
Registered: 2023-02-24
Posts: 15

Re: Disable "Stick to Windows Title Bar" ?

It actually happens with a touchpad or a wired usb mouse.

Offline

Board footer

Powered by FluxBB