Xfce Forum

Sub domains
 

You are not logged in.

#1 2024-02-19 13:12:48

rayandrews
Member
From: Vancouver B.C. Canada
Registered: 2011-12-30
Posts: 179

pulseaudio doesn't start automatically.

Greetings:

I never seem to have had pulseaudio but it never seemed to matter, my sound was always there and alsamixer seemed to do whatever needed to be done.  My webcam even worked.  But then it stopped working and I don't know when or why since I don't use it much.  But then I had need of it again.  The video worked fine but there was no sound.  Various online testing facilities reported that I had a mic but that it was muted, or that I had no mic at all.  Hacking around, it seems that alsamixer couldn't get it fired up either.  But 'pulseaudio -D' did get it working tho it complains that root isn't supposed to have sound.  I wonder why root isn't supposed to have sound, but nevertheless it did work.  Various online tests report my mic as 'OrbiCam' when in fact it's a Logitech HD Pro Webcam C920. 

Can this be cleaned up a little?  Can I get the sound activated automatically?  I'll try a line in /etc/rc.local if nothing is offered here. 

Tx.

Offline

#2 2024-02-19 18:20:43

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,106

Re: pulseaudio doesn't start automatically.

rayandrews wrote:

But 'pulseaudio -D' did get it working tho it complains that root isn't supposed to have sound.

Seems like you ran the command with root privileges. Does it work when you run it under your user account?

I wonder why root isn't supposed to have sound,

Most likely because its meant to be a user-based utility.

Can I get the sound activated automatically?

If it runs properly under your user account, just add an entry into Session and Startup > Autostart Applications.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#3 2024-02-19 18:36:26

rayandrews
Member
From: Vancouver B.C. Canada
Registered: 2011-12-30
Posts: 179

Re: pulseaudio doesn't start automatically.

I run as root all the time and I used to have my webcam working.  In 15 years of running as root I've had exactly two incidents -- once a guy managed to download a picture of his boat, and a while ago someone managed to hack my facebook password.  Other than that I have no issues with root, so, since it saves so much trouble when I have to switch to root, I just stay as root all the time.  Can this be accommodated?  I'm betting that somewhere in /etc there's a file in which permission can be granted.

Offline

#4 2024-02-19 18:49:57

eriefisher
Member
From: ON, Canada
Registered: 2008-10-25
Posts: 418

Re: pulseaudio doesn't start automatically.

Running as root is never recommended. Aside from security risks some applications are designed to be run as a user and will throw errors otherwise. This may be your issue. ToZ's suggestion should work but I would think about setting up a proper user account.


Siduction
Debian Sid
Xfce 4.18

Offline

#5 2024-02-19 18:54:37

rayandrews
Member
From: Vancouver B.C. Canada
Registered: 2011-12-30
Posts: 179

Re: pulseaudio doesn't start automatically.

Like I said I have no problems, except this one, so I'm sticking to my sinful ways.  Linux is about freedom,  no?  So if I want to run as root I'm a'goin' to run as root.  Actually ... I remember that ... nuts, what was the name ... used a traffic cone as their symbol ... some player ... refused to run as root.  Thing is that I came from DOS where you actually own your own computer and that's my culture.  If I ever run into a real disaster, yeah, I'll repent of my ways and set up a user account.  Actually, I have one, I just never use it.  BTW, it seems strange that the cam video works without any complains, just the Big Bad sound -- dunno why sound would be so dangerous.  Anyway:

% pulseaudio --system=true

... seems to work, too, *and* I get the lecture about being a bad boy gratis. 

But ... maybe I really should start using my user.  Tx.

Last edited by rayandrews (2024-02-19 19:07:48)

Offline

#6 2024-02-19 19:57:21

chang-zhao
Member
Registered: 2023-11-20
Posts: 36

Re: pulseaudio doesn't start automatically.

rayandrews, you don't seem to need any advice, but just my 2 cents:

There was a time I hated the inconvenience of not being a root.

Then I properly set polkit etc., and now I never even have to enter root password.

I also have "root terminal" and "root thunar" among my icons /toolbars /context menus... But it's not often that I have to use them.

Eventually working from a user account was not as scary as I thought.

Just saying...

Last edited by chang-zhao (2024-02-19 19:58:07)

Offline

#7 2024-02-19 20:39:57

rayandrews
Member
From: Vancouver B.C. Canada
Registered: 2011-12-30
Posts: 179

Re: pulseaudio doesn't start automatically.

chang-zhao wrote:

rayandrews, you don't seem to need any advice, but just my 2 cents:

There was a time I hated the inconvenience of not being a root.

Then I properly set polkit etc., and now I never even have to enter root password.

I also have "root terminal" and "root thunar" among my icons /toolbars /context menus... But it's not often that I have to use them.

Eventually working from a user account was not as scary as I thought.

Just saying...

Thanks!  Yeah, once I got used to it I'd probably be just like you.

Offline

Board footer

Powered by FluxBB