Xfce Forum

Sub domains
 

You are not logged in.

#1 2024-05-21 00:47:03

Skaperen
Member
From: right by Jesus, our Saviour
Registered: 2013-06-15
Posts: 824

how to set the Num Lock state?

i run multiple users under lightdm.  this means each user starts up in its own instance of Xorg and X windows environment (which is Xfce for all users by default under Xubuntu).  the situation i have is that the Num Lock key comes up in the off state as expected for all users except for one of them named "vx".  when that user gets logged in, the Num Lock state is on and i need to press the Num Lock key to toggle it off.

is something (unintentially) set to make Num Lock start in the on state?  how can i fix Num Lock so it starts in the off state?  is there a script command (that i could put in /home/vx/.bashrc) to set or toggle the Num Lock key state?  i don't know if Xorg or the Linux kernel keeps this state but i think it is likely to be Xorg.  i don't know how Xfce could intervene with this.

Offline

#2 2024-05-21 01:28:02

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,205

Re: how to set the Num Lock state?

What does the following return:

xfconf-query -c keyboards -lv | grep -i numlock

Enabling Settings Manager > Keyboard > "Restore Numlock" will create/alter the RestoreNumlock property and on logout will save the numloock state to the Numlock property. If both are true then that would explain what is happening. You could (with the numlock disabled):

xfconf-query -c keyboards -p /Default/Numlock -t bool -s false --create

...to set that value to false.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

Board footer

Powered by FluxBB