Xfce Forum

Sub domains
 

You are not logged in.

#1 2024-05-31 19:36:35

Lalalend
Member
Registered: 2024-05-31
Posts: 7

27 years of XFCE! and there's still no user-friendly Autostart menu.

Are you all joking here? In 2024, I have to type /usr/bin/foo in the Session and Autostart menu, and there isn’t even any menu to choose applications from /usr/share/applications?? WOW. Did I miss something? I wonder when XFCE started giving so little attention, frankly speaking.

Offline

#2 2024-05-31 19:49:26

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,237

Re: 27 years of XFCE! and there's still no user-friendly Autostart menu.

What are you going on about? There are 3 menu applications to choose from: the applicationsmenu plugin, Whisker menu, and Application Finder. There is also xfdashboard.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#3 2024-06-01 06:00:21

Lalalend
Member
Registered: 2024-05-31
Posts: 7

Re: 27 years of XFCE! and there's still no user-friendly Autostart menu.

XDG Autostart. /etc/xdg/autostart . ~/.config/autostart.
{Applications Menu,  Whisker,  xfdashboard } - launchers

Offline

#4 2024-06-01 15:17:41

CwF
Member
Registered: 2018-01-28
Posts: 299

Re: 27 years of XFCE! and there's still no user-friendly Autostart menu.

There is one, been there forever;

Settings>Session and Startup>Application Autostart

Offline

#5 2024-06-01 18:40:28

Lalalend
Member
Registered: 2024-05-31
Posts: 7

Re: 27 years of XFCE! and there's still no user-friendly Autostart menu.

CwF wrote:

There is one, been there forever;

Settings>Session and Startup>Application Autostart

You don't have the option to select an application to run. You can only specify the path to the executable file.

Offline

#6 2024-06-02 02:09:10

CwF
Member
Registered: 2018-01-28
Posts: 299

Re: 27 years of XFCE! and there's still no user-friendly Autostart menu.

Lalalend wrote:

You don't have the option to select an application to run. You can only specify the path to the executable file.

Same thing...
Specifying the path has the added benefit of not being limited to the items that actually have a menu listing!

Offline

#7 2024-06-02 20:32:11

Lalalend
Member
Registered: 2024-05-31
Posts: 7

Re: 27 years of XFCE! and there's still no user-friendly Autostart menu.

CwF wrote:
Lalalend wrote:

You don't have the option to select an application to run. You can only specify the path to the executable file.

Same thing...
Specifying the path has the added benefit of not being limited to the items that actually have a menu listing!

Don't lie. This is not the same. Look around at other DE. It might seem like a simple feature, but it's very useful.

Offline

#8 2024-06-02 20:36:16

Lalalend
Member
Registered: 2024-05-31
Posts: 7

Re: 27 years of XFCE! and there's still no user-friendly Autostart menu.

btw, I don't want to make a new thread. But maybe someone knows how to fully disable any window decorations and preview boxes when I just press Alt + Tab. This is so maddening and painful. I want to switch between two windows without any tooltips. Just switch between the two windows

Offline

#9 2024-06-02 21:26:53

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,237

Re: 27 years of XFCE! and there's still no user-friendly Autostart menu.

Settings Manager > Window Manager > Keyboard. Clear the current "Cycle Windows" (Alt+Tab) shortcut and add Alt-Tab as the shortcut for "Switch Application".

As for your previous request, feel free to ad your +1 to the existing enhancement request.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#10 2024-06-03 12:16:51

Lalalend
Member
Registered: 2024-05-31
Posts: 7

Re: 27 years of XFCE! and there's still no user-friendly Autostart menu.

ToZ wrote:

Settings Manager > Window Manager > Keyboard. Clear the current "Cycle Windows" (Alt+Tab) shortcut and add Alt-Tab as the shortcut for "Switch Application".

As for your previous request, feel free to ad your +1 to the existing enhancement request.

The Switch Application option is almost what I need. However, this option cycles through all the windows on the panel. Can the Switch Application option have the same behavior as Cycle Windows? That is, switch between the current window and the most recently visited window.

issues №125 - this is exactly what is missing.

Offline

#11 2024-06-03 16:37:08

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,237

Re: 27 years of XFCE! and there's still no user-friendly Autostart menu.

Try this instead. Add back the Alt-tab shortcut to the "Cycle Windows" event. Then add the following content to ~/.config/gtk-3.0/gtk.css:

#xfwm-tabwin {background: transparent; opacity: 0}

...and finally, restart xfwm4:

xfwm4 -r

Not when you quickly Alt-Tab you will repeatedly switch between 2 windows. Hold down the ALT to switch between others. The CSS tweak will make the popup window invisible.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#12 2024-06-03 21:12:34

Lalalend
Member
Registered: 2024-05-31
Posts: 7

Re: 27 years of XFCE! and there's still no user-friendly Autostart menu.

ToZ wrote:

Try this instead. Add back the Alt-tab shortcut to the "Cycle Windows" event. Then add the following content to ~/.config/gtk-3.0/gtk.css:

#xfwm-tabwin {background: transparent; opacity: 0}

...and finally, restart xfwm4:

xfwm4 -r

Not when you quickly Alt-Tab you will repeatedly switch between 2 windows. Hold down the ALT to switch between others. The CSS tweak will make the popup window invisible.

Well, it works, but it's just a CSS "hack." I still have some delay between switching windows. That's sad.

Offline

#13 2024-06-03 23:48:43

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,237

Re: 27 years of XFCE! and there's still no user-friendly Autostart menu.

Go to Settings Manager > Window Manager > Cycling tab, and check off the "Cycle through windows in a list". See if that helps with performance.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

Board footer

Powered by FluxBB