Xfce Forum

Sub domains
 

You are not logged in.

#1 2024-07-03 06:36:33

rustico
Member
Registered: 2024-06-01
Posts: 6

Xubuntu Noble Minimal MTP support

In Xubuntu 24.04 minimal, when I connect an Android device via USB cable for file transfer, I see the prompt on the device, but nothing happens in Xubuntu. What do I need to install to get USB file transfer working?

Thanks.

Offline

#2 2024-07-03 11:15:58

eriefisher
Member
From: ON, Canada
Registered: 2008-10-25
Posts: 441

Re: Xubuntu Noble Minimal MTP support

You may need to adjust the settings on the phone itself. Somewhere the should be a way to change what ever it is now to file transfer. The option are usually file transfer, midi, PTP or charge only. Once you select file transfer Xubuntu should see it as a usb thumb drive.

open settings, search for usb.


Siduction
Debian Sid
Xfce 4.18

Offline

#3 2024-07-03 14:26:20

rustico
Member
Registered: 2024-06-01
Posts: 6

Re: Xubuntu Noble Minimal MTP support

When the phone is connected with the cable, the phone presents a menu with radio buttons for charging, file transfer, or photo transfer. Under earlier versions, once file transfer was selected, an icon for the phone would appear on the desktop and the device could be mounted. With 24.04 (Minimal), no icon appears and the OS seems to be unaware that anything was connected.

Offline

#4 2024-07-03 15:02:28

mint4all
Member
From: off the map
Registered: 2018-08-21
Posts: 271

Re: Xubuntu Noble Minimal MTP support

rustico wrote:

In Xubuntu 24.04 minimal, when I connect an Android device via USB cable for file transfer, I see the prompt on the device, but nothing happens in Xubuntu. What do I need to install to get USB file transfer working?
Thanks.

Greetings!

Ime, there are 3 things you can do:
1) verify that your "removable media" is properly being mounted (Settings Manager > "Hardware" section > "removable..." button" > uncheck then recheck options).
2) try a different USB-C / USB-A cable (the chips handling data in the connectors may have burned out)
3) try a different USB port on your PC / Laptop.
On my Galaxy phones (old A21, new A15) I get the "Allow" access pop-up when I connect the cable to my Mint 21 XFCE desktops (4.16 and 4.18). Then thunar auto-mounts it as an external drive. What version of XFCE and Android are you running?
Cheers, m4a


Linux Mint 21.2 -- xfce 4.18 ... Apple iMAC -- Dell & HP Desktops and Laptops -- Family & Community Support

Offline

#5 2024-07-03 15:30:46

eriefisher
Member
From: ON, Canada
Registered: 2008-10-25
Posts: 441

Re: Xubuntu Noble Minimal MTP support

I would also check your cable. Some of them are charge only and don't carry data.


Siduction
Debian Sid
Xfce 4.18

Offline

#6 2024-07-03 15:39:45

CwF
Member
Registered: 2018-01-28
Posts: 299

Re: Xubuntu Noble Minimal MTP support

rustico wrote:

With 24.04 (Minimal), no icon appears and the OS seems to be unaware that anything was connected.

Check the OS sees it with

lsusb

Offline

#7 2024-07-03 16:05:17

rustico
Member
Registered: 2024-06-01
Posts: 6

Re: Xubuntu Noble Minimal MTP support

Thanks for the help; it's working now. While I had tried different cables and ports last night, I tried again this morning and it's now OK. I'm perplexed because it now works regardless of cable or port. Let's declare victory and go home.

Offline

#8 2024-07-04 06:24:48

rustico
Member
Registered: 2024-06-01
Posts: 6

Re: Xubuntu Noble Minimal MTP support

Testing some spare laptops tonight, I think I've found the solution. While the connected Android devices showed an entry in lsusb, the icon did not appear on the Desktop. This fixed it:

Install gvfs-backends and gvfs-fuse
Restart and connect the device. It may be necessary to enable USB file transfer (instead of charging or photo transfer), depending on the device manufacturer or Android version, but an icon for the device should appear on the desktop.

It appears that Xubuntu Minimal installs some gvfs components but not these two, which are needed for MTP support. After a Minimal install, Thunar (Edit > Preferences > Advanced > Enable volume management > Configure . . .) shows a message at the bottom of the dialog warning that gvfs is not installed. That should go away after the two components are installed and the system is restarted.

Offline

Board footer

Powered by FluxBB