Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-08-19 11:12:31

gnome_refugee
Member
Registered: 2010-01-15
Posts: 164

xfwm4 in Xfce 4.10 behaving badly?

A friend installed Linux Mint Xfce 13 on an old-ish Dell Inspiron laptop recently. After a week of daily, trouble-free use, her desktop suddenly behaved strangely on login, and she asked me for help:

- All application windows were opening in the top left of the screen, instead of the centre
- The minimise, maximise and close-down buttons were missing from the title bar of all windows
- No window could be moved with the mouse
- Window focus was following the mouse, although the setting was to click to gain focus
- The Xfce panel icons had rearranged themselves, and the 8-workspace workspace switcher was only showing 1 workspace

This looks like for some reason the window manager had not started. However, when I opened Alt+F2 and tried xfwm4 --replace, nothing happened. I deleted the xfwm session file in ~/.cache/sessions files and rebooted. No change, still no window management.

After much fiddling and googling (which told me that other people were having trouble with the window manager in 4.10), I found I could get normal window manager behaviour by entering this command in a terminal:

xfwm4 --sm-client-disable

As soon as this command stopped running (by my stopping it, or logging out), the window management problem came back. However, if I tried xfwm4 --replace while the above command was running, the window manager started and normal behaviour was restored. I could then kill the command, log out with 'save session on exit', and log back in to a normal desktop.

Any ideas on what's going on with xfwm4?

Offline

#2 2012-08-19 18:48:31

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: xfwm4 in Xfce 4.10 behaving badly?

May I say that I never had this problem? But I have a very old machine that works slowly so it's a special case.
It could be the same reason why thunar-volman never worked for me either.

Offline

#3 2012-08-19 22:41:58

gnome_refugee
Member
Registered: 2010-01-15
Posts: 164

Re: xfwm4 in Xfce 4.10 behaving badly?

The problem on my friend's laptop is 'fixed' but I'm still puzzled by it. I found this post

http://forum.xfce.org/viewtopic.php?id=7342

on this forum from jt_04 that suggests that 4.10 needs libxfce4util.so.6. Linux Mint 13 Xfce in fact comes with libxfce4util.so.4 in /usr/lib. The 'building Xfce' doc

http://docs.xfce.org/xfce/building

doesn't specify the version number for that .so. Anyone know what's in these .so's that might affect xfwm4?

Offline

#4 2012-08-20 01:03:15

Homesteader
Member
Registered: 2012-08-19
Posts: 4

Re: xfwm4 in Xfce 4.10 behaving badly?

Hello. I found this forum because I was researching this very problem. Starting this morning:

- all windows open top left corner of screen
- many can't be dragged with mouse to re-position
- no min/max/close buttons, except in Google Chrome (and they don't work)
- only 1 workspace when I actually have 4
- sometimes keyboard unresponsive
- home folder icon on desktop partly hidden under top panel
- in Settings Manager, both Window manager and window manager tweak are blank
- terminal emulator blank (I had to switch back to gnome to complete my sign up verification for the forum)

I am new to Xfce, having discovered it after installing Ubuntu 12.04 on my new computer. I didn't like Unity and so installed Gnome Fallback. I was willing to settle for Gnome Classic Without Effects, but then I read about Xfce, installed it, and am totally converted.

Now this.

Like Gnome-refugee I discovered that these problems with xmwf4 are not uncommon. I found bug reports about it at Launchpad:
https://bugs.launchpad.net/ubuntu/+sour … bug/495361
https://bugs.launchpad.net/ubuntu/+sour … bug/978333

"xfwm4 --replace" in terminal is supposed to manually fix it, but I couldn't even get terminal to work.

Sometimes session saving is involved, but I don't save sessions and I'm still having problems.

I've used Ubuntu for 4 years and love it. However, I'm not especially geeky. It seems to have been a problem for awhile. Any suggestions?

Offline

#5 2012-08-20 01:13:01

gnome_refugee
Member
Registered: 2010-01-15
Posts: 164

Re: xfwm4 in Xfce 4.10 behaving badly?

Hi, homesteader.

As I said in the first post, this worked:

1. In a terminal, enter

xfwm4 --sm-client-disable

This should restore the desktop and the workspace switcher in the panel. If it doesn't...??

2. Open the run dialog with Alt+F2, and enter xfwm4 --replace

This should restart xfwm4 properly.

3. Make sure everything in your session is set up as you prefer, then log out with 'save session on exit'.

4. Log in again. Everything OK? On my friend's laptop the only thing still wrong is that the Window Manager and Window Manager Tweaks icons are missing from the Settings overview box. However, they can still be reached by choosing them from the right-click menu on a blank part of the desktop (Applications > Settings).

Let us know what happens.

Offline

#6 2012-08-20 01:16:01

Homesteader
Member
Registered: 2012-08-19
Posts: 4

Re: xfwm4 in Xfce 4.10 behaving badly?

Gnome-refugee, thanks for such a swift reply. I logged out of Xfce because I couldn't get terminal to run properly, it was just a greyed out screen that did not respond to the keyboard. I'm in Gnome now. I'll switch back and see what I can do.

Offline

#7 2012-08-20 01:23:00

Homesteader
Member
Registered: 2012-08-19
Posts: 4

Re: xfwm4 in Xfce 4.10 behaving badly?

YES!!! It worked! Thank you so much. What a relief. I was heartbroken to think I'd have to give up Xfce.

Offline

#8 2012-08-20 01:34:44

gnome_refugee
Member
Registered: 2010-01-15
Posts: 164

Re: xfwm4 in Xfce 4.10 behaving badly?

Happy to help. Let's hope the bug can be pinned down and squashed, because it may recur.

Know how you feel about Xfce. My desktop is a work machine and by customising Xfce I've made that work a *lot* more efficient.

Offline

#9 2012-08-20 01:37:09

Homesteader
Member
Registered: 2012-08-19
Posts: 4

Re: xfwm4 in Xfce 4.10 behaving badly?

Agreed. I'll bookmark your fix to keep it handy for future reference.

Offline

Board footer

Powered by FluxBB