Xfce Forum

Sub domains
 

You are not logged in.

#26 2018-12-30 15:27:35

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,680

Re: Screen tearing

There have been some significant changes made to help with tearing in the 4.13x branches of xfwm4. Unfortunately, Xubuntu 18.10 still uses the 4.12 branch.

I don't have an nvidia card to test with, but I have read that enabling the CompositionPipeline helps. See this Arch wiki entry for more information.

Offline

#27 2018-12-30 15:29:57

timbuck2
Member
Registered: 2018-12-30
Posts: 18

Re: Screen tearing

Same here.  Just installed Linux Lite 4.2 with XFCE and have screen tearing on scrolling pages.  NVIDIA 680.  Used the NVIDIA 390 drivers and turned on vysnc also.  Same as previous poster basically.

Offline

#28 2018-12-30 15:32:15

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,680

Re: Screen tearing

timbuck2 wrote:

Same here.  Just installed Linux Lite 4.2 with XFCE and have screen tearing on scrolling pages.  NVIDIA 680.  Used the NVIDIA 390 drivers and turned on vysnc also.  Same as previous poster basically.

What version of xfwm4 does Linux Lite 4.2 use?
Did you try the CompositionPipeline configurations? And if so, did they help?

Offline

#29 2018-12-30 15:49:12

timbuck2
Member
Registered: 2018-12-30
Posts: 18

Re: Screen tearing

dpkg -l says it's 4.12.4-0ubun.  I actually switched xfce over to use openbox instead but it still has tearing.

No, I hadn't tried that but I just turned it on via NVIDIA X Server Settings Advanced Display Settings.  Need to read about it...there were 2 options.  Force Composition Pipeline and Force Full Composition Pipeline.  Have no idea what it is, but still have tearing when scrolling pages quickly with the mouse wheel.  Too much information overload starting new with Linux after 10 years lol.  Thanks for the suggestion though.

Offline

#30 2018-12-30 18:21:14

timbuck2
Member
Registered: 2018-12-30
Posts: 18

Re: Screen tearing

Ugh.  Sorry for double post but wanted to share this.  After rebooting with the Force Full Composition Pipeline my second monitor only showed the background wallpaper.  It was in front of everything else and so I couldn't use it.  Turned off FFCP and applied changes and the second monitor worked fine again.

Offline

#31 2018-12-30 18:39:12

dowx
Member
Registered: 2018-12-29
Posts: 24

Re: Screen tearing

timbuck2 wrote:

Ugh.  Sorry for double post but wanted to share this.  After rebooting with the Force Full Composition Pipeline my second monitor only showed the background wallpaper.  It was in front of everything else and so I couldn't use it.  Turned off FFCP and applied changes and the second monitor worked fine again.

No issues here. Enabling "Force (Full) Composition Pipeline" fixed screen tearing for me (it's not perfect, but it's big improvement). Try running nvidia-xconfig first and modify/copy the file the way it's described in wiki that ToZ mentioned.

You can experiment with Xfce window manager (there's vsync option available) or, if you use Firefox, you can try disabling recommended performance setting in options. Tbh, I didn't see any difference with or without these options enabled.

BTW: Do you know how can I control my GPU's fan speed depending on the current temperature? The fan keeps turning on and off.  It literally turns on for half a second and stops, about 60 times in a single minute. It starts acting this way when temperature is 57 and stops below 50. Silent but really annoying sounds.

Last edited by dowx (2018-12-30 19:05:56)

Offline

#32 2019-01-21 13:38:29

sh4tr
Member
Registered: 2014-03-20
Posts: 29

Re: Screen tearing

RV630 with the free radeon driver and mesa. By default in xorg (in general) there is no tearing in full screen[1] for video playback, scrolling in Firefox also does not tear. There are 2 fixes with an xorg.conf - either tearfree or exavsync, and they work as expected if xfwm's compositing is not enabled.

The two top checkboxes under Enable display compositing for full screen and vertical blank do not appear to work[?] or make a difference. I was hoping the first one would disable xfwm's compositing for windows in full screen but video playback is still slowed down, interestingly with no dropped frames.

mesa 18.3.1
xorg-server 1.20.3
xf86-video-ati 1:18.1.0
[1] this is also true if there is no panel and the video player is maximised, for example openbox without tint, iirc

Offline

#33 2019-01-21 15:41:54

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,680

Re: Screen tearing

sh4tr wrote:

The two top checkboxes under Enable display compositing for full screen and vertical blank do not appear to work[?] or make a difference.


Depending on the version of xfwm4 you are running, these were broken. Is there a possibility that you might be able to test the development version of xfwm4 (4.13.x), there have been some significant changes in addressing screen tearing. I'm sure the developer would appreciate feedback.

Offline

#34 2019-01-25 04:45:59

sh4tr
Member
Registered: 2014-03-20
Posts: 29

Re: Screen tearing

ToZ wrote:

... test the development version of xfwm4 (4.13.x), there have been some significant changes in addressing screen tearing. I'm sure the developer would appreciate feedback.

so i did

i used https://aur.archlinux.org/packages/xfwm4-git/

xfwm4 -V
        This is xfwm4 version 4.13.1git.5f501cad (revision 5f501cad) for Xfce 4.12
        Released under the terms of the GNU General Public License.
        Compiled against GTK+-3.24.4, using GTK+-3.24.4.

        Build configuration and supported features:
        - Startup notification support:                 Yes
        - XSync support:                                Yes
        - Render support:                               Yes
        - Xrandr support:                               Yes
        - Xpresent support:                             Yes
        - Embedded compositor:                          Yes
        - Epoxy support:                                Yes
        - KDE systray proxy (deprecated):               No

no xorg conf [radeon's default]

test done with mpv

mpv -V
mpv 0.29.1 Copyright © 2000-2018 mpv/MPlayer/mplayer2 projects
 built on Sun Dec  9 16:21:27 CET 2018
ffmpeg library versions:
   libavutil       56.22.100
   libavcodec      58.35.100
   libavformat     58.20.100
   libswscale      5.3.100
   libavfilter     7.40.101
   libswresample   3.3.100
ffmpeg version: n4.1

tested 2 videos, one 24fps for tearing and one 60fps for overhead

results? compositing works = no tearing in windowed mode, no slowness in fs either = playback normal

Offline

#35 2019-01-25 12:56:45

pcdoc2000
Member
Registered: 2019-01-25
Posts: 5

Re: Screen tearing

There are indeed some workarounds to make it work with NVidia cards, but I use 2 monitors, with different resolution and non of those workarounds really did the job. After some tinkering the below is what helped me with screentearing (only for NVidia cards of course) and two moniors. Just put this in your autostart:


nvidia-settings --assign CurrentMetaMode="HDMI-0: nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }, DVI-D-0: nvidia-auto-select +2560+185 { ForceFullCompositionPipeline = On }"

You might need to updated HDMI-0 and/or DVI-0 to your ports of course. +2560+185 also depends on the resolution of your first and the position of the second monitor.

If you just use one monitor ignore everything after the comma ",".

This fix will cause a short flicker when logging in, but that is the only really negative impact I experienced.

Maybe that helps!

Offline

Board footer

Powered by FluxBB