Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-08-29 11:09:48

dejan
Member
Registered: 2022-08-29
Posts: 3

CTRL-F6 shortcut gobbled up by XFCE

I am developing a tiny application using GtkD (https://gtkd.org) and after some time trying to figure out why none of my CTRL+Fx shortcuts work decided to test my theory that XFCE4 for whatever reason does not propagate those to my application. I started a GNOME session, and CTRL-F6 shortcut worked. Same story with Deepin. So, I am quite sure it is something in my XFCE4 environment that is causing this. Since I never messed with keyboard mapping it must be some default XFCE4 setting that is causing this.

I tried few other applications, just to check whether my theory (Gedit, IntelliJ IDEA, and VS CODE) and in none of these applications CTRL-Fx shortcuts worked on XFCE.

Any idea how to enable CTRL+Fx shortcuts when I run XFCE4?

Offline

#2 2022-08-29 13:44:04

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,211

Re: CTRL-F6 shortcut gobbled up by XFCE

Hello and welcome.

By default in Xfce, Ctrl+Fx is used to change workspaces (Ctrl+F6 to go to workspace 6 - but note that only 4 workspaces are default so it would look like it doesn't work). To remove the shortcut, go to Settings Manager > Window Manager > Keyboard, and delete the "Workspace x" shortcuts.

Offline

#3 2022-08-29 15:20:46

dejan
Member
Registered: 2022-08-29
Posts: 3

Re: CTRL-F6 shortcut gobbled up by XFCE

Originally I was looking at Settings / Keyboard... - You were right. Even though I only got 2 workspaces (I actually use only one, so would be happy to disable workspaces completely, if possible) XFCE reserves all CTRL-Fxx shortcuts for workspaces 1 to 12. As you suggested, once I cleared CTRL-F6 for workspace #6 it worked. My application now reacts to CTRL-F6 as I needed. I also noticed ALT-Fxx shortcuts are reserved too for various XFCE actions. Considering that I have the "desktop" key on my FILCO Tenkeyless keboard (with nice Linux penguin on it instead of Windows logo) I will try to reconfigure CTRL-Fxx and ALT-Fxx key bindings to DESKTOP-Fxx and DESKTOP-ALT-Fxx, if possible.

Thanks for your help, greatly appreciated!

Offline

#4 2022-08-29 17:13:54

KBar
Moderator
Registered: 2021-11-05
Posts: 612

Re: CTRL-F6 shortcut gobbled up by XFCE

dejan wrote:

(I actually use only one, so would be happy to disable workspaces completely, if possible)

You can set the number of workspaces to exactly 1 and effectively disable this feature. Look for the Workspaces dialog.
xfwm4-workspace-settings.png


Remember to edit the subject of your topic to include the [SOLVED] tag once you're satisfied with the answers or have found a solution (in which case, don't forget to share it as well), so that other members of the community can quickly refer to it and save their time. Pretty please! tongue

Offline

#5 2022-08-29 17:47:32

dejan
Member
Registered: 2022-08-29
Posts: 3

Re: CTRL-F6 shortcut gobbled up by XFCE

Yes, I am aware of that. I already mentioned I have 2 workspaces on my workstation even though I use only one... Problem here was not about workspaces but about the key-bindings. Thanks for your feedback anyway!

Offline

Board footer

Powered by FluxBB