Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-04-21 02:52:06

dchmelik
Member
From: USA
Registered: 2022-04-02
Posts: 5
Website

git blocked; can't report bugs (add 'session and autostart' blacklist)

Gitlab.xfce.org says my account is blocked: I can't report bugs anymore.  I login with my username and/or email (same; ) not with a git site.
    Applications -> settings -> session and startup could use a blacklist/whitelist.  Several people I know use skype, though I hate it, it's only way they may contact me with audio/video, so I usually have it on.  However every time one starts skype it adds itself to 'session and startup' programs that auto-start on XFCE start, without consent.  I try to remove it every time and want to blacklist it.  I complained in skype help but doubt microsoft will even listen/reply as probably sneaky marketing trick they don't care users dislike.

Last edited by dchmelik (2022-04-21 02:54:01)

Offline

#2 2022-04-21 03:13:07

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 8,939

Re: git blocked; can't report bugs (add 'session and autostart' blacklist)

dchmelik wrote:

Gitlab.xfce.org says my account is blocked: I can't report bugs anymore.

Probably best to reach out to someone at the #xfce-dev Libera IRC channel or via the xfce4-dev mailing list to get your account sorted out.

Applications -> settings -> session and startup could use a blacklist/whitelist.  Several people I know use skype, though I hate it, it's only way they may contact me with audio/video, so I usually have it on.  However every time one starts skype it adds itself to 'session and startup' programs that auto-start on XFCE start, without consent.  I try to remove it every time and want to blacklist it.  I complained in skype help but doubt microsoft will even listen/reply as probably sneaky marketing trick they don't care users dislike.

Try this:

  1. In a terminal window, go to your user's autostart directory:

    cd ~/.config/autostart
  2. Empty out the "skypeforlinux.desktop" file (make sure you type the greater than sign):

    > skypeforlinux.desktop
  3. Turn on the immutable flag (so the file can't be written to):

    sudo chattr +i skypeforlinux.desktop

This should prevent it from auto starting.

Offline

#3 2022-04-22 14:01:37

KBar
Moderator
Registered: 2021-11-05
Posts: 448

Re: git blocked; can't report bugs (add 'session and autostart' blacklist)

toz wrote:

    This should prevent it from auto starting.

That's another eye-opener and trick up to sleeve! Thanks for sharing this.

I think I had a similar idea with the weather plugin. Could changing file ownership or mode bits also help achieve this? I haven't had that problem reappear ever again after I made its rc-file unwritable, but maybe it was fixed by itself. tongue

Last edited by KBar (2022-04-22 14:03:38)


Remember to edit the subject of your topic to include the [SOLVED] tag once you're satisfied with the answers or have found a solution (in which case, don't forget to share it as well), so that other members of the community can quickly refer to it and save their time. Pretty please! tongue

Offline

#4 2022-04-22 23:02:46

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 8,939

Re: git blocked; can't report bugs (add 'session and autostart' blacklist)

KBar wrote:

Could changing file ownership or mode bits also help achieve this?

Possibly, but depending on the scenario, the app may try to reset those permissions. Making a file immutable via root pretty much guarantees that it won't be written to.

Offline

#5 2022-04-30 00:38:21

dchmelik
Member
From: USA
Registered: 2022-04-02
Posts: 5
Website

Re: git blocked; can't report bugs (add 'session and autostart' blacklist)

Apparently skype has the option somewhere in a menu and I forgot to turn it off.

Offline

Board footer

Powered by FluxBB