Xfce Forum

Sub domains
 

You are not logged in.

#1 2023-08-19 22:22:24

advice1010
Member
Registered: 2023-02-19
Posts: 74

[SOLVED] Whisker menu slight pause when using super key to open it

I apologize I don't really think there is an answer for this but I have my Whisker menu set to open when super key is pressed and I notice when using this hotkey the menu doesn't just load up fast, like I would think it would be instant because XFCE does not have any kind of animation linked to this, but there is an odd slight pause between hitting the key and the menu appearing.  It is less noticable when using mouse click on menu icon to open it, not sure if has to do when length of key stroke.  It is not a major issue but just something does not feel right about it.
Does anyone else notice this?  Is there a setting somewhere something like a "make Whisker menu open quicker" type of thing..... smile

Also, another thing I noticed is that usually in other OS / DE when you hit the super key once the menu opens and then if you hit it again the menu toggles closed.
Not sure why but with XFCE / Whisker menu you have to hit the super key twice to close it.  I know you can also use escape key.
Again not a major issue but just curious why this would occur, just figured while I was already asking a question about Whisker menu I might as well mention it.

Thank You

Last edited by advice1010 (2023-12-04 22:10:12)

Offline

#2 2023-09-05 22:07:34

advice1010
Member
Registered: 2023-02-19
Posts: 74

Re: [SOLVED] Whisker menu slight pause when using super key to open it

Everything else in Xfce is relatively fast, so this little pause just feels strange.
I know the menu is more complex to load then a context menu, but when you RMB click the context menu is instant.
As mentioned there probably isn't any solution for this but would anyone be able to at least let me know if they experience this or not?

Not a huge issue, just curious if these two items mentioned are common or not.

Thank You

Offline

#3 2023-09-05 23:37:12

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,205

Re: [SOLVED] Whisker menu slight pause when using super key to open it

Can you confirm that the command associated with the super key is "xfce4-popup-whiskermenu" (Settings Manager > Keyboard > Application Shortcuts) ? If so, what happens if you run that command in a terminal window?
- Any messages in the terminal window?
- Is the popup faster?


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#4 2023-09-06 16:02:12

ds
Member
Registered: 2023-09-06
Posts: 6

Re: [SOLVED] Whisker menu slight pause when using super key to open it

Interesting. I found mine behaves like that too (a tiny bit delay when using the super key, but not when using the mouse button.) I can't find super key association in the Application Shortcuts. In fact, xfce4-popup-whiskermenu is associated with Alt+F1 by default. And if I use Alt+F1 it's instantaneous. Running the command via Terminal is also instantaneous.

While playing around, I found that pressing the Alt+F1 shortcut and holding it will make whisker menu flickers very quickly, but the super key would not do that. Instead, holding the super key for just a little (around 1 second or more) will not trigger the whisker menu at all. The same when trying to close the whisker menu using the super key. Holding it more than 1 second won't do, you simply have to tap.

So maybe it is intentional; the delay is probably to make sure that if the super key is accidentally hold, the whisker menu would not pop in and out frantically.

Last edited by ds (2023-09-06 16:04:20)

Offline

#5 2023-09-06 18:42:28

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,205

Re: [SOLVED] Whisker menu slight pause when using super key to open it

ds wrote:

Interesting. I found mine behaves like that too (a tiny bit delay when using the super key, but not when using the mouse button.) I can't find super key association in the Application Shortcuts. In fact, xfce4-popup-whiskermenu is associated with Alt+F1 by default. And if I use Alt+F1 it's instantaneous. Running the command via Terminal is also instantaneous.

Do you have "xcape" running? It remaps the super key to use Alt-F1. If so, it may be the cause of the delay.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#6 2023-09-07 05:56:50

ds
Member
Registered: 2023-09-06
Posts: 6

Re: [SOLVED] Whisker menu slight pause when using super key to open it

Ah yes, you're right! I have xcape running. When I turned it off and set the super key to xfce4-popup-whiskermenu manually now it has no delay, the same as using Alt+F1.

Curiously, they behave differently. Holding the super key opens the whisker menu immediately but won't make it flicker on and off, unlike the Alt+F1.

Offline

#7 2023-09-07 09:53:41

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,205

Re: [SOLVED] Whisker menu slight pause when using super key to open it

The issue with using just the Super key for the menu, is that you can't properly use any other shortcuts where the Super key is paired with another key, as they will both be triggered. However, it does look that this bug has been recently resolved.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#8 2023-09-08 16:47:52

advice1010
Member
Registered: 2023-02-19
Posts: 74

Re: [SOLVED] Whisker menu slight pause when using super key to open it

Thought I figured out a solution but instead I may have figured out why this pause is there.

@ToZ
Thank you for your response
Also saw that you just responded again, I will check this link out, Thank you.
Still a little confused how version numbers / updates in Xfce work, so it may have been fixed?
Note: I typed all this below before seeing your last response.

@ds
Thank you for verifying this, nice to know that it is not just me / system.
I imagine the menu does not popup when you hold down the super key because it must take in account the use of the “super” as a modifier key when combined with other keys.
Holding down the “super” before I did items below produced same results, no menu if held down for a second.

SOME TESTS / INFORMATION
-Looked in my “Keyboard – Application Shortcuts” and did not see anything about Whisker menu and also no “super” key shortcut
-Checked “Settings Editor – xfce4-keyboard-shortcuts” nothing in there.
-Ran the command from terminal and it does appear to open up the menu quicker
-Decided to create new hotkey in “Keyboard – Application Shortcuts” shows up as “super L”

However some odd stuff occurred after I created this shortcut.
-Now if you hold down the super key the menu opens no matter what, so now the super key can no longer be used as a modifier key
-Now if you hit the super key to open it, if you try to toggle it closed by hitting super key again, mentioned above that before if you hit the key twice it would close it (as if you hit escape key), but now if you hit the key again even once while open it does one flicker and opens itself again.

I thought maybe it was because the hotkey was already set, so this was doubling the action and that is what it was.
I looked everywhere I could think and the last thing I remembered seeing this in “Session and Startup”
In there my distro had the following command set to run at startup “Xfce-superkey”.
When I killed this process that runs in the background, it fixes the all the issues, even the having to hit the super key twice to toggle the menu close is gone.  The menu now loads up as quick as when you click on icon with the mouse.

However, now if you use the super key as a modifier it opens up the Whisker menu before doing so.
Like if you hit “super + e” to open your FM, you will see the Whisker menu flash open before your FM opens.
So this is probably why this pause is occurring?
I was so excited before realizing this last part, thought it worked.
Sorry for the long response but I was typing all of this as I was testing all of this.

Thank you both for your help, hopefully this will help others in the future.
If anyone confirms all of this, please share the results for others.

Everything that I typed here may be irrelevant if this was fixed as ToZ mentioned above?

Last edited by advice1010 (2023-09-08 16:59:58)

Offline

#9 2023-09-08 17:18:53

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,205

Re: [SOLVED] Whisker menu slight pause when using super key to open it

Xfce-superkey is most probably a shell script that runs xcape. So this is a second confirmation that xcape is the culprit in the delay.

As for the fix, it has been fixed in the git development branch for libxfce4ui version 4.19.3 and backported to libxfce4ui version 4.18.5. It will depend on when your distro officially makes these versions available.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#10 2023-10-19 21:10:00

advice1010
Member
Registered: 2023-02-19
Posts: 74

Re: [SOLVED] Whisker menu slight pause when using super key to open it

@ToZ
Apparently "xfce-superkey" is a fork of "ksuperkey" which is a fork of "xcape"
https://github.com/JixunMoe/xfce-superkey
If this is true then does that mean that this "xcape" fix will not solve this issue.
Little confused because in general apparently this pause is due to the menu loading on the release of the super key, yet the odd thing is is that other DEs I have tried in the past none have this noticeable pause.
Even Windows uses this and I don't think has a pause either.  Wonder how all these other DEs achieve this then?  Do they just have some kind of time based setting set to a quicker release so it isn't as noticeable?

Thank you

@Anyone Interested
I don't like to mention other DEs on a DEs forum but this may help as an example.
If anyone tries Plasma for instance with the "Kicker" menu, it loads up instantly with super key, but the super key can still be used as a modifier as well.
(If anyone tests this Plasma example, helps to turn off menu animation, Desktop Effects - Sliding Popups - uncheck)

A little off topic but similar, not as noticeable of a pause but I also notice a little pause when loading the XFCE Application Finder.
Even without being linked to the super key itself (Alt+F3 expanded / Alt+F2 collapsed) these finders (more noticeable with expanded) have a slight pause as well. It isn't animating / fading in but kind of feels like the windows open at header and like very quickly fades down. Not sure if anyone experiences this as well? I don't imagine there is any way to get these finders to open instantly either but if anyone has any ideas please let me know. Obviously not a major issue, for example I tested “Rofi” a little and that loads up instantly which just feels better, but I would rather use the built in finder, would think it would load up just as fast being that it is a part of XFCE.
Nothing saying that any program has to load up instantly but it is just with searches / finders / menus / context menus / etc. just feels better when load up instantly.  With XFCE known for being quick, it just seems strange when they don't load up these items as quick as others.

Anways thank you

Last edited by advice1010 (2023-10-19 21:13:58)

Offline

#11 2023-11-03 10:56:48

kamelox
Member
From: Barcelona (Spain)
Registered: 2023-11-03
Posts: 1

Re: [SOLVED] Whisker menu slight pause when using super key to open it

ToZ wrote:
ds wrote:

Interesting. I found mine behaves like that too (a tiny bit delay when using the super key, but not when using the mouse button.) I can't find super key association in the Application Shortcuts. In fact, xfce4-popup-whiskermenu is associated with Alt+F1 by default. And if I use Alt+F1 it's instantaneous. Running the command via Terminal is also instantaneous.

Do you have "xcape" running? It remaps the super key to use Alt-F1. If so, it may be the cause of the delay.

Thank you for this suggestion. I had the same problem with the Whiskermenu opening. Actually, I wouldn't have explained it as a delay but as a need to hold the super key for longer than some milliseconds. The menu blinked if the period was smaller than the required one.

Also, I wanted to say that after killing xcape, another problem that I could imagine that were related, also disappeared. I have enabled the drop-down XFCE terminal by pressing "Ctrl L + Super L", working as a switch, i.e., the same combination shows and hides the terminal. The problem was that, to hide the terminal I usually had more problems: the whiskermenu opened unless your cursor was over the drop-down terminal. After killing xcape, neither of the problems appears.

I don't know if this setting will remain after rebooting (I will check it soon). smile

Offline

#12 2023-12-04 22:16:00

advice1010
Member
Registered: 2023-02-19
Posts: 74

Re: [SOLVED] Whisker menu slight pause when using super key to open it

@ToZ
Has been a little while, have been very distracted with other things but I recently discovered something that I thought I would share.
I recently updated my Whisker menu to a newer version (2.8.0) and noticed that the following two issues have been fixed....
1.) Removes the odd pause before showing the Whisker menu
2.) You can now tap the super key again to toggle the menu close if you change your mind, instead of hitting escape.

However now in this new version, the ability to adjust the size of the menu in realtime with grabs has been removed, so one solved one problem and now generated another one.  I really liked this feature, I will be making a separate post about this.
EDIT: here is link if anyone is interested
https://forum.xfce.org/viewtopic.php?pid=74024#p74024

Thank you guys again for all your help

Last edited by advice1010 (2023-12-04 22:32:02)

Offline

Board footer

Powered by FluxBB