Xfce Forum

Sub domains
 

You are not logged in.

#1 2024-02-08 02:29:27

shellmaster
Member
Registered: 2024-02-07
Posts: 5

xfce terminal can't change colors under Artix

Hello,
Since the latest update, I can't change colors from xfce terminal's preferences. I have tried removing all terminalrc files and loging into uncustomized xfce but the problem remains the same. This is the case for Artix runit and openrc though I hardly think colors have anything to do with init.

This problem doesn't occur under Arch with the same xfce and xfce4-terminal version.

~~~
xfce4-terminal --version
xfce4-terminal 1.1.2 (Xfce 4.18)

Last edited by shellmaster (2024-02-08 02:38:36)

Offline

#2 2024-02-08 11:21:50

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 10,891

Re: xfce terminal can't change colors under Artix

Is xfconfd installed and running? xfce4-terminal has migrated to using xfconf as the backend (no longer using terminalrc) as of version 1.1.0.

Also, is there any info in your log files about xfce4-terminal and/or xfconfd?


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#3 2024-02-08 11:55:49

shellmaster
Member
Registered: 2024-02-07
Posts: 5

Re: xfce terminal can't change colors under Artix

huh it was init related after all.

No there is no xfconf service or daemon in Artix. xfconf it self is installed though.

How can I run it from the command line? perhaps I can write a service for it ...

Offline

#4 2024-02-08 12:14:29

shellmaster
Member
Registered: 2024-02-07
Posts: 5

Re: xfce terminal can't change colors under Artix

xfconf--4.18.3-1 is installed, but I only get xfconf-query in the shell.

Also there are no errors or logs from xfce terminal

~
Upon further investigation , I see that I can go to the terminal tab in xfce settings editor and changing the values there effectively changes the terminal colors.
But this is highly inconvenient, Do I have to set colors one by one for my fav colorscheme ?

Offline

#5 2024-02-08 18:55:27

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 10,891

Re: xfce terminal can't change colors under Artix

No, you shouldn't have to. But its weird that making the change from the terminal preferences doesn't work (indicating a possible dbus/xfconfd connection problem), but that changing the setting in the settings editor works (indicating no issue with dbus/xfconfd connectivity).

You're not running the terminal as root or something, are you? Because by default root terminal won't have access to user-based dbus/xfconfd. If so, try launching xfce4-terminal as "dbus-launch xfce4-terminal".


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#6 2024-02-11 18:04:46

shellmaster
Member
Registered: 2024-02-07
Posts: 5

Re: xfce terminal can't change colors under Artix

launching xfce terminal from an xterm instance: dbus-launch xfce4-terminal

(xfce4-terminal:21156): xfce4-terminal-WARNING **: 21:29:05.007: Failed to connect to session manager: Failed to connect to the session manager: SESSION_MANAGER environment variable not defined

Attempting to change colors:

(xfce4-terminal:21156): xfce4-terminal-CRITICAL **: 21:30:21.690: terminal_preferences_dialog_presets_changed: assertion 'TERMINAL_IS_PREFERENCES_DIALOG (widget)' failed

I'm not running a root terminal, it is just a normal terminal. I have sddm running. I tried in both xfce session and i3wm and in both cases these are the errors Im getting.

Also I have no idea what the value of SESSION_MANAGER environment variable should be.
can it be something like `export SESSION_MANAGER=$(cat /proc/self/sessionid)` ?

Last edited by shellmaster (2024-02-11 18:06:03)

Offline

#7 2024-02-11 20:56:21

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 10,891

Re: xfce terminal can't change colors under Artix

Attempting to change colors:

(xfce4-terminal:21156): xfce4-terminal-CRITICAL **: 21:30:21.690: terminal_preferences_dialog_presets_changed: assertion 'TERMINAL_IS_PREFERENCES_DIALOG (widget)' failed

It looks like its a known bug that has been fixed and will be released in the next version.

shellmaster wrote:

launching xfce terminal from an xterm instance: dbus-launch xfce4-terminal

(xfce4-terminal:21156): xfce4-terminal-WARNING **: 21:29:05.007: Failed to connect to session manager: Failed to connect to the session manager: SESSION_MANAGER environment variable not defined

That being said, you have some weird error messages there. Do you get the same if you run just "xfce4-terminal" without the dbus-launch?

Also I have no idea what the value of SESSION_MANAGER environment variable should be.
can it be something like `export SESSION_MANAGER=$(cat /proc/self/sessionid)` ?

Mine is set to:

SESSION_MANAGER=local/xfgit:@/tmp/.ICE-unix/13538,unix/xfgit:/tmp/.ICE-unix/13538

Its set up at session initiation. Are you using xfce4-session?


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#8 2024-02-22 02:56:46

merazi
Member
Registered: 2024-02-22
Posts: 6
Website

Re: xfce terminal can't change colors under Artix

Henlo, I have the same behaviour with XFCE4-TERMINAL, plus when I try to disable the app menu from right clicking on the desktop that doesn't get applied either...

My SESSION_MANAGER looks like this:

local/archlinux:@/tmp/.ICE-unix/153157,unix/archlinux:/tmp/.ICE-unix/153157

I really don't want to say it, but... I'm on arch btw, and I'm new to the forum too.

Offline

#9 2024-02-22 11:07:32

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 10,891

Re: xfce terminal can't change colors under Artix

merazi wrote:

Henlo, I have the same behaviour with XFCE4-TERMINAL

This is fixed in git master and will be rolled out in the next release shortly.

plus when I try to disable the app menu from right clicking on the desktop that doesn't get applied either...

Can you run xfdesktop in debug mode:

xfdesktop -Q && xfdesktop -e

...and try to disable the appmenu and see whats recorded in the debug output.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#10 2024-02-22 15:31:44

merazi
Member
Registered: 2024-02-22
Posts: 6
Website

Re: xfce terminal can't change colors under Artix

Henlo,

I built master branch for xfce4-terminal and the issue is now gone, thanks!

Regarding xfdesktop, this is the entire output: https://pastebin.com/x84WdFyi

The lines that say "DBG[menu.c:77] menu_populate(): show desktop menu icons TRUE" appeared when I right-clicked on the desktop, it doesn't matter if app menu is turned on or off those lines always appear when I right click on the desktop.

Offline

#11 2024-02-22 16:58:17

merazi
Member
Registered: 2024-02-22
Posts: 6
Website

Re: xfce terminal can't change colors under Artix

Okay... I just noticed I was changing the wrong option in the xfdesktop menu, I feel so dumb now, sorry! Everything works as expected.

Offline

Board footer

Powered by FluxBB