Xfce Forum

Sub domains
 

You are not logged in.

#1 2015-02-22 21:59:06

zotya62
Member
Registered: 2015-02-22
Posts: 13

[Solved] XFCE system sounds

I am using Linux Mint 17 XFCE. How to easily set up system sounds? (login, logout sound, etc.) I have read many description like this http://pclosmag.com/html/Issues/201305/page09.html  My opinion is that this is simply not feasible.

Offline

#2 2015-02-22 22:12:31

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,058

Re: [Solved] XFCE system sounds

There have been a number of threads on this forum about getting system sounds set up:

- https://forum.xfce.org/viewtopic.php?id=8618
- https://forum.xfce.org/viewtopic.php?id=7199
- https://forum.xfce.org/viewtopic.php?id=7780
- https://forum.xfce.org/viewtopic.php?id=8782
- https://forum.xfce.org/viewtopic.php?id=9094

...to list a few. Have a read through them to see if they help you get system sounds running.

Offline

#3 2015-02-23 13:18:02

zotya62
Member
Registered: 2015-02-22
Posts: 13

Re: [Solved] XFCE system sounds

ToZ wrote:

There have been a number of threads on this forum about getting system sounds set up:

- https://forum.xfce.org/viewtopic.php?id=8618
- https://forum.xfce.org/viewtopic.php?id=7199
- https://forum.xfce.org/viewtopic.php?id=7780
- https://forum.xfce.org/viewtopic.php?id=8782
- https://forum.xfce.org/viewtopic.php?id=9094

...to list a few. Have a read through them to see if they help you get system sounds running.

I have read these threads.  These relate to Ubuntu. I have Linux Mint. Which  Canberra packages need to install?

Last edited by zotya62 (2015-02-23 13:21:53)

Offline

#4 2015-02-23 13:46:51

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,058

Re: [Solved] XFCE system sounds

Linux Mint is based on Ubuntu. Try these instructions.

Offline

#5 2015-02-23 15:00:30

sixsixfive
Member
From: behind you
Registered: 2012-04-08
Posts: 579
Website

Re: [Solved] XFCE system sounds

also for debian:

apt-get install moblin-sound-theme libcanberra-gtk-module libcanberra-gtk3-module
printf "gtk-modules = \042canberra-gtk-module\042" >>~/.gtkrc-2.0
xfconf-query -c xsettings -p /Net/SoundThemeName -s moblin
xfconf-query -c xsettings -p /Net/EnableEventSounds -T
xfconf-query -c xsettings -p /Net/EnableInputFeedbackSounds -T

PS: per default canberra will use ALSA so you might need: libcanberra-pulse or libcanberra-gstreamer for other backends
PPS: there is also the freedesktop sound theme, but you need ogg support for it

Offline

#6 2015-02-24 14:51:35

zotya62
Member
Registered: 2015-02-22
Posts: 13

Re: [Solved] XFCE system sounds

ToZ wrote:

Linux Mint is based on Ubuntu. Try these instructions.

I have made thes steps and there is no logout and any other system event sound except login and volume control. Also i have created  the necessary files but nothing changed.

Offline

#7 2015-02-24 15:08:47

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,058

Re: [Solved] XFCE system sounds

Can you post back the results of the following commands:

dpkg -l | cut -d' ' -f3 | grep -E 'sox|canberra'
ls -l /usr/share/sounds
xfconf-query -c xsettings -p /Net/EnableEventSounds
xfconf-query -c xsettings -p /Net/EnableInputFeedbackSounds
xfconf-query -c xsettings -p /Net/SoundThemeName
env | grep GTK_MODULES
cat /usr/local/bin/xfce4-session
ls -l /usr/local/bin/xfce4-session

And also, make sure your System Sounds are turned up in pavucontrol (the volume control indicator).

Offline

#8 2015-02-24 17:03:59

zotya62
Member
Registered: 2015-02-22
Posts: 13

Re: [Solved] XFCE system sounds

ToZ wrote:

Can you post back the results of the following commands:

dpkg -l | cut -d' ' -f3 | grep -E 'sox|canberra'
ls -l /usr/share/sounds
xfconf-query -c xsettings -p /Net/EnableEventSounds
xfconf-query -c xsettings -p /Net/EnableInputFeedbackSounds
xfconf-query -c xsettings -p /Net/SoundThemeName
env | grep GTK_MODULES
cat /usr/local/bin/xfce4-session
ls -l /usr/local/bin/xfce4-session

And also, make sure your System Sounds are turned up in pavucontrol (the volume control indicator).


dpkg -l | cut -d' ' -f3 | grep -E 'sox|canberra'
gnome-session-canberra
libcanberra-gtk0:i386
libcanberra-gtk3-0:i386
libcanberra-pulse:i386
libcanberra0:i386
libsox-fmt-alsa:i386
libsox-fmt-base:i386
libsox2:i386
sox

ls -l /usr/share/sounds
összesen 3456
drwxr-xr-x 2 root   root     4096 jún   23  2014 alsa
drwxr-xr-x 3 zoli62 zoli62   4096 febr  24 12:59 Borealis
drwxr-xr-x 3 root   root     4096 jún   23  2014 freedesktop
-rw-r--r-- 1 root   root    23246 júl    6  2014 KDE-Im-Cant-Connect.ogg
-rw-r--r-- 1 root   root    23459 júl    6  2014 KDE-Im-Connection-Lost.ogg
-rw-r--r-- 1 root   root    18426 júl    6  2014 KDE-Im-Contact-In.ogg
-rw-r--r-- 1 root   root    17798 júl    6  2014 KDE-Im-Contact-Out.ogg
-rw-r--r-- 1 root   root    22583 júl    6  2014 KDE-Im-Error-On-Connection.ogg
-rw-r--r-- 1 root   root    24739 júl    6  2014 KDE-Im-Highlight-Msg.ogg
-rw-r--r-- 1 root   root    23372 júl    6  2014 KDE-Im-Internal-Error.ogg
-rw-r--r-- 1 root   root    23595 júl    6  2014 KDE-Im-Irc-Event.ogg
-rw-r--r-- 1 root   root    23474 júl    6  2014 KDE-Im-Low-Priority-Message.ogg
-rw-r--r-- 1 root   root    22733 júl    6  2014 KDE-Im-Message-In.ogg
-rw-r--r-- 1 root   root    22724 júl    6  2014 KDE-Im-Message-Out.ogg
-rw-r--r-- 1 root   root    23299 júl    6  2014 KDE-Im-Network-Problems.ogg
-rw-r--r-- 1 root   root    23386 júl    6  2014 KDE-Im-New-Mail.ogg
-rw-r--r-- 1 root   root    28948 júl    6  2014 KDE-Im-Nudge.ogg
-rw-r--r-- 1 root   root    61621 júl    6  2014 KDE-Im-Phone-Ring.ogg
-rw-r--r-- 1 root   root    35885 júl    6  2014 KDE-Im-Sms.ogg
-rw-r--r-- 1 root   root    32643 júl    6  2014 KDE-Im-User-Auth.ogg
-rw-r--r-- 1 root   root    39958 júl    6  2014 KDE-K3B-Finish-Error.ogg
-rw-r--r-- 1 root   root    41497 júl    6  2014 KDE-K3B-Finish-Success.ogg
-rw-r--r-- 1 root   root    41892 júl    6  2014 KDE-K3B-Insert-Medium.ogg
-rw-r--r-- 1 root   root    40670 júl    6  2014 KDE-Sys-App-Error-Critical.ogg
-rw-r--r-- 1 root   root    41410 júl    6  2014 KDE-Sys-App-Error.ogg
-rw-r--r-- 1 root   root    41318 júl    6  2014 KDE-Sys-App-Error-Serious.ogg
-rw-r--r-- 1 root   root    40541 júl    6  2014 KDE-Sys-App-Error-Serious-Very.ogg
-rw-r--r-- 1 root   root    24711 júl    6  2014 KDE-Sys-App-Message.ogg
-rw-r--r-- 1 root   root    35896 júl    6  2014 KDE-Sys-App-Negative.ogg
-rw-r--r-- 1 root   root    37107 júl    6  2014 KDE-Sys-App-Positive.ogg
-rw-r--r-- 1 root   root    41382 júl    6  2014 KDE-Sys-Error-Printing.ogg
-rw-r--r-- 1 root   root    40133 júl    6  2014 KDE-Sys-File-Open-Foes.ogg
-rw-r--r-- 1 root   root    41654 júl    6  2014 KDE-Sys-List-End.ogg
-rw-r--r-- 1 root   root    40109 júl    6  2014 KDE-Sys-List-Match-Multiple.ogg
-rw-r--r-- 1 root   root    41278 júl    6  2014 KDE-Sys-List-Match-No.ogg
-rw-r--r-- 1 root   root   225872 júl    6  2014 KDE-Sys-Log-In-Long.ogg
-rw-r--r-- 1 root   root   244953 júl    6  2014 KDE-Sys-Log-In.ogg
-rw-r--r-- 1 root   root   154528 júl    6  2014 KDE-Sys-Log-In-Short.ogg
-rw-r--r-- 1 root   root    48592 júl    6  2014 KDE-Sys-Log-Out.ogg
-rw-r--r-- 1 root   root    40889 júl    6  2014 KDE-Sys-Question.ogg
-rw-r--r-- 1 root   root    40541 júl    6  2014 KDE-Sys-Special.ogg
-rw-r--r-- 1 root   root    40208 júl    6  2014 KDE-Sys-Trash-Emptied.ogg
-rw-r--r-- 1 root   root    41337 júl    6  2014 KDE-Sys-Warning.ogg
-rw-r--r-- 1 root   root     8363 júl    6  2014 KDE-Window-All-Desktops-Not.ogg
-rw-r--r-- 1 root   root     8712 júl    6  2014 KDE-Window-All-Desktops.ogg
-rw-r--r-- 1 root   root     8865 júl    6  2014 KDE-Window-Close.ogg
-rw-r--r-- 1 root   root     7977 júl    6  2014 KDE-Window-Maximize.ogg
-rw-r--r-- 1 root   root    11200 júl    6  2014 KDE-Window-Minimize.ogg
-rw-r--r-- 1 root   root    13575 júl    6  2014 KDE-Window-Move.ogg
-rw-r--r-- 1 root   root    10711 júl    6  2014 KDE-Window-Move-Stop.ogg
-rw-r--r-- 1 root   root     9959 júl    6  2014 KDE-Window-Shade-Down.ogg
-rw-r--r-- 1 root   root     9439 júl    6  2014 KDE-Window-Shade-Up.ogg
drwxr-xr-x 3 root   root     4096 jún   23  2014 LinuxMint
-rw-r--r-- 1 root   root    23314 jún   18  2014 linuxmint-gdm.wav
-rw-r--r-- 1 root   root   707756 jún   18  2014 linuxmint-login.wav
-rw-r--r-- 1 root   root   708644 jún   18  2014 linuxmint-logout.wav
drwxr-xr-x 2 root   root     4096 okt   28 19:18 purple
drwxr-xr-x 2 root   root     4096 jún   23  2014 speech-dispatcher


xfconf-query -c xsettings -p /Net/EnableEventSounds
true

xfconf-query -c xsettings -p /Net/EnableInputFeedbackSoundstrue
true

xfconf-query -c xsettings -p /Net/SoundThemeName
Borealis

env | grep GTK_MODULES
GTK_MODULES=:canberra-gtk-module

cat /usr/local/bin/xfce4-session
#!/bin/bash

# run the real xfce4-session executable
/usr/bin/xfce4-session

# on exit, run my stuff
# canberra-gtk-play -f /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg
canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/Exit1_2.ogg

ls -l /usr/local/bin/xfce4-session
-rwxr-xr-x 1 root root 245 febr  24 13:54 /usr/local/bin/xfce4-session

Offline

#9 2015-02-24 18:33:03

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,058

Re: [Solved] XFCE system sounds

dpkg -l | cut -d' ' -f3 | grep -E 'sox|canberra'
gnome-session-canberra
libcanberra-gtk0:i386
libcanberra-gtk3-0:i386
libcanberra-pulse:i386
libcanberra0:i386
libsox-fmt-alsa:i386
libsox-fmt-base:i386
libsox2:i386
sox

As per sixsixfive's comment, my Xubuntu system has the libcanberra modules installed by default. Can you install them on your system:

sudo apt-get install libcanberra-gtk-module libcanberra-gtk3-module

-----

ls -l /usr/share/sounds
összesen 3456
drwxr-xr-x 2 root   root     4096 jún   23  2014 alsa
drwxr-xr-x 3 zoli62 zoli62   4096 febr  24 12:59 Borealis
drwxr-xr-x 3 root   root     4096 jún   23  2014 freedesktop
-rw-r--r-- 1 root   root    23246 júl    6  2014 KDE-Im-Cant-Connect.ogg
-rw-r--r-- 1 root   root    23459 júl    6  2014 KDE-Im-Connection-Lost.ogg
-rw-r--r-- 1 root   root    18426 júl    6  2014 KDE-Im-Contact-In.ogg
-rw-r--r-- 1 root   root    17798 júl    6  2014 KDE-Im-Contact-Out.ogg
-rw-r--r-- 1 root   root    22583 júl    6  2014 KDE-Im-Error-On-Connection.ogg
-rw-r--r-- 1 root   root    24739 júl    6  2014 KDE-Im-Highlight-Msg.ogg
-rw-r--r-- 1 root   root    23372 júl    6  2014 KDE-Im-Internal-Error.ogg
-rw-r--r-- 1 root   root    23595 júl    6  2014 KDE-Im-Irc-Event.ogg
-rw-r--r-- 1 root   root    23474 júl    6  2014 KDE-Im-Low-Priority-Message.ogg
-rw-r--r-- 1 root   root    22733 júl    6  2014 KDE-Im-Message-In.ogg
-rw-r--r-- 1 root   root    22724 júl    6  2014 KDE-Im-Message-Out.ogg
-rw-r--r-- 1 root   root    23299 júl    6  2014 KDE-Im-Network-Problems.ogg
-rw-r--r-- 1 root   root    23386 júl    6  2014 KDE-Im-New-Mail.ogg
-rw-r--r-- 1 root   root    28948 júl    6  2014 KDE-Im-Nudge.ogg
-rw-r--r-- 1 root   root    61621 júl    6  2014 KDE-Im-Phone-Ring.ogg
-rw-r--r-- 1 root   root    35885 júl    6  2014 KDE-Im-Sms.ogg
-rw-r--r-- 1 root   root    32643 júl    6  2014 KDE-Im-User-Auth.ogg
-rw-r--r-- 1 root   root    39958 júl    6  2014 KDE-K3B-Finish-Error.ogg
-rw-r--r-- 1 root   root    41497 júl    6  2014 KDE-K3B-Finish-Success.ogg
-rw-r--r-- 1 root   root    41892 júl    6  2014 KDE-K3B-Insert-Medium.ogg
-rw-r--r-- 1 root   root    40670 júl    6  2014 KDE-Sys-App-Error-Critical.ogg
-rw-r--r-- 1 root   root    41410 júl    6  2014 KDE-Sys-App-Error.ogg
-rw-r--r-- 1 root   root    41318 júl    6  2014 KDE-Sys-App-Error-Serious.ogg
-rw-r--r-- 1 root   root    40541 júl    6  2014 KDE-Sys-App-Error-Serious-Very.ogg
-rw-r--r-- 1 root   root    24711 júl    6  2014 KDE-Sys-App-Message.ogg
-rw-r--r-- 1 root   root    35896 júl    6  2014 KDE-Sys-App-Negative.ogg
-rw-r--r-- 1 root   root    37107 júl    6  2014 KDE-Sys-App-Positive.ogg
-rw-r--r-- 1 root   root    41382 júl    6  2014 KDE-Sys-Error-Printing.ogg
-rw-r--r-- 1 root   root    40133 júl    6  2014 KDE-Sys-File-Open-Foes.ogg
-rw-r--r-- 1 root   root    41654 júl    6  2014 KDE-Sys-List-End.ogg
-rw-r--r-- 1 root   root    40109 júl    6  2014 KDE-Sys-List-Match-Multiple.ogg
-rw-r--r-- 1 root   root    41278 júl    6  2014 KDE-Sys-List-Match-No.ogg
-rw-r--r-- 1 root   root   225872 júl    6  2014 KDE-Sys-Log-In-Long.ogg
-rw-r--r-- 1 root   root   244953 júl    6  2014 KDE-Sys-Log-In.ogg
-rw-r--r-- 1 root   root   154528 júl    6  2014 KDE-Sys-Log-In-Short.ogg
-rw-r--r-- 1 root   root    48592 júl    6  2014 KDE-Sys-Log-Out.ogg
-rw-r--r-- 1 root   root    40889 júl    6  2014 KDE-Sys-Question.ogg
-rw-r--r-- 1 root   root    40541 júl    6  2014 KDE-Sys-Special.ogg
-rw-r--r-- 1 root   root    40208 júl    6  2014 KDE-Sys-Trash-Emptied.ogg
-rw-r--r-- 1 root   root    41337 júl    6  2014 KDE-Sys-Warning.ogg
-rw-r--r-- 1 root   root     8363 júl    6  2014 KDE-Window-All-Desktops-Not.ogg
-rw-r--r-- 1 root   root     8712 júl    6  2014 KDE-Window-All-Desktops.ogg
-rw-r--r-- 1 root   root     8865 júl    6  2014 KDE-Window-Close.ogg
-rw-r--r-- 1 root   root     7977 júl    6  2014 KDE-Window-Maximize.ogg
-rw-r--r-- 1 root   root    11200 júl    6  2014 KDE-Window-Minimize.ogg
-rw-r--r-- 1 root   root    13575 júl    6  2014 KDE-Window-Move.ogg
-rw-r--r-- 1 root   root    10711 júl    6  2014 KDE-Window-Move-Stop.ogg
-rw-r--r-- 1 root   root     9959 júl    6  2014 KDE-Window-Shade-Down.ogg
-rw-r--r-- 1 root   root     9439 júl    6  2014 KDE-Window-Shade-Up.ogg
drwxr-xr-x 3 root   root     4096 jún   23  2014 LinuxMint
-rw-r--r-- 1 root   root    23314 jún   18  2014 linuxmint-gdm.wav
-rw-r--r-- 1 root   root   707756 jún   18  2014 linuxmint-login.wav
-rw-r--r-- 1 root   root   708644 jún   18  2014 linuxmint-logout.wav
drwxr-xr-x 2 root   root     4096 okt   28 19:18 purple
drwxr-xr-x 2 root   root     4096 jún   23  2014 speech-dispatcher

Though probably not relevant, you should change the ownership rights on the Borealis directory to root:

sudo chmod -R root:root /usr/share/sounds/Borealis

-----

xfconf-query -c xsettings -p /Net/EnableEventSounds
true

xfconf-query -c xsettings -p /Net/EnableInputFeedbackSoundstrue
true

xfconf-query -c xsettings -p /Net/SoundThemeName
Borealis

env | grep GTK_MODULES
GTK_MODULES=:canberra-gtk-module

cat /usr/local/bin/xfce4-session
#!/bin/bash

# run the real xfce4-session executable
/usr/bin/xfce4-session

# on exit, run my stuff
# canberra-gtk-play -f /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg
canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/Exit1_2.ogg

ls -l /usr/local/bin/xfce4-session
-rwxr-xr-x 1 root root 245 febr  24 13:54 /usr/local/bin/xfce4-session

Looks good.

-----

ToZ wrote:

And also, make sure your System Sounds are turned up in pavucontrol (the volume control indicator).

Is the system sounds volume turned up in your sound settings? Try minimizing and maximizing a window (you should hear a zoom sound).

-----

Can also try running directly:

canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/Exit1_2.ogg

...to see if your sound system is set up properly?

Offline

#10 2015-02-25 00:50:58

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,107

Re: [Solved] XFCE system sounds

Just an observation: I jumped through all the hoops that enabling system sounds on a previous linux Mint Xfce distro required. After approximately one week, I realized just how annoying it was when the computer made noises every time I did anything. It might be a kindness to also include instructions for disabling the system sounds for when that happens.

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#11 2015-02-25 03:48:16

zotya62
Member
Registered: 2015-02-22
Posts: 13

Re: [Solved] XFCE system sounds

ToZ wrote:

dpkg -l | cut -d' ' -f3 | grep -E 'sox|canberra'
gnome-session-canberra
libcanberra-gtk0:i386
libcanberra-gtk3-0:i386
libcanberra-pulse:i386
libcanberra0:i386
libsox-fmt-alsa:i386
libsox-fmt-base:i386
libsox2:i386
sox

As per sixsixfive's comment, my Xubuntu system has the libcanberra modules installed by default. Can you install them on your system:

sudo apt-get install libcanberra-gtk-module libcanberra-gtk3-module

-----

ls -l /usr/share/sounds
összesen 3456
drwxr-xr-x 2 root   root     4096 jún   23  2014 alsa
drwxr-xr-x 3 zoli62 zoli62   4096 febr  24 12:59 Borealis
drwxr-xr-x 3 root   root     4096 jún   23  2014 freedesktop
-rw-r--r-- 1 root   root    23246 júl    6  2014 KDE-Im-Cant-Connect.ogg
-rw-r--r-- 1 root   root    23459 júl    6  2014 KDE-Im-Connection-Lost.ogg
-rw-r--r-- 1 root   root    18426 júl    6  2014 KDE-Im-Contact-In.ogg
-rw-r--r-- 1 root   root    17798 júl    6  2014 KDE-Im-Contact-Out.ogg
-rw-r--r-- 1 root   root    22583 júl    6  2014 KDE-Im-Error-On-Connection.ogg
-rw-r--r-- 1 root   root    24739 júl    6  2014 KDE-Im-Highlight-Msg.ogg
-rw-r--r-- 1 root   root    23372 júl    6  2014 KDE-Im-Internal-Error.ogg
-rw-r--r-- 1 root   root    23595 júl    6  2014 KDE-Im-Irc-Event.ogg
-rw-r--r-- 1 root   root    23474 júl    6  2014 KDE-Im-Low-Priority-Message.ogg
-rw-r--r-- 1 root   root    22733 júl    6  2014 KDE-Im-Message-In.ogg
-rw-r--r-- 1 root   root    22724 júl    6  2014 KDE-Im-Message-Out.ogg
-rw-r--r-- 1 root   root    23299 júl    6  2014 KDE-Im-Network-Problems.ogg
-rw-r--r-- 1 root   root    23386 júl    6  2014 KDE-Im-New-Mail.ogg
-rw-r--r-- 1 root   root    28948 júl    6  2014 KDE-Im-Nudge.ogg
-rw-r--r-- 1 root   root    61621 júl    6  2014 KDE-Im-Phone-Ring.ogg
-rw-r--r-- 1 root   root    35885 júl    6  2014 KDE-Im-Sms.ogg
-rw-r--r-- 1 root   root    32643 júl    6  2014 KDE-Im-User-Auth.ogg
-rw-r--r-- 1 root   root    39958 júl    6  2014 KDE-K3B-Finish-Error.ogg
-rw-r--r-- 1 root   root    41497 júl    6  2014 KDE-K3B-Finish-Success.ogg
-rw-r--r-- 1 root   root    41892 júl    6  2014 KDE-K3B-Insert-Medium.ogg
-rw-r--r-- 1 root   root    40670 júl    6  2014 KDE-Sys-App-Error-Critical.ogg
-rw-r--r-- 1 root   root    41410 júl    6  2014 KDE-Sys-App-Error.ogg
-rw-r--r-- 1 root   root    41318 júl    6  2014 KDE-Sys-App-Error-Serious.ogg
-rw-r--r-- 1 root   root    40541 júl    6  2014 KDE-Sys-App-Error-Serious-Very.ogg
-rw-r--r-- 1 root   root    24711 júl    6  2014 KDE-Sys-App-Message.ogg
-rw-r--r-- 1 root   root    35896 júl    6  2014 KDE-Sys-App-Negative.ogg
-rw-r--r-- 1 root   root    37107 júl    6  2014 KDE-Sys-App-Positive.ogg
-rw-r--r-- 1 root   root    41382 júl    6  2014 KDE-Sys-Error-Printing.ogg
-rw-r--r-- 1 root   root    40133 júl    6  2014 KDE-Sys-File-Open-Foes.ogg
-rw-r--r-- 1 root   root    41654 júl    6  2014 KDE-Sys-List-End.ogg
-rw-r--r-- 1 root   root    40109 júl    6  2014 KDE-Sys-List-Match-Multiple.ogg
-rw-r--r-- 1 root   root    41278 júl    6  2014 KDE-Sys-List-Match-No.ogg
-rw-r--r-- 1 root   root   225872 júl    6  2014 KDE-Sys-Log-In-Long.ogg
-rw-r--r-- 1 root   root   244953 júl    6  2014 KDE-Sys-Log-In.ogg
-rw-r--r-- 1 root   root   154528 júl    6  2014 KDE-Sys-Log-In-Short.ogg
-rw-r--r-- 1 root   root    48592 júl    6  2014 KDE-Sys-Log-Out.ogg
-rw-r--r-- 1 root   root    40889 júl    6  2014 KDE-Sys-Question.ogg
-rw-r--r-- 1 root   root    40541 júl    6  2014 KDE-Sys-Special.ogg
-rw-r--r-- 1 root   root    40208 júl    6  2014 KDE-Sys-Trash-Emptied.ogg
-rw-r--r-- 1 root   root    41337 júl    6  2014 KDE-Sys-Warning.ogg
-rw-r--r-- 1 root   root     8363 júl    6  2014 KDE-Window-All-Desktops-Not.ogg
-rw-r--r-- 1 root   root     8712 júl    6  2014 KDE-Window-All-Desktops.ogg
-rw-r--r-- 1 root   root     8865 júl    6  2014 KDE-Window-Close.ogg
-rw-r--r-- 1 root   root     7977 júl    6  2014 KDE-Window-Maximize.ogg
-rw-r--r-- 1 root   root    11200 júl    6  2014 KDE-Window-Minimize.ogg
-rw-r--r-- 1 root   root    13575 júl    6  2014 KDE-Window-Move.ogg
-rw-r--r-- 1 root   root    10711 júl    6  2014 KDE-Window-Move-Stop.ogg
-rw-r--r-- 1 root   root     9959 júl    6  2014 KDE-Window-Shade-Down.ogg
-rw-r--r-- 1 root   root     9439 júl    6  2014 KDE-Window-Shade-Up.ogg
drwxr-xr-x 3 root   root     4096 jún   23  2014 LinuxMint
-rw-r--r-- 1 root   root    23314 jún   18  2014 linuxmint-gdm.wav
-rw-r--r-- 1 root   root   707756 jún   18  2014 linuxmint-login.wav
-rw-r--r-- 1 root   root   708644 jún   18  2014 linuxmint-logout.wav
drwxr-xr-x 2 root   root     4096 okt   28 19:18 purple
drwxr-xr-x 2 root   root     4096 jún   23  2014 speech-dispatcher

Though probably not relevant, you should change the ownership rights on the Borealis directory to root:

sudo chmod -R root:root /usr/share/sounds/Borealis

-----

xfconf-query -c xsettings -p /Net/EnableEventSounds
true

xfconf-query -c xsettings -p /Net/EnableInputFeedbackSoundstrue
true

xfconf-query -c xsettings -p /Net/SoundThemeName
Borealis

env | grep GTK_MODULES
GTK_MODULES=:canberra-gtk-module

cat /usr/local/bin/xfce4-session
#!/bin/bash

# run the real xfce4-session executable
/usr/bin/xfce4-session

# on exit, run my stuff
# canberra-gtk-play -f /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg
canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/Exit1_2.ogg

ls -l /usr/local/bin/xfce4-session
-rwxr-xr-x 1 root root 245 febr  24 13:54 /usr/local/bin/xfce4-session

Looks good.

-----

ToZ wrote:

And also, make sure your System Sounds are turned up in pavucontrol (the volume control indicator).

Is the system sounds volume turned up in your sound settings? Try minimizing and maximizing a window (you should hear a zoom sound).

-----

Can also try running directly:

canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/Exit1_2.ogg

...to see if your sound system is set up properly?


Missing modules are installed. Volume control is on 100%. The event sounds can be heard. Nearly total success. smile Almost everything works except logout sound. Thank you for your valuable assistance so far.

Offline

#12 2015-02-25 04:15:59

zotya62
Member
Registered: 2015-02-22
Posts: 13

Re: [Solved] XFCE system sounds

MountainDewManiac wrote:

Just an observation: I jumped through all the hoops that enabling system sounds on a previous linux Mint Xfce distro required. After approximately one week, I realized just how annoying it was when the computer made noises every time I did anything. It might be a kindness to also include instructions for disabling the system sounds for when that happens.

Regards,
MDM

Even when I used KDE desktop, me too irritated system sounds, which were installed by default. I would have a lightweight  environment so I chose XFCE. Here, however, the system sounds are missing for me. I felt it a challenge to be able to configure.

Last edited by zotya62 (2015-02-25 04:17:43)

Offline

#13 2015-02-25 04:49:14

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,058

Re: [Solved] XFCE system sounds

zotya62 wrote:

Missing modules are installed. Volume control is on 100%. The event sounds can be heard. Nearly total success. smile Almost everything works except logout sound. Thank you for your valuable assistance so far.

What happens when you run this command at the terminal:

canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/Exit1_2.ogg

Do you hear the logout Exit1_2.ogg sound file?

Offline

#14 2015-02-25 05:39:43

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,107

Re: [Solved] XFCE system sounds

I'm probably just inserting a red herring into the discussion, but is it possible that the logout sound isn't being played because the logout happens too quickly? What would happen if you configured a five second delay (if that is even possible?) into the logout routine, or a delay of whatever length the sound is (plus the "loading time" for same)?

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#15 2015-02-25 06:45:22

zotya62
Member
Registered: 2015-02-22
Posts: 13

Re: [Solved] XFCE system sounds

ToZ wrote:
zotya62 wrote:

Missing modules are installed. Volume control is on 100%. The event sounds can be heard. Nearly total success. smile Almost everything works except logout sound. Thank you for your valuable assistance so far.

What happens when you run this command at the terminal:

canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/Exit1_2.ogg

Do you hear the logout Exit1_2.ogg sound file?

Yes, I can hear it. However, /usr/local/bin/xfce4-session running in terminal this message can be read: xfce4-session: Another session manager is already running. MDM touched on it well, what could be the cause, maybe the delay.

Offline

#16 2015-02-25 11:36:32

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,058

Re: [Solved] XFCE system sounds

Possibly, though I know it works because it works here for me on the one system where I have sounds enabled. Can we try with some debug statemtents in the /usr/local/bin/xfce4-session file to see what is happening?

#!/bin/bash

echo "DEBUG: 1 Before real executable" > /tmp/xfce4-session.log
# run the real xfce4-session executable
/usr/bin/xfce4-session
echo "DEBUG: 2 After real executable" >> /tmp/xfce4-session.log

echo "DEBUG: 3 Before sound file" >> /tmp/xfce4-session.log
# on exit, run my stuff
# canberra-gtk-play -f /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg
canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/Exit1_2.ogg
echo "DEBUG: 4 After sound file" >> /tmp/xfce4-session.log

Edit to the code of that file to the above. Log out and back in again to use the new file.

Then log out once again (don't reboot) and log in again and post back the contents of /tmp/xfce4-session.log.

Offline

#17 2015-02-26 06:10:14

zotya62
Member
Registered: 2015-02-22
Posts: 13

Re: [Solved] XFCE system sounds

ToZ wrote:

Possibly, though I know it works because it works here for me on the one system where I have sounds enabled. Can we try with some debug statemtents in the /usr/local/bin/xfce4-session file to see what is happening?

#!/bin/bash

echo "DEBUG: 1 Before real executable" >> /tmp/xfce4-session.log
# run the real xfce4-session executable
/usr/bin/xfce4-session
echo "DEBUG: 2 After real executable" >> /tmp/xfce4-session.log

echo "DEBUG: 3 Before sound file" >> /tmp/xfce4-session.log
# on exit, run my stuff
# canberra-gtk-play -f /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg
canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/Exit1_2.ogg
echo "DEBUG: 4 After sound file" >> /tmp/xfce4-session.log

Edit to the code of that file to the above. Log out and back in again to use the new file.

Then log out once again (don't reboot) and log in again and post back the contents of /tmp/xfce4-session.log.

The log file was not created.

Offline

#18 2015-02-26 11:44:57

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,058

Re: [Solved] XFCE system sounds

zotya62 wrote:

The log file was not created.

What is your path?

echo $PATH

EDIT: I've made a small change to the script to ensure that the log file shows everything after you log back in again. Try this new version:

#!/bin/bash

date >> /tmp/xfce4-session.log
echo "DEBUG: 1 Before real executable" >> /tmp/xfce4-session.log
# run the real xfce4-session executable
/usr/bin/xfce4-session
echo "DEBUG: 2 After real executable" >> /tmp/xfce4-session.log

echo "DEBUG: 3 Before sound file" >> /tmp/xfce4-session.log
# on exit, run my stuff
# canberra-gtk-play -f /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg
canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/Exit1_2.ogg
echo "DEBUG: 4 After sound file" >> /tmp/xfce4-session.log

Offline

#19 2015-02-27 00:08:21

zotya62
Member
Registered: 2015-02-22
Posts: 13

Re: [Solved] XFCE system sounds

ToZ wrote:
zotya62 wrote:

The log file was not created.

What is your path?

echo $PATH

EDIT: I've made a small change to the script to ensure that the log file shows everything after you log back in again. Try this new version:

#!/bin/bash

date >> /tmp/xfce4-session.log
echo "DEBUG: 1 Before real executable" >> /tmp/xfce4-session.log
# run the real xfce4-session executable
/usr/bin/xfce4-session
echo "DEBUG: 2 After real executable" >> /tmp/xfce4-session.log

echo "DEBUG: 3 Before sound file" >> /tmp/xfce4-session.log
# on exit, run my stuff
# canberra-gtk-play -f /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg
canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/Exit1_2.ogg
echo "DEBUG: 4 After sound file" >> /tmp/xfce4-session.log

echo $PATH   /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games

With the modified script log file also  was not created.

Offline

#20 2015-02-27 01:09:18

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,058

Re: [Solved] XFCE system sounds

If /usr/local/bin is in your path before /usr/bin then this xfce4-session wrapper script should run before the real xfce4-session executable. However, since the log file is not being created, then it is not being run.

I wonder if Mint is doing something different with its Xfce startup files? Maybe specifying the exact path to to the xfce4-session executable (which is strange given that Xubuntu does not and Mint is based on Ubuntu).

For a sanity check, can you post back the current locations of the xfce4-session executables:

locate xfce4-session | grep bin

You also might want to check the Mint login manager configuration files to see if it is starting the session manager by directly specifying /usr/bin/xfce4-session as the startup session executable. And if so, change the location there to point to /usr/local/bin/xfce4-session.

Another way around this would be to (while not logged in) rename /usr/bin/xfce4-session to /usr/bin/xfce4-session.orig and move the /usr/local/bin/xfce4-session executable to /usr/bin. Also make sure that you change the location of the real executable in that file so that you don't create a loop:

#!/bin/bash

date >> /tmp/xfce4-session.log
echo "DEBUG: 1 Before real executable" >> /tmp/xfce4-session.log
# run the real xfce4-session executable
/usr/bin/xfce4-session.orig
echo "DEBUG: 2 After real executable" >> /tmp/xfce4-session.log

echo "DEBUG: 3 Before sound file" >> /tmp/xfce4-session.log
# on exit, run my stuff
# canberra-gtk-play -f /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg
canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/Exit1_2.ogg
echo "DEBUG: 4 After sound file" >> /tmp/xfce4-session.log

Just keep in mind that with this workaround, the /usr/bin/xfce4-session executable will get overwritten whenever the package is upgraded.

Offline

#21 2015-02-27 01:59:04

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,058

Re: [Solved] XFCE system sounds

Ah yes. Just downloaded the Mint ISO and I see what they are doing. They are using the alternatives system and it points directly to /usr/bin/xfce4-session:

$ cat /etc/X11/Xsession.d/55xfce4-session
# For Xfce, we add a directory to XDG_DATA_DIRS
# to allow the admin to set, for example, defaults.list properly
BASESTARTUP=$(basename "$STARTUP" | cut -d\  -f1)
if [ "$BASESTARTUP" = x-session-manager ]; then
    BASESTARTUP=$(basename $(readlink /etc/alternatives/x-session-manager))
fi
case "$BASESTARTUP" in
  xfce4-session|startxfce4)
    # We prepend /usr/share/xfce4 since its defaults.list actually points
    # to /etc so it is configurable.
    if [ -z "$XDG_DATA_DIRS" ]; then
      XDG_DATA_DIRS=/usr/share/xfce4:/usr/local/share/:/usr/share/
    else
      XDG_DATA_DIRS=/usr/share/xfce4:"$XDG_DATA_DIRS"
    fi
    export XDG_DATA_DIRS
    ;;
esac

...and:

$ ll /etc/alternatives/x-session-manager
lrwxrwxrwx 1 root root 22 Jan  7 17:24 /etc/alternatives/x-session-manager -> /usr/bin/xfce4-session

You'll either have to create a new alternative entry for x-session-manager and have it point to /usr/local/bin/xfce4-session or rename the existing /usr/local/bin executable as noted in my previous post.

Offline

#22 2015-02-27 07:35:45

zotya62
Member
Registered: 2015-02-22
Posts: 13

Re: [Solved] XFCE system sounds

ToZ wrote:

Ah yes. Just downloaded the Mint ISO and I see what they are doing. They are using the alternatives system and it points directly to /usr/bin/xfce4-session:

$ cat /etc/X11/Xsession.d/55xfce4-session
# For Xfce, we add a directory to XDG_DATA_DIRS
# to allow the admin to set, for example, defaults.list properly
BASESTARTUP=$(basename "$STARTUP" | cut -d\  -f1)
if [ "$BASESTARTUP" = x-session-manager ]; then
    BASESTARTUP=$(basename $(readlink /etc/alternatives/x-session-manager))
fi
case "$BASESTARTUP" in
  xfce4-session|startxfce4)
    # We prepend /usr/share/xfce4 since its defaults.list actually points
    # to /etc so it is configurable.
    if [ -z "$XDG_DATA_DIRS" ]; then
      XDG_DATA_DIRS=/usr/share/xfce4:/usr/local/share/:/usr/share/
    else
      XDG_DATA_DIRS=/usr/share/xfce4:"$XDG_DATA_DIRS"
    fi
    export XDG_DATA_DIRS
    ;;
esac

...and:

$ ll /etc/alternatives/x-session-manager
lrwxrwxrwx 1 root root 22 Jan  7 17:24 /etc/alternatives/x-session-manager -> /usr/bin/xfce4-session

You'll either have to create a new alternative entry for x-session-manager and have it point to /usr/local/bin/xfce4-session or rename the existing /usr/local/bin executable as noted in my previous post.

The problem is solved. The "xfce4-session" name had to be changed to the "xfce4-session-logout" So now after clicking on the logout launcher button the selected tune will sound.
Thank you for your patience. This thread was very instructive.

Last edited by zotya62 (2015-02-28 12:51:08)

Offline

Board footer

Powered by FluxBB