Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-06-26 19:09:36

thierry95
Member
Registered: 2022-06-26
Posts: 2

Dracula theme problem

Hello everyone. I installed the gtk Dracula theme, but when I go to apply it, the borders of the windows and clickable tabs disappear. As you can see in the screenshot, the options are all stuck to each other. How can I fix it?
https://ibb.co/HTnPBSR/

Offline

#2 2022-06-26 19:18:00

KBar
Moderator
Registered: 2021-11-05
Posts: 634

Re: Dracula theme problem

Hi and welcome.

EDIT:
You also need to select this in the Window Manager app for it to affect Xfwm4 SSD (server-side decorations). This should fix it.

That means:
- either the styling of those elements isn't shipped with the theme (unlikely);
- or you did not build it correctly;

We'd like to know your Xfce version and some other info:

xfce4-about --version # Xfce version
xfconf-query --channel xsettings --property /NetThemeName # run this after selecting that theme
ls -l /usr/share/themes # was the theme installed correctly?

Last edited by KBar (2022-06-26 19:26:22)


Remember to edit the subject of your topic to include the [SOLVED] tag once you're satisfied with the answers or have found a solution (in which case, don't forget to share it as well), so that other members of the community can quickly refer to it and save their time. Pretty please! tongue

Offline

#3 2022-06-26 19:50:45

thierry95
Member
Registered: 2022-06-26
Posts: 2

Re: Dracula theme problem

xfce4-about 4.16.1 (Xfce 4.16)
xfconf-query --channel xsettings --property /Netgtk-master    terminal tells me there is no ¨/Netgtk-master, gtk-master is the name of the theme
ls -l /usr/share/themes    The theme does not show up in the list, I created the theme folder in the home directory and placed it inside that folder

Offline

#4 2022-06-27 05:27:20

KBar
Moderator
Registered: 2021-11-05
Posts: 634

Re: Dracula theme problem

Please, consider using code tags. It significantly improves intelligibility.

terminal tells me there is no ¨/Netgtk-master, gtk-master is the name of the theme

I see. Sorry for the confusion. You need to run the second command as is. Just copy and paste verbatim, as in:

xfconf-query --channel xsettings --property /Net/ThemeName

Do not change anything.

Next, list the contents of ~/.themes. Again, in code tags.

Finally, you also need to select the theme in Window Manager:
xfwm4-settings-style.png


Remember to edit the subject of your topic to include the [SOLVED] tag once you're satisfied with the answers or have found a solution (in which case, don't forget to share it as well), so that other members of the community can quickly refer to it and save their time. Pretty please! tongue

Offline

#5 2022-06-27 06:21:26

StJimmy
Member
From: De Lage Landen
Registered: 2022-06-27
Posts: 5

Re: Dracula theme problem

It seems that the GTK theme is not compatible with the GTK version your system uses - the "symptoms" match up well enough, e.g. the "broken" tabs.
See if you can find which GTK versions the theme supports (likely findable on its homepage/repository), and which you actually have installed (query your package manager for that information).

GTK is sadly somewhat finnicky regarding theme compatibility between versions, sadly, so themes working for version N will not necessarily work properly on versions (N+1) or (N-1).


Nanos gigantum humeris insidentes.

Offline

Board footer

Powered by FluxBB